ivio's Avatar


04 Oct, 2018 01:22 PM


Thank you for the continuing support. After installing the FPR9 I noticed that it reset my selection of search engines to the standard. More worryingly, however, is that I can't anymore see a way to download add-ons - from Tools I am shown only the installed, but no access to the Firefox lists; when I go from Preferences < Search < Add more... I manage to access the Firefox lists, but there is no more the option to install, never mind access to older versions as was in the past. Firefox don't even recognize that I am using a browser from the family, instead it force me to download Firefox or Register/ Log In. Am I missing something or things changed for worse?

  1. 1 Posted by Raphaël Guay on 04 Oct, 2018 03:59 PM

    Raphaël Guay's Avatar


    Firefox 57 and later completely removed support for already existing add-ons and moved to Webextensions, which in turn do not work on earlier versions of Firefox (and therefore TenFourFox).

    You should see:

    if it's only search add-ons you need, you can either:

    Open preferences > tenfourfox ; then set your user agent to Firefox 60ESR (intel). Once you have installed the search add-ons you wanted from, revert the user agent to the default one immediately. Don't do this to install anything but search add-ons.


    Navigate to the domain that corresponds to the search engine you want and open the search bar's drop-down menu to install their search add-on. Comment #7 at has a screenshot of this. Not all sites have this (for example, if the search add-on was created by a third party).

    Both ways work for me.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac