TenFourFox FPR28 Cannot Connect to ANY URL after FPR29 problem

geeji's Avatar

geeji

24 Nov, 2020 10:24 AM

Hi,

I tried to update to FPR29 on OS X 10.5.8 (Cube G4), but I got the "chrome://browser/content/browser.xul" error message, because I used the wrong language pack (by this time, I did not know it was the problem...).

So I then tried to go back to FPR28, but it did not work anymore.
When starting, I would get a "Connecting..." Tab, looping forever, and it would not connect to any URL, as if there was no Internet connection.
At the same time, Safari was connecting fine to Internet (otherwise, I could not send this post).

Also, when I quitted TenFourFox, it would not quit properly, crashing after some time with 2 Console messages : "com.apple.launchd ([0x0-0x4d04d].com.floodgap.tenfourfox[431]) Exited abnormally: Bus error"

I then decided to do a "clean install", deleting all (hidden, system) files with "Firefox" or "TenfourFox" in their name. But it did not improve anything.

I am afraid I have now made a big mess of my TenFourFox install, and I apologize for that.
But is there any way to do a true "clean install" ?
I suppose I could rebuild my whole disk from scratch, but it will be quite long and painful, and I am almost sure to loose some features beyond TenFourFox.

Thanks for your help.

  1. 1 Posted by polluks on 24 Nov, 2020 04:41 PM

    polluks's Avatar
  2. 2 Posted by geeji on 25 Nov, 2020 05:52 AM

    geeji's Avatar

    Sorry if my first post was not clear enough.

    I DID (finally) read this thread.
    I DID use the proper FPR29 language package (for French).
    But it does NOT work any better, I cannot open any URL from this latest french-customized TenFourFox, I only get Tabs which show "Connecting..." forever, and TenFourFox does not properly quits, it has to be forced to quit.
    And as explained in the original post, all the workarounds I tried failed, likely messing up my system.

    Thanks for your help

  3. Support Staff 3 Posted by Chris (chtrusch... on 25 Nov, 2020 06:23 AM

    Chris (chtrusch)'s Avatar

    jj.gud/geeji, I'm posting this from TenFourFox FPR 29 with the French Langpack applied. I don't see (at the moment) how a different localization might be responsible for the problems you have.

    Generally: If you're running 10.5 on a G4 cube, you may run into all sorts of problems since that 450 or 500 MHz 7400 (?) processor isn't supposed to run anything higher than 10.4. Also, hardware failure can never be ruled out.

    Please try this:

    1) Download TenFourFox FPR 29 (zip file), but don't install it yet. Be sure to download the correct version for your processor.
    2) Quit TenFourFox
    3) Delete the TenFourFox application you just quit
    4) In the Finder, navigate to MacintoshHD>Users>your username>Library>Caches>Firefox and delete the folder 'Profiles' inside
    5) In the Finder, navigate to MacintoshHD>Users>your username>Library>Application Support and move the 'Firefox' folder to the Desktop (in case you have bookmarks etc. in there and want to keep it for later)
    6) Re-start your Mac
    7) Make sure you have a network connection
    8) Unzip TenFourFox from 1) and start the application
    9) If it works correctly, quit it. Then apply TFF-FPR29-Packlangage-Français.app
    10) Test again whether it works correctly with the langpack applied.

    If 9) fails I won't be able to help much beyond the general remarks above. If 9) works but 10) fails I will investigate if there's a bug in the langpack installer.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

20 Jan, 2021 10:49 PM
17 Jan, 2021 02:13 PM
15 Jan, 2021 09:53 PM
07 Jan, 2021 04:14 PM
06 Jan, 2021 11:01 PM