Firefox sync connexion impossible with Feature Parity 16 and17

bertrand.dekoninck's Avatar


12 Dec, 2019 10:44 AM

When trying to connect to Firefox sync on a freshly installed Leopard system with TTF FP17, signin in my firefox accounts fails and returns the following message : "No connexion. You must have an internet connexion to signin" (roughly translated from french, sorry)..

I've got the same problem on an older Leopard system when TTF FP16 was running Firefox sync happily : I've tried to disconnect and reconnect to sync and now it fails.

The signin procedure seems to have change on Firefox.
On Firefox, the signin procedure leads to this page :
On TenFourfox, the signin procedure begins at the page : about:preferences?entrypoint=menupanel#sync and when you click on signin you're sent to this page : about:accounts?action=signin&entrypoint=menupanel

I've tried to access the Firefox account connexion page with Tenfourfox, and it fails with an infinite running spinner on TTF-FP16. On TTF-FP17, I can connect to my Firefox account, but I see no way to have sync running.

  1. Support Staff 1 Posted by Cameron Kaiser on 12 Dec, 2019 09:37 PM

    Cameron Kaiser's Avatar

    I'll look into this, but please be advised in advance that Sync support is best effort only. See this FAQ entry for more information:

    If this is straightforward, I will try to repair it. However, if fixing this requires adding additional support, it is likely I would simply remove Sync support entirely.

  2. Support Staff 2 Posted by Cameron Kaiser on 21 Dec, 2019 06:21 AM

    Cameron Kaiser's Avatar

    I am able to login and connect my Firefox account with FPR17 in the Sync tab, so I can't reproduce this. I'm not sure if the difference is the locale.

    The about:preferences is a pseudo-URL and not actually what is being accessed.

  3. 3 Posted by bertrand.dekoni... on 21 Dec, 2019 10:07 AM

    bertrand.dekoninck's Avatar

    You are right : I can now connect to sync on TTF17 in the default locale (without the french locale package). And the problem remains with the french locale.

  4. Support Staff 4 Posted by Chris (chtrusch... on 21 Dec, 2019 11:51 AM

    Chris (chtrusch)'s Avatar

    I can reproduce this, but only with the French and Italian langpacks installed, no other locales. I have an idea why this may be the case (they stem from a different branch made by another contributer, while I made all other langpacks based on the German one), I'm currently investigating…

  5. Support Staff 5 Posted by Chris (chtrusch... on 21 Dec, 2019 12:10 PM

    Chris (chtrusch)'s Avatar

    I don't like uploading stuff here but I can't on Github, so there. Please test. You need to put a fresh copy of TFF FPR 17 (that was never touched by the old French langpack installer) in your Applications folder first.

  6. Support Staff 6 Posted by Chris (chtrusch... on 24 Dec, 2019 11:02 PM

    Chris (chtrusch)'s Avatar

    Italian langpack, also fixed.

  7. Support Staff 7 Posted by Cameron Kaiser on 08 Jan, 2020 02:22 AM

    Cameron Kaiser's Avatar

    These are now live on site.

  8. Cameron Kaiser closed this discussion on 08 Jan, 2020 02:22 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac