Library Logins and CAPTCHAs

Steve Graanet's Avatar

Steve Graanet

16 Sep, 2019 03:59 PM

Like a number of people here, I too have been struggling with public library logins. I often use the public wifi network of the Burbank California Public Library and have been unable to login with TenFourFox FPR 16. I end up logging in with the latest version of WebKit for Leopard (v. 604.5.6_2) instead. Intel Macs have no trouble automatically sensing the wifi network, which is usually somewhere at https://n95.network-auth.com/splash/?mac=00%3A18%3A0A%3A7B%3A09%3A00&real_ip=10.44.14.130&client_ip=10.44.14.130&client_mac=00:30:BD:90:AA:01&vap=4&a=1f1362ea41d1bc65be321c0a378a20159f9a26d0&b=3462621&auth_version=5&key=23159366a50c6775b81e12ecb719f7ee4d4245aa&acl_ver=P9377076V2&continue_url=http%3A%2F%2Fwww.bing.com%2F

But even with WebKit, I often have to plugin this cryptic url. Can that be remedied? Is there something I can do to help TenFourFox automatically sense the library's wifi network?

I've also been having trouble with CAPTCHAs. No matter what I do, it will keep asking me for more things to recognize and more things to recognize, with no end in sight. And if I go to use the audio recognition instead, it will accuss me of being some sort of process and refuse to continue. In short, I'm unable to get past any sort of CAPTCHA with TenFourFox.

  1. Support Staff 1 Posted by Chris (chtrusch... on 17 Sep, 2019 04:40 PM

    Chris (chtrusch)'s Avatar

    I cannot answer your first question, but I may have some hints for dealing with captchas. If they *never* solve for you, there's something wrong. It may take a while on some sites and you may have to find a lot of hydrants and busses and traffic lights, but eventually they should solve. The point with captchas is that it actually may not matter that much whether you click the correct images, but the way you move the mouse and target them, i.e. whether you behave like a human. If you have add-ons that prevent Google from getting this information, or make the browser so slow that it cannot transfer them fast enough, your captchas may not solve. Please try a fresh browser profile and see if the situation improves.

  2. Support Staff 2 Posted by Cameron Kaiser on 18 Sep, 2019 12:11 AM

    Cameron Kaiser's Avatar

    I agree with Chris: I haven't had an issue solving captchas with TenFourFox personally, and it usually accepts my entry in two or three tries. If you have add-ons blocking the captcha, then it will almost certainly not solve on any system.

    The first issue might be related to issue 533, because it sounds similar to a prior report that turned out to be that issue (the symptom is a line like this is undefined in your Browser Console). Unfortunately, if that's the problem, I haven't been able to come up with a solution for it because the fix was buried in a very large change to the JavaScript parser.

  3. 3 Posted by Steve on 20 Sep, 2019 09:44 AM

    Steve's Avatar

    I'm terribly sorry, but why is it regarding the library logins, that Webkit always picks up the wifi network login, but but I've never had TenFourFox do so. And Tobias Netzel stopped updating Webkit for Leopard just last year.

    And regarding the CAPCHAs. the only add-ons I've had are those I've mentioned: the Quicktime Enabler, the MP4 Enabler, the avc1Decoder, and MiG's Video DownloadHelper. There must be a better way than having to go through 10 or 15 minutes of endless images never getting past them. This never happens when I use an Intel Mac; and always happens when I use webkit as well. And even on this forum, there's an extremely simplified CAPCHA that's used instead.

    Is there a chance for progress. Many,many important websites require CAPCHAs and not being able to process them severely damages our ability to still use our PPC Macs.

    I wish you both all the best regarding these two issues and remember, we're all pulling for you and are always very grateful for how far you've come so far.

  4. Support Staff 4 Posted by Chris (chtrusch... on 20 Sep, 2019 09:38 PM

    Chris (chtrusch)'s Avatar

    Have you tried a fresh browser profile for captchas?

  5. Support Staff 5 Posted by Cameron Kaiser on 20 Sep, 2019 11:16 PM

    Cameron Kaiser's Avatar

    What Chris said, but let me also point out the bigger issue: we can't reproduce either of your issues. If we can't reproduce them, we can't fix them.

    I mentioned the telltale sign of issue 533. Did you look and see if that message appears in the Browser Console when you try to get into the WiFi? If it does, then that's what it is, and it's already on my radar. If it's not, then see if any other errors appear that might tell me what's going on because (not to put too fine a point on it) I'm not on your library's WiFi.

  6. 6 Posted by Steve Graanet on 21 Sep, 2019 07:02 PM

    Steve Graanet's Avatar

    Thank you. Regarding the library logins, I'll talk with the library's network administrator and see what I can do and come back with the information.

    And regarding the CAPCHAs, I looked up "sample capcha test" on Bing, tried them out, as well as a couple of others that I know of and found out that the problem that I've been running into is not that these CAPCHAs are impassable, but rather that they take a long time. Which i their intent in the first place. They take much longer on PPC than Intel, but they're passable. Again, thank you for the quick help.

  7. Support Staff 7 Posted by Cameron Kaiser on 21 Sep, 2019 07:42 PM

    Cameron Kaiser's Avatar

    By all means ask your library administrator, but I don't think they'd have much experience with TenFourFox (you could mention you're using the equivalent of Firefox 45 and see what they say other than "upgrade your computer"). Whatever turns up in your Browser Console would still be (possibly more) helpful.

  8. 8 Posted by Steve Graanet on 23 Sep, 2019 02:05 AM

    Steve Graanet's Avatar

    Thanks for the help Cameron. That's a lot of work you guys do.

    I'll see if I can get a hold of my library administrator.

    I didn't know that TenFourFox had a console. I just found it:

     Tools>Web Developer>Browser Console

    Shall I take a screen capture of the Browser Console when I'm at the library and add it as an attachment in one of these posts? Or is there a preferred method that you guys would like? I'm not a programmer, so I don't know about any of this. Only about how to take screen captures.

    Anyway, thank you for the great support.

  9. Support Staff 9 Posted by Cameron Kaiser on 23 Sep, 2019 05:02 AM

    Cameron Kaiser's Avatar

    Yes, a screenshot is fine, or cut and paste the text inside of it. Optimally, you should clear the Browser Console first, then try to sign on to the WiFi, then see what has newly appeared.

    You might also look at Console.app (this is an actual application usually in Applications/Utilities) to see if any messages appear there when you try.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

10 Dec, 2019 01:14 AM
04 Dec, 2019 04:47 PM
04 Dec, 2019 07:39 AM
22 Nov, 2019 03:13 AM
22 Nov, 2019 01:05 AM