UPS package tracking no longer working in TFF

rardin's Avatar

rardin

07 Jun, 2019 12:23 PM

I noticed yesterday that the UPS package tracking page no longer works in TFF FPR14 for G4 7450 on a Mac running Leopard. I'm visiting this type of URL with a tracking number inserted at the end of the string:

https://www.ups.com/track?loc=en_US&tracknum=

This lands me on the tracking page with a spinning progress wheel, but I never get a result. TFF remains responsive, but the wheel just keeps spinning. I tried disabling TFF's basic adblock yesterday and this morning I backed off to FPR10 and also tried using various user agents, all with no change in behavior. I assume UPS changed something on their end. I have no add-ons enabled. My alternative for now is to use Leopard WebKit for UPS package tracking.

  1. Support Staff 1 Posted by Chris (chtrusch... on 08 Jun, 2019 07:37 AM

    Chris (chtrusch)'s Avatar

    I can comfirm the problem, also that it works on LWK. It's another instance of issue 533 ('TypeError: this is undefined'), see
    https://github.com/classilla/tenfourfox/issues/533

  2. 2 Posted by rardin on 08 Jun, 2019 02:18 PM

    rardin's Avatar

    Thanks for confirming the issue, Chris. Issue 533 strikes again. I'm a Citi customer, so I'm already familiar with it, but didn't assume immediately that the UPS tracking issue was related.

  3. 3 Posted by guest on 25 Aug, 2019 01:13 PM

    guest's Avatar

    @rardin - is the missing menu on Citi.com also related ?

  4. 4 Posted by rardin on 25 Aug, 2019 06:26 PM

    rardin's Avatar

    Yes, but the Citi issue may have been resolved by a change on the Citi end. I'd be interested to hear another Citi customer confirm that I'm not imagining this.

  5. Support Staff 5 Posted by Cameron Kaiser on 25 Aug, 2019 09:43 PM

    Cameron Kaiser's Avatar

    Yes, they're the same underlying issue.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

12 Oct, 2019 08:21 PM
11 Oct, 2019 08:29 PM
06 Oct, 2019 03:15 PM
05 Oct, 2019 08:36 PM
02 Oct, 2019 07:53 PM