code-server Does not load

Tara K's Avatar

Tara K

27 May, 2019 07:49 PM

I thought it'd be cool to run vscode on my iBook G3 and have code-server working in Chrome and Firefox for Windows but under TenFourFox it just gives a gray screen.

I tried running in safe mode on the latest stable version but the same error comes up in the console:
SyntaxError: missing ; before statement

Obviously super low priority and just for sh*ts'n'giggles but it would be neat.

  1. Support Staff 1 Posted by Cameron Kaiser on 27 May, 2019 09:52 PM

    Cameron Kaiser's Avatar

    This is because TenFourFox's JavaScript doesn't support async/await. It does affect other sites (including Github itself) but I don't have an ETA on this; I'm not even sure it's technically possible with the runtime as written.

  2. 2 Posted by Tara K on 28 May, 2019 02:21 PM

    Tara K's Avatar

    No worries.
    I just thought it'd be funny to lug this thing to Starbucks again and do actual work on it.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • IMG_20190527_154134.jpg 241 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

16 Feb, 2020 11:02 AM
16 Feb, 2020 10:23 AM
10 Feb, 2020 03:45 PM
29 Jan, 2020 05:17 AM
28 Jan, 2020 06:00 AM