TFF freezes on some webpages.

Marek's Avatar

Marek

27 May, 2019 11:20 AM

I have this issue more often.
Everything freeze, only 'rainbow wheel' is spinning. And after a few minutes i need to use "Force Quit Applications".

I've noticed that very often when it freezes, on Status bar, I see "Waiting for fonts.googleapis.com". But not always.

  1. Support Staff 1 Posted by Chris (chtrusch... on 27 May, 2019 02:47 PM

    Chris (chtrusch)'s Avatar

    It's always helpful to add the following information to posts like these:
    a) which websites this happens on regularly
    b) which add-ons/extension are installed

  2. 2 Posted by Holly on 27 May, 2019 10:30 PM

    Holly's Avatar

    Its mainly been happening since 4/29/19 and been maddening as it occurs every time on secure sites. They keep saying it's my browser and trying to make me find other browsers. At one point I borrowed a legacy Windows 7 laptop running an old version of Chrome. It worked, so I bitched to my secure (bank) site that they must be wrong about the age of browser being the reason. I've daily checked for updates for TFF; have received 2 since 4/29/19, but it still freezes at a RECAPTCHA (google crap) window. I'll complete every obstacle, then get a frozen blank page. With my visual issues it's maddening! I'm relatively sure my add-ons (only there due to trying to make TFF emulate Chrome & IE) are not an issue in enabling the connection.

  3. Support Staff 3 Posted by Chris (chtrusch... on 28 May, 2019 04:34 AM

    Chris (chtrusch)'s Avatar

    Not to be impolite, but pretty much every website ist 'secure' nowadays (with a padlock). I need some actual URLs/links to reproduce your issues, otherwise I won't be able to diagnose the problem. You're describing all sorts of issues, let's start at the spinning beachball that necessitates a "Force Quit". On which site(s) does it happen?

    As for your bank, you can go to Preferences>TenFourFox and choose User Agent: Firefox 52 (or even 60) and try again.

  4. 4 Posted by Marek on 28 May, 2019 05:18 AM

    Marek's Avatar
  5. 5 Posted by LBHB on 28 May, 2019 06:55 PM

    LBHB's Avatar

    Chris,
    Thanks for the suggestion regarding using Firefox User Agent 52 or
    60. I tried both before responding here and neither worked. After
    being quizzed on RECAPTCHA alot, the tab header stayed this time, but
    then I just got a blank white page... no rainbow wheel or anything
    but the curser "arrow".

    I'm so completely frustrated as I've not been able to utilize ANY of
    my financial sites since 4/29/19 using my Mac. The iPad is a look
    but don't touch situation. That's why I've mainly directed my
    efforts toward getting the banks to fix it. I happened upon the
    discussion about TFF freezing yesterday and added my note which
    you've responded to.

    Sincerely,

    Holly
    vacs2graphics@q.com

  6. Support Staff 6 Posted by Chris (chtrusch... on 28 May, 2019 07:35 PM

    Chris (chtrusch)'s Avatar

    Marek, I cannot reproduce the freeze at
    https://e-legnickie.pl/wiadomosci-z-regionu/legnica/23972-33-do-4-dla-pis-w-gminach-regionu-legnickiego

    Please go to Help>Troubleshooting Information and restart with add-ons disabled. If that doesn't help, please try refreshing TenFourFox.

  7. 7 Posted by Holly on 28 May, 2019 08:16 PM

    Holly's Avatar

    https://myaccounts.bellco.org/Authentication/ValidateUsernameAndPassword

    is the site after RECAPTCHA pics.. all confirmed pics, "not a robot"; then a blank page and no action.

    I doubt you'll find that link useful, especially if you don't have an acct. Same thing happened at another banking site, only they didn't put me thru RECAPTCHA pics.
    I could copy and send that link, but same issue... you'd have to have an acct. and password entered to get to that link.

  8. Support Staff 8 Posted by Chris (chtrusch... on 29 May, 2019 04:54 AM

    Chris (chtrusch)'s Avatar

    Holly, we're getting off-topic with your problem (which is not a freeze technically), but your link is actually helpful. Using a bogus username and password I can confirm the issue. After the recaptcha it simply arrives at an empty page, it doesn't even get to validate the username/password. Nothing meaningful in the console. The same happens in Leopard Webkit, nothing in the console there, either. Does this website work at all with regular Firefox on a recent Mac?

  9. 9 Posted by Marek on 29 May, 2019 05:53 AM

    Marek's Avatar

    Runing in Safe Mode - helped. There was a little freeze but just for 15 s on "ajax.googleapis.com".

  10. 10 Posted by Marek on 29 May, 2019 06:11 AM

    Marek's Avatar

    Runing in Safe Mode - helped. There was a little freeze but just for 15 s on "ajax.googleapis.com".

    ...but then...
    ...when I've manualy disabled all add-ons — it doesn't helped :/ It still freezes :(

  11. 11 Posted by marek on 31 May, 2019 12:32 PM

    marek's Avatar

    So, what else does "Safe Mode" do (besides disabling add-ons), that freezing don't occurs?

  12. 12 Posted by LBHB on 31 May, 2019 07:54 PM

    LBHB's Avatar

    Chris, I'm thrilled that you were able to replicate my issue. Yes
    the website worked with regular FireFox on the Mac I had at work (2
    yrs. ago) and it also worked on TFF until 4/25/19 this year. I
    apologize I didn't respond very quickly... wasn't feeling well.
    These issues stress me alot and with my health issues, I have to
    avoid stress.
    Bellco's IT still says it's my browser; they sent me links to "update
    my OS" , however I've ran all update checks on both my systems (iPad
    which uses Safari 9.3.5 & this Mac which uses OS Tiger); both systems
    say no updates available. I borrowed a Windows 7 laptop to test
    access the site. It runs Chrome 7.4.0.3729.157 to test access and
    that worked fine. I responded to Bellco IT that if all works on the
    legacy Windows 7 and Chrome systems, why would they make it
    ineffective to work on Mac OS 9.3.5 (iPad) and TFF parity release
    14. I haven't received any understanding or changes from them.
    I really couldn't tell if TFF was "freezing" or if RECAPTCHA was just
    interferring. I reported it as a web forgery to Google.
    I'm disabled. It's very difficult to do what I need to do on the
    computer without the stress it incurs. I cannot afford to chase the
    technology and buy a newer system.
    I know you didn't need to know all that, however, I thought it
    relevant to the issue and certainly if it helps resolve my issue from
    a TECH perspective, please, help me if you can. Thanks!

    Holly

  13. Support Staff 13 Posted by Chris (chtrusch... on 03 Jun, 2019 10:10 PM

    Chris (chtrusch)'s Avatar

    Marek, Safe Mode also temporarily disables essential custom settings that might cause problems.

    Holly, I'm afraid there isn't much I can do to resolve your issue. There will be no OS updates for PPC Macs. Currently, no browser on PPC Macs can display that website properly. It may get fixed with a future browser update for TenFourFox or Webkit. You'll have better chances on your iPad right now – even if it cannot be updated from iOS 9, that system is less than three years old. If Safari on iOS 9 can't display the site, Bellco made a mistake in my opinion by not testing properly on systems that are still in mainstream use (and/or forgot to update their system requirements which state that iOS 8 or newer is required on mobile devices). I'd try iCab or Opera on the iPad.

  14. Support Staff 14 Posted by Chris (chtrusch... on 03 Jun, 2019 10:49 PM

    Chris (chtrusch)'s Avatar

    Holly, after further testing I found something that may be worthwhile trying:

    Go to https://myaccounts.bellco.org/ , log in, solve the captcha until you end up on the empty page. Then go to https://myaccounts.bellco.org/ again and log in. If I do this, the website now tells me my credentials are wrong, i.e. it's validating. With the right credentials you may get in (or, again, end up on the empty page).

    Please report back what happens because that information may be helpful to fix the issue. If the website itself works it may simply be a handover problem between Bellco and the Cloudflare security check.

  15. 15 Posted by Holly on 15 Jun, 2019 08:52 PM

    Holly's Avatar

    Chris,
    Thank you for your wise suggestion. That has worked so far for me this week, and I've got them scratchin''' their heads as I've reported the progress. I apologize for my untimely response here, but between my IP issues (rural area that is getting older equipment replaced by old equipment...and this is via CenturyLink as they don't want to invest in this rural area) and life in general, I was slow to try it more than once this week so I could report back to you if it worked.
    Holly

  16. Support Staff 16 Posted by Chris (chtrusch... on 16 Jun, 2019 05:53 AM

    Chris (chtrusch)'s Avatar

    Holly – great!

    Cameron, what do we make of this? I haven't seen or heard of similar problems with the Cloudflare security check and "handing over" the credentials after the check is done. Might this be on their side? I've tested this on a Windows 10 machine with regular Firefox, too, but there the Cloudflare check doesn't even appear.

  17. 17 Posted by Holly on 18 Jun, 2019 10:13 PM

    Holly's Avatar

    Chris,
    I'm having a very similar issue on a different secure site. Not sure if you can replicate it as well. I tried your work-around previously mentioned, however, even with TFF emulating FireFox intel60, it's still not accessible. I have found that using a legacy Windows 7 Chrome app, it works... which I think is bizzarre!
    Here's the link: https://secure.cuaccount-access.com/DeltaCountyFCU/ORUI/index.html

  18. Support Staff 18 Posted by Chris (chtrusch... on 19 Jun, 2019 04:32 AM

    Chris (chtrusch)'s Avatar

    What happens when you try to log in? I get as far as 'continue with security code' (which would then be texted to my mobile number which is obviously not registered with this service) without running into trouble. Do you get the Cloudflare check with Google captcha here as well?

  19. 19 Posted by Holly on 19 Jun, 2019 07:22 PM

    Holly's Avatar

    I think you got farther than I. I didn't get any Cloudfare or Recaptcha, just a blank page with 3 flashing left to right dots in thee middle of the page, the tab name disappears and so does the status bar. On one of my retries, emulating a different browser, I think it was Chrome, when I tried reentering my login and PW, then a different home screen for them opened, but still stalled the same way when I tried to re-login and PW. That website also states to me that my problem is "my browser" and that I'm "using too old of a system, I need to upgrade my equipment". I believe I've proven that wrong as I've borrowed a legacy Windows 7 laptop and via Chrome version 74.0.3729.157, have been able to access the site... but I cannot always borrow it. I sure hope you can shed some light on it for me.

  20. Support Staff 20 Posted by Chris (chtrusch... on 19 Jun, 2019 07:53 PM

    Chris (chtrusch)'s Avatar

    Holly, I can't reproduce this problem at all, I'm sorry to say I don't know how to help you with this.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

17 Jul, 2019 01:27 PM
14 Jul, 2019 05:21 PM
14 Jul, 2019 03:00 PM
14 Jul, 2019 02:51 PM
14 Jul, 2019 06:12 AM