Automatically changes default search engine after reboot

max's Avatar


11 Oct, 2016 09:23 PM

Hardware: iBook G4, Software: 10.5.8

Whenever I reboot or turn my iBook back on from being off, the search engine on TenFourFox is always Yahoo (which I change back every time to Google). I don't know why exactly this is happening, and I am not sure if it is either something from the actual browser or if it is related to my OS.

Showing page 2 out of 2. View the first page

  1. 31 Posted by Brian Szemon on 03 Dec, 2016 05:16 AM

    Brian Szemon's Avatar

    Hi their I use my machine everyday and try to help out here and may have found the solution as it was defaulting to Yahoo for me I use yahoo as my default and never came across this glitch sol I just replicated everything and may have found a solution it worked for me on 10.4.11.
    1. tenfourfox->preference->search
    2. remove google under one-click search engines
    3. click add more search engines
    4. on the add-ons page chose google default-> add to firefox
    5. back in preferences choose google as default search engine
    6. un-check provide search suggestions
    7. open new tab close out preferences tab and try a search in the address bar.
    8. if search pulled up google close browser restart and google should still be default.

  2. 32 Posted by Brian Szemon on 03 Dec, 2016 05:43 AM

    Brian Szemon's Avatar

    I worked on this for about an hour changing things in about:config before simply trying the way I found that worked. I do plan on making a YouTube video of how I did it but at last it's 0040 here and I need some rest tomorrow is another day. Try the above if it works let me know if doesn't then maybe it's a combination of this and setting i played with in about:config and I'll post them but I'm sure it's not.

  3. 33 Posted by Scott Novak on 03 Dec, 2016 05:47 AM

    Scott Novak's Avatar

    I just tried this and Google seems to remain the default search engine. So far it's working great! Thanks Brian!

    Scott Novak

  4. 34 Posted by Brian Szemon on 03 Dec, 2016 06:37 AM

    Brian Szemon's Avatar

    You are very welcome Mr. Scott Novak I'm glad with a little work I could find a fix.
     Cameron Kaiser and Chris (chtrusch) maybe we can make my fix a sticky or something to help others. I'm not a coder but maybe their is a way to take my fix and tweak some code inside the program, But this is beyond me.

  5. Support Staff 35 Posted by Cameron Kaiser on 03 Dec, 2016 07:25 PM

    Cameron Kaiser's Avatar

    Your suggestion is certainly a good workaround but I'd like to better understand what went wrong. Before anyone tries this, please look at comments 26-28 and see if Brian's steps change the files mentioned in those comments.

  6. Support Staff 36 Posted by Chris (chtrusch... on 04 Dec, 2016 08:19 PM

    Chris (chtrusch)'s Avatar

    Hard to tell if my test of this workaround makes sense because here in Europe, Google is the default search engine anyway, while in the US it's Yahoo.

    search-metadata.json still doesn't exist in a fresh profile and isn't created by any of the actions taken as described in the workaround.

    After taking the steps described in the workaround, "Google Default" seemed to stick as the default search engine. However, after I had I applied my own STR, at the next restart "Google Default" had vanished and "Google", which I had previously deleted, was set as the default engine again.

  7. 37 Posted by Scott Novak on 04 Dec, 2016 10:53 PM

    Scott Novak's Avatar

    Also note that I rechecked "Provide search suggestions" and Google still remains as my search engine when I restart Tenfourfox.

    For now all is well.


  8. 38 Posted by Terrence J. Doy... on 19 Dec, 2016 02:04 AM

    Terrence J. Doyle's Avatar

    I created a new profile and found the same behavior that the others report: The default search engine reverts to Yahoo once TenFourFox is restarted. My old profile is able to retain Google as a default search engine except for the occasional appearance of a random search engine that I reported earlier.

    Here are the results of my investigation into this matter:

    My old profile contains the file, search-metadata.json, and in prefs.js the following two lines are present:

    user_pref("", "US");
    user_pref("", "Google");

    After creating the new profile it did not contain search-metadata.json, and of the two lines in the old profile's prefs.js the new profile's prefs.js contained only the line:

    user_pref("", "US");

    After starting TenFourFox with the new profile and changing the default search engine to Google there were no pertinent changes in the profile's directory -- no search-metadata.json and prefs.js was still missing:

    user_pref("", "Google");

    However, upon quitting TenFourFox the defaultenginename line appeared in prefs.js. There was still no search-metadata.json. I had not made any actual searches before quitting.

    With the next start of TenFourFox the default search engine reverted to Yahoo, but the defaultenginename line with Google remained in prefs.js. But then I did a search with the default engine (Yahoo), and the defaultenginename line disappeared from prefs.js. The line did not come back after quitting. After several rounds of restoring defaultenginename with Google to prefs.js and doing a search it became clear that executing a search removes the defaultenginename line from prefs.js.

    Next, I copied search-metadata.json from my old profile to my new profile and started TenFourFox with the new profile. The defaultenginename line was absent from prefs.js. This time Google was the default engine at start-up. And, defaultenginename with Google had been restored to prefs.js. What's more, executing a search did not remove defaultenginename from prefs.js. After another restart of TenFourFox with my new profile Google remained as the default search engine. However, as I wrote in my previous message, Google continues to prompt with instructions to set Google as the default search engine even though it is the default search engine.

    As a final test I removed search-metadata.json from my new profile and started TenFourFox again. Sure enough, the default search engine reverted to Yahoo.

    So, the problem really seems to be that setting a default search engine through TenFourFox->Preferences does not create search-metadata.json. In case it matters, here's the contents of search-metadata.json from my old profile:


    All that text was on one line. E-mail clients will undoubtedly mess it up.

                        Terrence Doyle

    On 12/3/16 1:25 PM, Cameron Kaiser wrote:
    pre { width: 92%; margin: 10px 2%; padding: 5px 2%; background: #efefef; border: 1px solid #d6d6d6 } blockquote { margin-left: 0; padding-left: 1em; border-left: 5px solid #ccc; }

    // Please reply above this line

    From: Cameron Kaiser (Support staff)

    Your suggestion is certainly a good workaround but I'd like to better understand what went wrong. Before anyone tries this, please look at comments 26-28 and see if Brian's steps change the files mentioned in those comments.

    On Fri, Dec 02 at 10:37 PM PST, Brian Szemon wrote:

    You are very welcome Mr. Scott Novak I'm glad with a little work I could find a fix.
     Cameron Kaiser and Chris (chtrusch) maybe we can make my fix a sticky or something to help others. I'm not a coder but maybe their is a way to take my fix and tweak some code inside the program, But this is beyond me.

    Having trouble reading this? View this discussion online: Automatically changes default search engine after reboot.

    Reply with #ignore to stop receiving notifications for this discussion.

  9. Support Staff 39 Posted by Cameron Kaiser on 21 Dec, 2016 10:46 PM

    Cameron Kaiser's Avatar

    Terrence, that is very helpful. To others experiencing the problem, if you recreate the file from an old profile, does that fix it for you also? If so, I think I have a good guess what went wrong now.

  10. Support Staff 40 Posted by Chris (chtrusch... on 22 Dec, 2016 01:42 PM

    Chris (chtrusch)'s Avatar

    I cannot confirm this, sadly. I can still reproduce the bug using my STR when an old search-metadata.json is present in a new profile. The file doesn't even get touched when I change the engine.

  11. Support Staff 41 Posted by Chris (chtrusch... on 22 Dec, 2016 02:21 PM

    Chris (chtrusch)'s Avatar

    What is touched, however, is search.json.mozlz4, as soon as I switch the engine. It's also the last thing in the profile that's written to in the startup sequence if the engine has been changed during the last session.

    If I change the engine, then quit TFF, then duplicate this file and rename the duplicate search.json.mozlz4.tmp (else TFF would create the temp file if it sees that it cannot write to search.json.mozlz4 at startup), then *lock* both of these files, then start TFF, the changed search engine sticks even when I use my STR repeatedly.

    Therefore the engine must be saved in search.json.mozlz4 and be overwritten somehow at startup with the default engine.

  12. 42 Posted by Brian Szemon on 23 Dec, 2016 12:48 AM

    Brian Szemon's Avatar

    Did not work for me ether, Although Chris's fix dose work so everything would seem to point at that "search.json.mozlz4" file being overwritten somehow after restart.

  13. Support Staff 43 Posted by Cameron Kaiser on 23 Dec, 2016 08:40 AM

    Cameron Kaiser's Avatar

    The LZ4 connection does make sense: we already know that the LZ4 module doesn't work properly on PowerPC for some reason (bookmark backups, for example).

  14. Support Staff 44 Posted by Cameron Kaiser on 30 Mar, 2017 03:54 PM

    Cameron Kaiser's Avatar

    I made a speculative fix to the beta version of 45.9 that goes with that theory (that LZ4 is responsible). Chris can no longer replicate this problem with this build. I'd appreciate others testing it, since none of our local test systems show the issue and I have no other way of verifying this is actually the problem.

  15. 45 Posted by Terrence J. Doy... on 03 Apr, 2017 09:11 PM

    Terrence J. Doyle's Avatar

    I tried 45.9-beta with a new profile. This time Google stuck as my
    default search engine. So, the problem really seems to be fixed.
    However, Google still pops up an annoying box saying, " Get to Google
    faster. Switch your default search engine to Google." Maybe we need to
    explain the fix to Google :).

    Terrence Doyle

  16. Support Staff 46 Posted by Cameron Kaiser on 03 Apr, 2017 11:15 PM

    Cameron Kaiser's Avatar


    Just remember that this is the same company that wants us all to switch to Chrome, and then says our systems aren't supported. 8-)

  17. 47 Posted by Dan Handelman on 19 Jun, 2017 01:50 AM

    Dan Handelman's Avatar

    We're still having this problem in 45.9 but it only started happening recently. Did anyone come up with a comprehensive way to fix this? BTW I'm trying to set the default to DuckDuckGo which doesn't have a "Default" engine like Google does.
    dan h
    portland or

  18. 48 Posted by Terrence J. Doy... on 20 Jun, 2017 09:16 PM

    Terrence J. Doyle's Avatar

    The fix is in 45.9. I'm using Google as the default, but it hasn't
    strayed since I installed Cameron's fix.

        I'm not quite sure what you mean by DuckDuckGo "doesn't have a
    'Default' engine like Google does." DuckDuckGo is just another choice
    among search engines which can be set as your default search engine. If
    you've truly set DuckDuckGo as your default search engine, and the
    setting reverts to Yahoo, try creating a new profile. Then, if setting
    your default search engine to DuckDuckGo sticks in the new profile, your
    old profile may be corrupt.

                        Terrence Doyle

  19. 49 Posted by Erik on 25 Jun, 2017 08:17 PM

    Erik's Avatar

    I'm still experiencing this on FPR 1. Same configuration as OP: iBook G4, 10.5.8

    Nothing makes search settings save; every time I close TFF and re-open, it's back to Yahoo Search. This occurs even when I delete all search engines from the "One-click search engines" list and add in "Google (Default)" as the sole search engine.

    Something is making this browser restore the default list of One-click search engines every time it launches.

    If there's a workaround or a file I can make read-only to force the settings to save, please let me know; otherwise, I think this issue just needs to be investigated further.

  20. Support Staff 50 Posted by Cameron Kaiser on 26 Jun, 2017 03:01 AM

    Cameron Kaiser's Avatar

    Just a reminder for people: as the release notes for 45.9 said, where the speculative fix was first deployed, you may need to start with a clean profile for the setting to stick -- for some users their profile was not able to be automatically fixed and we don't know why. You can try creating a clean profile with the profile manager and seeing if that works (see the FAQ for instructions). If it does, export your bookmarks and any necessary settings and add-ons and load them into the new profile. If it doesn't, please note that here, though I don't have other suggestions right now and I've still never been able to replicate it on the test systems.

  21. 51 Posted by Scott Novak on 26 Jun, 2017 04:28 AM

    Scott Novak's Avatar

    I installed 45.9.0 and I was able to set Google as my search engine without any problems. I haven't had any problems.
    Powerbook G4 1.5 GHZ 10.5.8


  22. 52 Posted by max on 26 Jun, 2017 01:06 PM

    max's Avatar

    How ironic that my AirPort WiFi card went kaput before the patch for the bug was released. Glad I reported the bug though, and glad it's working (at least to my understanding).

  23. 53 Posted by RocketRancher on 30 Jul, 2017 03:29 AM

    RocketRancher's Avatar

    Thanks to all for working these threads on the search pref.
    Just rolled to 45.9.0 (G5/quad, 10.5.8) with existing profile and all is well.

  24. 54 Posted by Michael on 12 Dec, 2017 05:27 PM

    Michael's Avatar

    I am having this problem again in FPR 4. TenFourFox defaults to Yahoo every time it is restarted, in spite of having the Default Search Engine add-on installed and set to Google, and in spite of having google set as my default search engine in Preferences!

    Machine Info:
    Model Name: Power Mac G4
    Model Identifier: PowerMac3,6 Processor Name: PowerPC G4 (3.3) Processor Speed: 1.25 GHz Number Of CPUs: 2 L2 Cache (per CPU): 256 KB L3 Cache (per CPU): 2 MB Memory: 2 GB Bus Speed: 167 MHz Boot ROM Version: 4.4.8f2 Serial Number (system): XB40905UQ6P Hardware UUID: 00000000-0000-1000-8000-000A95CFC548

  25. Support Staff 55 Posted by Chris (chtrusch... on 18 Dec, 2017 06:50 PM

    Chris (chtrusch)'s Avatar

    Michael, I think you're seeing a different problem. What we had originally was the browser changing the default engine by itself (i.e. no related add-ons installed), and this problem has been fixed. I cannot replicate the old bug with FPR4.1 using the STR I posted in this thread. Please try uninstalling the add-on you're using and then set up the default engine again. If this doesn't work you may have to resort to what's described in comment #50.

  26. 56 Posted by Joey on 05 Apr, 2018 02:55 AM

    Joey's Avatar

    I'm using the latest version of TFF, FPR6 (SPR1). On Max OS X 10.4.11 on a powerbook G3 in the United States. This just happened to me, it reverts to yahoo after tenfourfox is opened. I replicated it twice.

  27. Support Staff 57 Posted by Chris (chtrusch... on 06 Apr, 2018 07:37 PM

    Chris (chtrusch)'s Avatar

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac