Automatically changes default search engine after reboot

max's Avatar

max

11 Oct, 2016 09:23 PM

Hardware: iBook G4, Software: 10.5.8

Whenever I reboot or turn my iBook back on from being off, the search engine on TenFourFox is always Yahoo (which I change back every time to Google). I don't know why exactly this is happening, and I am not sure if it is either something from the actual browser or if it is related to my OS.

  1. Support Staff 1 Posted by Chris (chtrusch... on 13 Oct, 2016 06:01 AM

    Chris (chtrusch)'s Avatar

    Hello, we've discussed this during an earlier development stage:

    http://tenfourfox.blogspot.com/2016/08/453-beta-1-available.html

    …but didn't come to a conclusive answer except that it may be Mozilla's problem. I'll investigate this further today.

  2. Support Staff 2 Posted by Chris (chtrusch... on 13 Oct, 2016 08:10 AM

    Chris (chtrusch)'s Avatar

    There are lots of bugs in Bugzilla related to inadvertent switching of the the search engine, but I couldn't find any recent ones related to our exact problem. I can still reproduce this reliably with TFF 45.5.0b1 (fresh user profile): Default engine for me (Europe) is Google per Mozilla's policy. Switching the engine to Yahoo and then re-starting the browser, the engine is again at Google. However, I am unable to reproduce this with Firefox 45.4 ESR running on 10.7.

  3. Support Staff 3 Posted by Cameron Kaiser on 13 Oct, 2016 01:32 PM

    Cameron Kaiser's Avatar

    It may well be that the systems I have here don't have a combination subject to this change internally, since I still can't reproduce it. I'll see if I can find the code that determines the default and just short-circuit it.

  4. Support Staff 4 Posted by Cameron Kaiser on 14 Oct, 2016 03:18 AM

    Cameron Kaiser's Avatar

    Well, it's pretty hairy. It looks like there is some browser code for trying to determine the region and proceeding appropriately, but I'm having trouble sorting this all out. Maybe we should see which regions are affected and go from there.

  5. 5 Posted by Scott Novak on 18 Oct, 2016 06:41 AM

    Scott Novak's Avatar

    I'm having a similar problem. I select Google as the default browser, but every time I quit TFF and reopen it the browser reverts to Yahoo. I tried deleting TFF as well as an old version of Firefox and all of the Mozilla files that I could find. I reloaded TFF version 45.4,0 and the problem remains. There are no add-ons of any kind.

    I'm running a 15" Powerbook G4 1.5 GHZ with OS 10.5.8.

  6. Support Staff 6 Posted by Cameron Kaiser on 18 Oct, 2016 01:29 PM

    Cameron Kaiser's Avatar

    Without means to reproduce I can't do anything about this locally without some more clues. Scott and Max, please also post your country of use. So far the only thing in common is that these are Leopard systems.

    To future reporters, if you find this thread and post to it, please include your OS and your country.

  7. Support Staff 7 Posted by Chris (chtrusch... on 18 Oct, 2016 03:38 PM

    Chris (chtrusch)'s Avatar

    I just tested this, and I cannot reproduce it on 10.4, either. But still very reliably on 10.5. But… why? (Sorry, I should have tested against 10.4 right in the beginning.)

  8. 8 Posted by Scott Novak on 18 Oct, 2016 07:04 PM

    Scott Novak's Avatar

    I'm in Minneapolis, Minnesota, USA.

    TenFourFox 45.4.0

    System Version: Mac OS X 10.5.8 (9L31a)
    Kernel Version: Darwin 9.8.0

    Hardware Overview:
    Model Name: PowerBook G4 15"
     Model Identifier: PowerBook5,6
     Processor Name: PowerPC G4 (1.2)
     Processor Speed: 1.5 GHz
     Number Of CPUs: 1
     L2 Cache (per CPU): 512 KB
     Memory: 1 GB
    Bus Speed: 167 MHz
    Boot ROM Version: 4.9.1f1

  9. Support Staff 9 Posted by Cameron Kaiser on 18 Oct, 2016 11:30 PM

    Cameron Kaiser's Avatar

    I have a working theory as to why this only affects Leopard, but I need a couple more data points.

  10. 10 Posted by herminio.hernan... on 21 Oct, 2016 05:55 PM

    herminio.hernandezjr's Avatar

    I am seeing this and am running Tiger and Leopard on the following machines using 45.5b2

    Model Name: iBook G4
    Model Identifier: PowerBook6,7
    Processor Name: PowerPC 7447a G4
    Processor Speed: 1.42 GHz
    OS Version: Mac OS X 10.4.12

    Model Name: PowerBook G4
    Model Identifier: PowerBook5,6
    Processor Name: PowerPC 7447a G4
    Processor Speed: 1.67 GHz
    OS Version: Mac OS X 10.4.12

    Model Name: PowerMac G5
    Model Identifier: PowerMac7,2
    Processor Name: PowerPC 970 G5 (x2)
    Processor Speed: 2.0 GHz
    OS Version: Mac OS X 10.5.8

  11. 11 Posted by Peter S on 22 Oct, 2016 03:02 AM

    Peter S's Avatar

    I'm having this same issue. I'm running TenFourFox 45.4.0 on an iMac PowerMac 4,5 running 10.4.11. I'm in Minnesota, USA. I have tried re-installing TenFourFox, and deleting the profile, but no dice.

  12. Support Staff 12 Posted by Cameron Kaiser on 22 Oct, 2016 05:07 AM

    Cameron Kaiser's Avatar

    Then the Leopard theory is out the window, and I have no idea what's going on with the affected systems right now.

  13. Support Staff 13 Posted by Cameron Kaiser on 22 Oct, 2016 05:07 AM

    Cameron Kaiser's Avatar

    Also, Herminio, you did not include your country of usage.

  14. 14 Posted by herminio.hernan... on 22 Oct, 2016 06:57 AM

    herminio.hernandezjr's Avatar

    I am in the US.

  15. Support Staff 15 Posted by Chris (chtrusch... on 22 Oct, 2016 07:03 AM

    Chris (chtrusch)'s Avatar

    Another factor is probably the processor specific build. I can reproduce the problem on my PB G4 10.5 running the correct 7450 version [edit: also with 7400]. I cannot reproduce it running the G3 version on that same hardware/OS. (Both of my 10.4 systems are G3s.)

  16. Support Staff 16 Posted by Chris (chtrusch... on 22 Oct, 2016 08:01 AM

    Chris (chtrusch)'s Avatar

    My STR are:
    0. quit TFF
    1. move the Firefox folder from Application Support to the Desktop
    2. start TFF, don't import anything & continue
    3. press cmd + , to open preferences, click on Search
    4. in the Default Search Engine dropdown, switch from the first option to the second one (whatever that is in your country)
    5. Re-start TFF twice (!) right away using cmd + Q
    6. press cmd + , to open preferences, click on Search

  17. 17 Posted by Peter S on 22 Oct, 2016 02:27 PM

    Peter S's Avatar

    Just tried that, no luck. I'm using the 7450 version if that helps.

  18. 18 Posted by Peter S on 22 Oct, 2016 02:56 PM

    Peter S's Avatar

    The problem doesn't seem to occur on my iBook G3, though. I think you are correct as to it only affecting a couple specific builds.

  19. 19 Posted by max on 23 Oct, 2016 03:15 PM

    max's Avatar

    Location: Ohio, USA
      Model Name: iBook G4
      Model Identifier: PowerBook6,7
      Processor Name: PowerPC G4 (1.5)
      Processor Speed: 1.33 GHz
      Number Of CPUs: 1
      L2 Cache (per CPU): 512 KB
      Memory: 512 MB
      Bus Speed: 133 MHz
      Boot ROM Version: 4.9.3f0

  20. Support Staff 20 Posted by Cameron Kaiser on 23 Oct, 2016 04:22 PM

    Cameron Kaiser's Avatar

    I'm not sure it's the build version, because my 7450 iMac G4 seems unaffected.

  21. Support Staff 21 Posted by Chris (chtrusch... on 23 Oct, 2016 05:01 PM

    Chris (chtrusch)'s Avatar

    There must be a difference between the G3 and the 7450/7400 builds plus something special in the OS X installation on my PowerBook that together triggers the bug.

  22. Support Staff 22 Posted by Chris (chtrusch... on 23 Oct, 2016 08:39 PM

    Chris (chtrusch)'s Avatar

    I took a spare external Firewire hard drive, connected it to my PB G4, partitioned it, and installed both 10.4 and 10.5 from scratch. I can reproduce the bug with the 7450 version (on both OSes), but not with the G3 version.

    I can reproduce the bug if the machine has no network connection at all.

    I was also able to reproduce it on my parents' eMac 1.0 GHz G4 running 10.5.

    The funny thing is that the bug is only triggered at the second re-start after the search preference has been set.

  23. 23 Posted by Raphaël G. on 23 Oct, 2016 09:56 PM

    Raphaël G.'s Avatar

    This bug affected me only once, but if it can help:

    QC, Cananda
    TFF45.5.0b2 (7450)
    PowerMac3,5 (First Quicksilver model)
    2 x 1.6Ghz 7447A
    Running 10.4.11

    I tried to reproduce the behaviour after reading this, but seems like it'll only happen once.

  24. 24 Posted by Peter S on 07 Nov, 2016 05:43 PM

    Peter S's Avatar

    It's been a while, so have any solutions been found? I haven't really been able to mess around with tff because I need to get a USB wifi adapter first. It's a pain lugging an iMac upstairs to the modem.

  25. Support Staff 25 Posted by Chris (chtrusch... on 12 Nov, 2016 08:07 AM

    Chris (chtrusch)'s Avatar

    Is there anything I can do or provide (logs, tests etc.) to help fixing this? I can still reproduce it reliably.

  26. Support Staff 26 Posted by Cameron Kaiser on 12 Nov, 2016 06:35 PM

    Cameron Kaiser's Avatar

    I don't have any current theories and I still don't have any systems affected.

    Currently this is going to need someone on an affected system who is able to debug it themselves. I have a new theory that the LZ4 cache for searches could be affected in the same way as they are for bookmark backups, but I'm not going to test that theory for 45.5.0 (possibly the first 45.6 beta). Even if this is the problem it may require some users to do a profile reset. If someone wants to play with this theory, see toolkit/components/search/nsSearchService.js.

  27. Support Staff 27 Posted by Cameron Kaiser on 12 Nov, 2016 06:37 PM

    Cameron Kaiser's Avatar

    (And this theory doesn't explain why my systems aren't affected and why G3 systems also seem unaffected, but it's probably buggy anyway.)

  28. Support Staff 28 Posted by Cameron Kaiser on 12 Nov, 2016 06:44 PM

    Cameron Kaiser's Avatar

    Actually, one thing does come to mind. What are the contents of search-metadata.json in your profile folder? (You can open this from Help > Troubleshooting Information, go to Profile Folder, click Open In Finder; open the highlighted folder and drag search-metadata.json to TextEdit.) Does this seem to match what you've selected? When it resets, does this file change?

  29. Support Staff 29 Posted by Chris (chtrusch... on 12 Nov, 2016 08:05 PM

    Chris (chtrusch)'s Avatar

    I don't see this json file in the newly created profiles I use for testing, but they still exhibit the problem.

    I do have that file in my regular TFF-45 profile. It was last changed March 7 2014 (I carried this profile over from the very beginning of TFF), but on this profile I cannot reproduce the bug using my STR.

  30. 30 Posted by Terrence Doyle on 03 Dec, 2016 03:24 AM

    Terrence Doyle's Avatar

    I'm having problem with the default search engine, but it isn't as consistent as the others describe. I've set my default search engine to Google. Occasionally I get a random search engine instead of Google. When I do get Google (which is most of the time), Google keeps giving me the instructions for setting my default search engine to Google. Google never gave the instructions before the switch to Yahoo as the factory default.

    One possible reason for the random search engine could be that my mouse cursor may be hovering over the drop-down list of search engines when I hit the return key. If that's the case, I'll have to say that I don't like the mouse-over "feature". But, that's a bone to pick with Firefox, not TenFourFox.

    Anyway, here's my info:

      Model Name: Power Mac G5
      Model Identifier: PowerMac7,2
      Processor Name: PowerPC 970 (2.2)
      Processor Speed: 1.6 GHz
      Number Of CPUs: 1
      L2 Cache (per CPU): 512 KB
      Memory: 2 GB
      Bus Speed: 800 MHz
      Boot ROM Version: 5.1.5f2
      Serial Number (system): YM3379SJNVQ
      Hardware UUID: 00000000-0000-1000-8000-000A95A5ABB0

    Location: Wisconsin

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

05 Jun, 2021 04:48 PM
16 May, 2021 10:29 PM
10 May, 2021 06:33 AM
08 May, 2021 07:24 PM
05 May, 2021 06:18 AM