Web site repeatedly crashes TenFourFox

Howard Peters's Avatar

Howard Peters

11 Oct, 2016 05:52 PM

Using TenFourFox7450 version 45.4.0:

Entering "macsales.com" into the search bar, which resolves to "https://www.macsales.com", which then starts to load the page but crashes the browser every time.

Here is relevant text from my console log:

Oct 11 12:39:44 Howards-Computer crashdump[4493]: Exited process crashed
Oct 11 12:39:44 Howards-Computer crashdump[4493]: crash report written to: /Library/Logs/CrashReporter/Exited process.crash.log
2016-10-11 12:39:59.977 firefox[4494] *** _NSAutoreleaseNoPool(): Object 0x40dde0 of class NSCFNumber autoreleased with no pool in place - just leaking

Here is relevant text from firefox.crash.log:

Host Name: Howards-Computer
Date/Time: 2016-10-11 04:18:36.328 -0500
OS Version: 10.4.11 (Build 8S165)
Report Version: 4

Command: firefox
Path: firefox
Parent: WindowServer [3180]

Version: ??? (???)

PID: 4185
Thread: Unknown

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x03612034

Backtrace not available

Unknown thread crashed with PPC Thread State 64:
  srr0: 0x0000000001776608 srr1: 0x000000000000f030 vrsave: 0x0000000000000000
    cr: 0x42000024 xer: 0x0000000000000000 lr: 0x0000000001776608 ctr: 0x00000000900013a0
    r0: 0x0000000001776608 r1: 0x00000000f2717a10 r2: 0x00000000a0001fa4 r3: 0x0000000000000000
    r4: 0x0000000000000000 r5: 0x0000000000010063 r6: 0x00000000ffffffff r7: 0x0000000000016e03
    r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x00000000a000c0c8 r11: 0x00000000f2717a10
   r12: 0x00000000900013a0 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
   r16: 0x0000000000000000 r17: 0x0000000000000000 r18: 0x0000000000000000 r19: 0x0000000000000000
   r20: 0x0000000000000000 r21: 0x0000000000000000 r22: 0x00000000f2717cd0 r23: 0x000000000000010d
   r24: 0x00000000f2717b60 r25: 0x0000000020898130 r26: 0x00000000f2717cd0 r27: 0x0000000024962690
   r28: 0x00000000f2717ba0 r29: 0x0000000000000000 r30: 0x0000000003612000 r31: 0x00000000017765b8

Binary Images Description:

Any further information needed? Please email me, I'll do my best to provide it.

  1. 1 Posted by Brian Szemon on 11 Oct, 2016 06:31 PM

    Brian Szemon's Avatar

    Hi their I was able to load this site up and browse it without the browser crashing. Have you tried loading this site in firefox safe mode? If so you might want to try and and reset your profile instructions can be found here --> https://tenfourfox.tenderapp.com/kb/general/how-to-reset-your-profile If none of these options helps I'm out of ideas and maybe someone else can help.

  2. Support Staff 2 Posted by Chris (chtrusch... on 11 Oct, 2016 07:19 PM

    Chris (chtrusch)'s Avatar

    I can't reproduce the crash, either.

  3. Support Staff 3 Posted by Cameron Kaiser on 12 Oct, 2016 02:14 AM

    Cameron Kaiser's Avatar

    Nor here (also 10.4.11). The crash is a null pointer exception, which can sometimes occur when the system is out of memory. How much RAM do you have?

  4. 4 Posted by Howard Peters on 12 Oct, 2016 05:31 PM

    Howard Peters's Avatar

    Thanks for your efforts, everyone. I appreciate your support and the
    unpaid hours you guys spend doing your work on this project!

    My machine is a Quicksilver (SP, was 867 Mhz, now with 1.47 Ghz
    accelerator), which has 1.5 Gb RAM, the maximum for that particular
    machine. I can't understand how my earlier Gigabit Ethernet machine,
    which I reluctantly declared obsolete due to power supply issues,
    could take 2 Gb, and this later machine maxes out at less.

    I spent some time testing using the suggestions and questions you sent:

    1) Quit every other app but TenFourFox, to make sure it wasn't a RAM
    problem. (Though I thought you weren't supposed to have RAM problems
    with OS X, it is supposed to swap RAM to disk, right?)
    2) Reset profile via shortcut.
    3) Reset profile via manual method.
    4) Tried TenFourFox Safe Mode.
    5) Restarted computer after clearing Login Items, then reintroduced
    them one at a time.

    In all cases above the crash at "macsales.com" continued to happen

    6) Restarted the computer in its Safe Mode. Which took a very long
    time to boot, unlike the normal boot which is pretty fast.

    In this one instance, the crash DIDN'T happen.

    I'm stymied. Unless I have a bad memory problem? I just ran the
    memtest utility, which reported nothing, but it only tested the top
    898 Mb and there is no way to test the rest without physically
    swapping memory modules, at least I believe that to be true. Maybe I
    can find time to do this later.

    Generally this software behaves very well and I really appreciate
    having a secure browser for OS 10.4.11. I use it for all my
    financial and health stuff. I still use the old Safari for such
    things as looking at YouTube videos (now that MacTubes is apparently
    defunct) and visiting a few known safe daily sites of no particular

    The only other crashes I have ever had from TenFourFox are, once in a
    while, using the "Safe as PDF" function in the Print dialog. This is
    extremely random, happens less than 1 in 20 uses of this function.

    At this point, this "macsales" crash will remain a mystery and I will
    have to just borrow my wife's laptop when I wish to visit Other World

  5. Support Staff 5 Posted by Cameron Kaiser on 13 Oct, 2016 04:58 AM

    Cameron Kaiser's Avatar

    Although OS X is indeed supposed to swap to disk, an application can still run out of virtual memory. In 32-bit mode (which is what your G4 runs in), applications have a little over 2GB of space before they exhaust their address range. It's difficult but definitely possible for TenFourFox to suck up that amount of virtual memory, but it would need a pathological site and macsales seems to be fine on this 1.25GB, 1GHz iMac G4. So RAM is probably not the issue. However, you also said:

    6) Restarted the computer in its Safe Mode. Which took a very long time to boot, unlike the normal boot which is pretty fast.

    In this one instance, the crash DIDN'T happen.

    Please clarify: safe mode reliably fixes it, or it just didn't crash one time when in safe mode?

    If the latter, I'm not sure what to add.

    If the former, that tells us something important. Safe mode disables certain non-system fonts, system extensions, kernel extensions, startup items and login items. Although TenFourFox doesn't install any of these itself, it interacts with some aspects of the operating system at a very low level to get around bugs Apple never fixed. These aspects are often the same ones such extensions attempt to patch or hook into.

    The fact that it doesn't crash in safe mode says one (or some?) of those items is conflicting with TenFourFox. Unfortunately, figuring out which one(s) is/are the offender(s) is going to be a tedious process, like debugging extensions on Mac OS 9. You might start with disabling login items in System Preferences and then see what kexts or other extensions you have installed. If you find the offender, please let us know. It might be something we can work around if we can reproduce the problem locally.

  6. 6 Posted by Howard Peters on 13 Oct, 2016 05:31 PM

    Howard Peters's Avatar

    I have already tried removing the Login Items, with no success.

    I rebooted in safe mode, went to macsales, browsed the site for Intel
    Mac Pros that I won't be buying any time soon, went to some other
    sites, visited macsales again a couple more times, and all was well.
    In the instances in normal mode where macsales does crash the
    browser, it always happens within about 15 seconds of the initial
    page load.

    I have 225 kexts in my /System/Library/Extensions folder. But most
    of these, fortunately, aren't actually used.

    In safe mode I used kextstat to see what kexts I had installed, 64.
    Saved the list. Rebooted in normal mode, kextstat revealed 89 kexts
    installed. Saved that list too.

    A brief comparison of the two lists of kexts revealed only 5 third-
    party kexts in normal mode.

    Here are the relevant lines for these:

    Index Refs Address Size Wired Name (Version) <Linked
        27 1 0x73c000 0x4000 0x3000
    com.firmtek.driver.Sil3112DeviceNub (5.1.3) <26 16 11>
        28 0 0x740000 0x13000 0x12000
    com.firmtek.driver.FT_ATA_Sil3112 (5.1.3) <27 26 16 11>
        77 0 0x75b000 0x5000 0x4000
    com.Cycling74.driver.Soundflower (1.3.1) <66 11>
        88 0 0x4bab0000 0x37000 0x36000
    com.midiman.driver.MAudioDelta (1.2.1) <66 16 11>
        89 0 0x4bbe2000 0x37000 0x36000
    com.midiman.driver.MAudioDeltaHT (1.2.1) <66 16 11>

    Of these, the firmtek pair are for a serial ATA hard disk interface I
    have installed in this computer. Soundflower is installed via Audio
    Hijack Pro to be able to snag sounds from some apps. The midiman
    pair are for my M-Audio Delta digital audio and midi PCI card.

    All other kexts have "com.apple" in their names. But this probably
    does not remove them from suspicion?

    So, I haven't ever done kext unloading, but google has revealed how
    to do it. I haven't ever fiddled with low-level system stuff like
    that. There is a certain amount of trepidation involved. So should
    I try unloading the firmtek pair first, then Soundflower, then the
    midiman pair to see if these are involved in the problem?

    If I do this and it doesn't change anything, then I can generate a
    list of the "com.apple" kexts that are not installed when in safe
    mode and try unloading each of these. It would only be another 20
    items, so I can probably do it. My only concern is somehow screwing
    stuff up big time, causing permanent damage. Is this possible? Or
    would I just have to reboot with no harm done?

    I will make a complete backup using Carbon Copy Cloner first, while
    awaiting your reply.

  7. Support Staff 7 Posted by Cameron Kaiser on 14 Oct, 2016 01:55 AM

    Cameron Kaiser's Avatar

    If the firmtek driver is your hard disk, definitely do not unload that, and com.apple.* drivers should "just work."

    However, Soundflower has shown up before in crash logs. I actually use Ambrosia WireTap for that purpose. I'd probably look into uninstalling that and seeing if that fixes the problem before I look at any others.

    I've attached the output of kextstat from this G5 so you have a point of comparison. Note this is a G5 instead of your G4, so the device drivers loaded will be a bit different.

  8. 8 Posted by Howard Peters on 14 Oct, 2016 03:13 PM

    Howard Peters's Avatar


    I had something called Instant Hijack installed, also courtesy of
    Audio Hijack Pro, and I'm not sure why I had installed both it and
    Soundflower. I uninstalled Instant Hijack, and macsales loaded and
    stayed loaded.

    An apparent added bonus is that when I thought to try a different
    page that had been loading excruciatingly slowly for me (I walked
    away, and a half hour later the page was still not loaded
    completely), it loaded at normal speed. I had just chalked this up
    to fancy stuff being done by modern web page designers and my poor
    ol' G4 couldn't keep up! Somehow that damned Instant Hijack was
    causing problems with a browser. Seems a bit mysterious.

    Well' I'm glad that's solved. I did reinstall Soundflower and it's
    not causing me any difficulties. That I'm aware of.

    Now just one more little thing...sorry!

    A completely repeatable phenomenon that I'm experiencing with some
    web sites, I'll just use "icloud.com" as an example. When I try to
    log into it, with TenFourFox, I get cascading alerts about Bad Font
    Detected. (Screen shot attached). This is also a problem I've had
    using my ancient Safari 4.1.3 (on a few other web sites), so it's not
    specific to any one browser. But it does prevent me from logging
    onto icloud.com at all with this G4, I have to use a modern intel

    Do you know of any way to work around this? (There's of course no
    System Font in my system). There's no font named System Font in the
    intel macbook either, but when you list every font it definitely
    shows up as one of the available fonts. I guess System Font may be
    some sort of font alias that actually resolves to Helvetica Neue or
    some such looking font.

  9. Support Staff 9 Posted by Cameron Kaiser on 16 Oct, 2016 05:21 AM

    Cameron Kaiser's Avatar

    Those fonts are not on your system; they're being downloaded from Apple, but there are attributes about it Apple Type Services in 10.4 (and, for that matter, 10.5, except the browser usually crashes in that case) doesn't like.

    The error is harmless on Tiger but annoying. However, it is much more problematic on Leopard, so we have a built-in blocklist for fonts that do this. I'll update it for the next version of TenFourFox. For now, if you must get into iCloud from your Power Mac, go to about:config and search for gfx.downloadable_fonts.enabled, and set it to false (set it back to true when you're done).

  10. Support Staff 10 Posted by Chris (chtrusch... on 16 Oct, 2016 06:28 AM

    Chris (chtrusch)'s Avatar

    Interestingly, https://www.icloud.com/ loads just fine on 10.5. I get a lot of font warning messages in console.app, but that's it.

  11. Support Staff 11 Posted by Cameron Kaiser on 17 Oct, 2016 03:48 AM

    Cameron Kaiser's Avatar

    The font blocklist update is now tracked as issue 330: https://github.com/classilla/tenfourfox/issues/330

  12. Support Staff 12 Posted by Cameron Kaiser on 13 Nov, 2016 03:11 AM

    Cameron Kaiser's Avatar

    This has been repaired in 45.5.0, which is now available as a release candidate on http://tenfourfox.blogspot.com/ .

  13. Cameron Kaiser closed this discussion on 13 Nov, 2016 03:11 AM.

  14. Howard Peters re-opened this discussion on 13 Nov, 2016 09:18 PM

  15. 13 Posted by Howard Peters on 13 Nov, 2016 09:18 PM

    Howard Peters's Avatar

    Hi, well, I tried 45.5.0 and no longer get the cascading Bad Font
    Detected messages, so much praise is to be heaped upon you.

    I still can't log onto icloud.com because after entering user name
    and password, it goes to a screen with a large, blank white box over
    the background. Using my wife's Intel laptop with the current Mac
    OS, I see that this is a dialog demanding that I update my Apple ID,
    which is disparaged because it does not have a capital letter. After
    about 30 seconds, it returns to the login screen.

    I would guess that this is a roadblock created by Apple to lock
    dinosaur users like me out of icloud.com. (Fortunately, I can still
    receive and send emails at my .mac, .me, .icloud addresses using my
    creaky old Mail.app, but who knows how long they will let that go
    on.) Later, I'll borrow the wife's computer again, when she's not
    using it, and will actually update my Apple ID (pain in the neck,
    arbitrary, un-necessary IMO) to see if I can get further into
    icloud.com using this old Power PC.


  16. Support Staff 14 Posted by Cameron Kaiser on 14 Nov, 2016 01:19 AM

    Cameron Kaiser's Avatar

    This is likely not a problem specific to TenFourFox -- a cursory Google search indicates that "white box" pops up on other systems. For example,


    Unfortunately, I don't use icloud, so I can't really suggest further advice other than to see if other computers will load it.

    I'm going to close this ticket since both of the original items are dealt with and I prefer one issue per ticket to make it easier for people to find and participate in discussions. If you have a new issue to report, feel free to open a new one.

  17. Cameron Kaiser closed this discussion on 14 Nov, 2016 01:19 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac