TFF 31.0 has killed Zotero!!

Bob Hughes's Avatar

Bob Hughes

24 Jul, 2014 09:46 PM

Hi - I've just installed TFF 31.0 - and my referencing/bibliography tool, Zotero, has vanished, along with the several hundred items in th bibliography I've been building up while writing my book, which I have to finish in the next couple of weeks! This is a really bad problem and could not have happened at a worse time.

Is there a fix? If no fix, what can I do to salvage the bibliography database?

I'm on an Aluminium G4 Powerbook, running Tiger (of course!).

All the best,

Bob Hughes

  1. Support Staff 1 Posted by Chris (chtrusch... on 24 Jul, 2014 10:09 PM

    Chris (chtrusch)'s Avatar

    Hello Bob, I would advise you to use TenFourFox 24.7.0 for the time being and wait until your bibliography add-on has been updated to work with 31.

  2. Support Staff 2 Posted by Cameron Kaiser on 25 Jul, 2014 12:05 AM

    Cameron Kaiser's Avatar

    Bob, what do you mean by "vanished"? We certainly didn't do anything to disable it on purpose. Does it still appear in Tools > Add-ons?

  3. 3 Posted by Bob Hughes on 25 Jul, 2014 07:46 AM

    Bob Hughes's Avatar

    It doesn't appear in Add-ons - in fact, I don't seem to have any add-ons any more.

    I tried re-installing Zotero from their site - after which it appears as an extension (extensions are disparaged?!!), and none of my references are there.

    By searching in Finder, I find I've got a folder on the desktop called Old Firefox Data (see screenshot), which seems to contain all my add-ons - and an enormous (381MB) Zotero folder. I've attached a screenshot of the folder contents with sizes. The bulk of it is a folder called 'Storage' which contains well over 100 other folders containing mostly graphics, from what I can see. Crazy.

    Presumably I could re-link the extension to this folder somehow (if I knew which of the various files to link to, and if the extension is OK to use).

    I assume 24.7.0 is my best bet? Can you give any particular guidance on doing that, so that nothing's lost?

  4. Support Staff 4 Posted by Cameron Kaiser on 25 Jul, 2014 09:34 PM

    Cameron Kaiser's Avatar

    Bob, that folder is usually generated after a profile reset. Did you run that anytime recently? It is a backup of what was in your profile at that time (check the modification date on it and the files inside). Since a profile reset will remove your addons, that would actually explain both findings. The profile reset does try to keep your bookmarks and history, so that would not be affected.

    I don't see the screenshot, but you can try replacing (keep a backup of everything, including the old folder, first!) the contents of your current profile folder with the old one, keeping in mind this might remove or reset bookmarks or cookies stored between now and then. Make sure you match like for like, i.e., splice it in correctly at the right point in the filesystem. If you're unsure, a quick listing of the backup and your Library/Application Support/Firefox folder would help.

  5. 5 Posted by Bob Hughes on 26 Jul, 2014 09:02 AM

    Bob Hughes's Avatar

    Cameron, should I install 24.7.0 before doing this, or could I
    continue with 31?

    I can't recall doing a profile reset (don't exactly know how that's
    done) but could there have been an OK button somewhere during install
    that I clicked inadvertently?

    I'll give all this a try, after making backups. Many thanks.


  6. 6 Posted by Bob Hughes on 26 Jul, 2014 09:30 AM

    Bob Hughes's Avatar

    That worked! Thanks!

  7. Support Staff 7 Posted by Cameron Kaiser on 26 Jul, 2014 03:30 PM

    Cameron Kaiser's Avatar

    Profile Reset is hard to kick off by accident and it would have asked you several prompts. I don't have any other explanation about how this happened unless every single one of your add-ons are incompatible with 31. (By the way, it's plugins that are, to borrow your term, "disparaged" -- extensions and add-ons are perfectly okay).

    It would be better to move you onto 31, because there won't be any more updates to 24 -- I don't have the resources to maintain two completely separate stable versions, and Mozilla will end 24ESR support in a few months generally anyway.

    What I suggest, before trying 31 again, is the following:

    • Make sure all of your add-ons are up-to-date, including Zotero.
    • Back up the Library/Application Support/Firefox folder.
    • Start 31. See what survives.

    If it fails, then stop 31, restore the backup Firefox application support folder, and return to 24.7.0. However, I can't imagine what could be breaking it -- I certainly didn't do anything specific, and updating to 31 was specifically to improve our compatibility with add-ons in the future.

  8. 8 Posted by Bob Hughes on 02 Dec, 2014 10:47 AM

    Bob Hughes's Avatar

    Hi Cameron,

    I've had the same problem again, twice, and I assume the problem must
    be with Zotero. In response to the reminder at the bottom of the
    browser window ("looks like you've not used TFF for a while ..." etc)
    I reset TFF (13.2 - will upgrade later today but one thing at a time)
    and when it came back all my paraphernalia were gone again. I
    repopulated the Profiles folder with the contents dumped in the Old
    Firefox Data folder, and all seems OK now.

    Have you tested Zotero? I am sure it's a problem on their side but it
    would be great if you could have a think about possible fixes. (And
    if you can't, maybe it's worth you knowing about it).

    I assume the problem is that Zotero accumulates such an enormous
    amount of data: snapshots, pngs, gifs and even pdfs along with the
    bibliographic data. Its folder (in Profiles) contains a Storage
    folder, which in turn contains 478MB of data in 232 folders.

    A cull would seem in order, but I'm wary of going in headlong.

    All the best,

    Bob Hughes

  9. Support Staff 9 Posted by Cameron Kaiser on 02 Dec, 2014 02:53 PM

    Cameron Kaiser's Avatar

    I've tried it briefly, but I'm undoubtedly not using it in the way you are. I should also mention that, in general, add-ons are on a best-effort basis, just as they are for the regular Firefox. We try to get everything working that works with Firefox, but there are technical limitations with the platform and certain add-on types. I'm not aware of Zotero being in that category, but perhaps things have changed.

    That does sound like a substantial amount of data, however, and I would not be surprised if that trips bugs in either the platform or Zotero itself. However, Zotero probably wants nothing to do with a non-standard rebuild of Firefox, and I don't know enough about its code to make you any suggestions. A careful cull with backups does seem a reasonable next step because at least you know you can get back to a known good state.

  10. 10 Posted by Ken Young on 15 Jan, 2015 07:34 PM

    Ken Young's Avatar

    I think I'm having the same or similar problem, on a G5PPC, running the current TFF version, and Zotero 4.0.25x. When I opened Zotero, none of my items appeared, and instead I got a message, "Loading items list...." but they never loaded. This seems to have occurred right after the Zotero add-on automatically updated to 4.0.25x. I sent in a report and Report ID and got the response from TFF support, "Yeah, this works in standard Firefox 31 ESR. If it's not working for you, that's an issue with TenFourFox." They suggested that I revert to Zotero and turn off auto-updating of add-ons. This works, but obviously, is a temporary fix to buy a little time.

  11. 11 Posted by Ken Young on 15 Jan, 2015 08:21 PM

    Ken Young's Avatar

    I've been asked by Zotero support to add some relevant comments they made about this particular problem, as well as a link to the message thread in the Zotero forum, so that TFF support has a better idea of where the problem is:
        [JavaScript Error: "Zotero.Utilities.trim(...).normalize is not a function" {file: "chrome://zotero/content/xpcom/search.js" line: 117}]

    Yeah, this works in standard Firefox 31 ESR. If it's not working for you, that's an issue with TenFourFox.

    No, there's no reason a new profile should be any different. Zotero 4.0.25 uses a new function that was introduced in Firefox 31. If it's not working for you, the TFF version of Firefox 31 is incomplete.

  12. Support Staff 12 Posted by Cameron Kaiser on 16 Jan, 2015 12:43 AM

    Cameron Kaiser's Avatar

    As Zotero support correctly points out, this is probably not related to Bob's issue.

    The next step is to disable the JIT and see if that corrects it. You can do that by going into about:config (it's a URL you type), find javascript.options.baselinejit in the list, and double click it, which will turn it to "false." Restart the browser (performance will be somewhat worse, but this is merely for testing purposes). See if the issue is corrected.

  13. 13 Posted by Ken Young on 16 Jan, 2015 05:44 PM

    Ken Young's Avatar

    Nope! Using TFF 31.4.0 and Zotero (both latest) in OSX 10.5.8.

  14. Support Staff 14 Posted by Cameron Kaiser on 17 Jan, 2015 06:08 AM

    Cameron Kaiser's Avatar

    In that case, unfortunately I don't have any other suggestions for you. I don't use Zotero and don't have any personal insight into its workings. normalize() is implemented in TenFourFox; Zotero support is actually wrong about where the problem lies. The problem is that the object being referenced appears to be null. Although I believe Zotero when they say it works fine with regular ESR 31, without a reliable minimal test case, determining the problem will require substantial work on my part and candidly that isn't likely to occur for some time.

    I can only recommend staying with the old version for as long as it serves you. The JavaScript subsystem is being rewritten for 38 and possibly that may fix whatever problem exists as part of the same process. If you discover the issue yourself, I will of course accept a patch.

  15. 15 Posted by Kenneth Young on 17 Jan, 2015 06:40 PM

    Kenneth Young's Avatar

    Cameron, thank you. For now, I'll keep the old Zotero version, which
    seems to work fine, and if it eventually breaks, I'll live without it.
    Just part of the cost of not keeping up with the latest machines. I do
    appreciate all the work you guys are doing on TFF.

  16. 16 Posted by Nathan on 08 Mar, 2015 02:52 AM

    Nathan's Avatar

    Thanks for this discussion. I came here looking for a solution to a problem very similar to Ken's problem above: I upgraded to TFF 31.5.0 and upgraded to the latest version of Zotero simultaneously, and Zotero broke (in my case, I could no longer save web pages to Zotero). Installing an older version of Zotero ( fixed the problem for me. I will stay with the older version of Zotero until TFF 38, and then I will test the latest version of Zotero again.

  17. Support Staff 17 Posted by Cameron Kaiser on 01 Aug, 2015 08:54 PM

    Cameron Kaiser's Avatar

    The problem is now better understood: the internationalization support introduced in 31 which Zotero requires is not currently compatible with TenFourFox (the browser cannot build if it is enabled). I am trying to fix this issue, but for 38 I put a stub in which emulates just enough to seem to make Zotero happy. I do not use it, however, so I can't determine if this is enough to get it working for everyone here. Please try 38 beta 2; see this blog post:

    If the add-on still fails, the idea is to get ICU building in a later release of 38, which should fix the problem completely.

  18. 18 Posted by Nina on 09 Sep, 2015 09:07 AM

    Nina's Avatar

    Any news?

    Hi there!
    I recently updated to 38 and this actually killed it for me. No combination of Zotero version and Tenfourfox version could fix it. I reverted to on older version of Zotero and I think an older version of Tenforfox (sorry, not in reach of my Ibook). This let me pull the server side saved bibliographies but I couldnt add anything. I get an error message and nothing is saved on the server. Trying beta also did nothing. :(

    I really need Zotero as migrating to a different service would be too much of a hassle (too many bibliographies and at least 3 machines with different OSs).

  19. Support Staff 19 Posted by Cameron Kaiser on 09 Sep, 2015 03:21 PM

    Cameron Kaiser's Avatar

    In that case, unfortunately I don't have any other suggestions for you. I don't use Zotero and can't really evaluate it further than I have. Please note that add-on compatibility is always best-effort only and not guaranteed.

    When ICU support is complete (there is no ETA for this), then it may be worth trying again.

  20. 20 Posted by Nina on 10 Sep, 2015 12:32 PM

    Nina's Avatar

    @Cameron Kaiser
    Thank you for that ultra fast response!

    Don't worry. You guys gave my old machine some purpose. I can't thank you enough for the great work. I will try to get it to work once more but I guess I'm migrating to Linux. The isssues are building up in the last few months as many programs are no longer maintained for our little dinosaurs...

    Again, thank you for the great work!

  21. 21 Posted by Bob Hughes on 22 Dec, 2015 11:36 AM

    Bob Hughes's Avatar

    Hi - What's up? The link to doesn't connect. Is it
    something I did, or is there a problem your end? Been this way for a
    few days now.


    Bob Hughes

    Phone (La Condamine): 0033 4 92 66 60 06
    Mobiles UK: 0044 7968 292499 France: 0033 6056 41599 * Mail:
    [email blocked]
    Personal site: | No One Is Illegal:

  22. Support Staff 22 Posted by Cameron Kaiser on 22 Dec, 2015 03:23 PM

    Cameron Kaiser's Avatar

    I'm not sure what to tell you, but I checked on three external networks I have access to and connects just fine.

    You can connect directly to which is where it redirects, but the address is preferred in case I need to move the hosting off my personal server in the future.

  23. 23 Posted by Bob Hughes on 22 Dec, 2015 03:34 PM

    Bob Hughes's Avatar

    Thanks, that worked.


  24. 24 Posted by Bob Hughes on 28 Jan, 2016 07:10 PM

    Bob Hughes's Avatar

    Dear Cameron,

    Just a line to say that I really like FoxBoxes. I''ve set one up for
    consulting Google Books, which I'm continually needing to access to
    check facts and quotes for the book I'm writing, and which otherwise
    bungs up the browser in an unhealthy way. This is ideal, and for the
    first time I am actually using 'My Library'; it somehow makes sense
    in this context.

    Virtuous stuff.

    All the best,

    Bob Hughes
    Phone (La Condamine): 0033 4 92 66 60 06
    Mobiles UK: 0044 7968 292499 France: 0033 6056 41599 * Mail:
    [email blocked]
    Personal site: | No One Is Illegal:

  25. Support Staff 25 Posted by Cameron Kaiser on 29 Jan, 2016 01:28 AM

    Cameron Kaiser's Avatar

    You're welcome. The foxbox idea was designed exactly for that sort of "obnoxious" (technically speaking) web site, so good to hear it fulfills that purpose for you as well.

  26. 26 Posted by kennethy4 on 29 Aug, 2016 11:31 PM

    kennethy4's Avatar

    I've given TFF 45.3 beta and the latest Zotero,, some light use for the past 2 days and haven't noticed any problems.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac