Mycroft Project Search Plugins not installing

Kevin J. Macdonald's Avatar

Kevin J. Macdonald

22 Jan, 2013 07:57 PM

Hi!

I've "written" some search plugins using the Mycroft opensearch generator and installed them onto my friend's iBook G4 without any issue and they work fine. I came home and tried to install them into my TenFourFox on my (very early model) G5 and received this message:

"You will need a browser which supports OpenSearch to install this plugin."

So I quit TenFourFox and tried AuroraFox, thinking that maybe it was some sort of plug-in issue. Same response.

Both machines are running 10.5.8 and the latest versions of TenFourFox (for their respective CPU), AuroraFox, and TenFourBird.

What am I missing?

KJ

  1. Support Staff 1 Posted by Cameron Kaiser on 23 Jan, 2013 01:59 AM

    Cameron Kaiser's Avatar

    How did you "try to install it"?

    Also, what version of Firefox was on the iBook?

  2. 2 Posted by Mycroft Project on 15 Feb, 2013 07:59 PM

    Mycroft Project's Avatar

    To see that message:
    (typeof window.external == "object") && ((typeof window.external.AddSearchProvider == "unknown") || (typeof window.external.AddSearchProvider == "function")) is evaluating as FALSE...

    Can you evaluate those typeof statements and let me know what you see.
    I suspect I could improve the test...

    (Separately I'm having some server trouble... hope to resolve soon)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

24 Feb, 2020 06:33 PM
20 Feb, 2020 06:12 PM
20 Feb, 2020 01:36 AM
16 Feb, 2020 11:02 AM
16 Feb, 2020 10:23 AM