Crash on page

Hauke Fath's Avatar

Hauke Fath

17 Dec, 2020 09:05 AM

First, as always, thank you for your work!

Trying to load <> on FPR 24 and 30 crashes TFF. The page does load on Camino. ;)

  1. 1 Posted by M-A Moldu on 17 Dec, 2020 05:28 PM

    M-A Moldu's Avatar

    Hi everyone (and yes thanks for the great work ;D)

    I just want to add that I experienced the same thing yesterday (on a different thread on - almost immediate crash.
    First with FPR29, then I upgraded to FPR30 with the same result. I also tried opening a tab with the google cache link instead which also crashed the app <> = boom!.

    TFF is the G5 version in my case.


  2. Support Staff 2 Posted by Chris (chtrusch... on 17 Dec, 2020 08:24 PM

    Chris (chtrusch)'s Avatar

    Confirmed. Will look into this later tonight.

  3. Support Staff 3 Posted by Chris (chtrusch... on 17 Dec, 2020 08:46 PM

    Chris (chtrusch)'s Avatar

    No correlation to ion or baselinejit. Doesn't crash with JS disabled. Crashes on other discussion threads as well, but doesn't crash on

  4. Support Staff 4 Posted by Cameron Kaiser on 18 Dec, 2020 11:27 AM

    Cameron Kaiser's Avatar

    This is the same as and seems to be a null pointer issue.

    I won't be able to do further analysis on this until my G5 is back in order. If someone wants to try to get a backtrace with a debug build with full symbols, that would help.

  5. Support Staff 5 Posted by Chris (chtrusch... on 24 Dec, 2020 11:36 AM

    Chris (chtrusch)'s Avatar

    I still don't know how to do a full backtrace. Maybe the information in the logs helps?

  6. Support Staff 6 Posted by Chris (chtrusch... on 24 Dec, 2020 11:42 AM

    Chris (chtrusch)'s Avatar

    Disabling javascript.options.asyncfuncs doesn't help.

  7. Support Staff 7 Posted by Cameron Kaiser on 24 Dec, 2020 11:47 AM

    Cameron Kaiser's Avatar

    You'd run the debug build in the TenFourFox debugger: (under Running and debugging)

    At the point it crashes, which may be earlier if an assertion fails, wait for the (gdb) prompt to reappear, and then do bt full. We should do this in a debug build so that we can see if any earlier trouble spots appear before the crash.

  8. Support Staff 8 Posted by Chris (chtrusch... on 26 Dec, 2020 10:05 AM

    Chris (chtrusch)'s Avatar

    I'm sorry, even installing the debugger is currently beyond my abilities. HowToBuildFPR says "Decompress and copy the binary to /usr/local/bin/gdb7". What's "the binary"? When I download gdb768-104fx-4.tar and decompress it, I get a folder of stuff, not a single binary.

  9. Support Staff 9 Posted by Cameron Kaiser on 26 Dec, 2020 11:08 PM

    Cameron Kaiser's Avatar

    Sorry, it should say decompress and build. I thought you already had it. No worries if you don't. I'll do this when I'm back up and running.

  10. Support Staff 10 Posted by Chris (chtrusch... on 27 Dec, 2020 03:44 PM

    Chris (chtrusch)'s Avatar

    That makes more sense.

    I have XCode 3.1.4 and built the debugger from the gdb-768 archive, then installed it to /usr/local/bin/gdb7. The binary is 3.7MB. Is this correct? I have close to zero experience with building in the terminal, and the instructions in the README files are a bit misleading.

    Maybe we can continue this elsewhere, but when I cd to, run 'gdb7 firefox' and hit 'run' at the 'gdb' prompt, I get 'Unable to find Mach task port for process-id 91361: (os/kern) failure (0x5)'. Running the gdb version that came with XCode works, however.

  11. 11 Posted by Kimo B. Yap on 11 Jan, 2021 07:54 AM

    Kimo B. Yap's Avatar

    I will see if I can build the debug version.

    I can verify it fails in safe mode, and even in normal mode, but with javascript disabled on the page through the NoScript extension. I was trying this page, (fwiw):

  12. Support Staff 12 Posted by Cameron Kaiser on 20 Jan, 2021 10:49 PM

    Cameron Kaiser's Avatar

    I have the G5 repaired and analysed the issue. This is, unfortunately, another instance of issue 621:

    I will try to temporarily disable the offending script at the URL level. Maybe I can get a better idea of how to fix it from this one.

  13. 13 Posted by Kimo B. Yap on 19 Feb, 2021 05:24 AM

    Kimo B. Yap's Avatar

    I guess your comment means this isn't fixed. It did seem much better, but this one does still crash it:

  14. Support Staff 14 Posted by Chris (chtrusch... on 27 Feb, 2021 05:51 PM

    Chris (chtrusch)'s Avatar

    Cameron, I can reproduce the crash locally with the dump from Google Cash. I discovered M-A Moldu's message from Dec. 17 today in the spam and restored it because I tought it might be interesting. I attached the html plus folder with JS/CSS.

  15. Support Staff 15 Posted by Chris (chtrusch... on 27 Feb, 2021 06:12 PM

    Chris (chtrusch)'s Avatar
  16. Support Staff 16 Posted by Cameron Kaiser on 03 Mar, 2021 03:46 AM

    Cameron Kaiser's Avatar

    The reduced didn't quite work, but I was able to do it with the first archive and pare it down. I'm still investigating. Thanks for doing that (no promises, of course, as stated).

  17. 17 Posted by M-A Moldu on 04 Mar, 2021 02:30 AM

    M-A Moldu's Avatar

    Thanks for resuscitating my message from the spam doom...

    Kidding aside; if I get this straight, as a workaround for the moment, disabling Javascript gets rid of that problem from a user's POV?

    Again, thanks a lot to you guys...

  18. Support Staff 18 Posted by Cameron Kaiser on 04 Mar, 2021 02:36 AM

    Cameron Kaiser's Avatar

    Unless something else has changed, it shouldn't crash in FPR30 SPR2. But disabling JavaScript entirely will also work around it.

  19. 19 Posted by kby+tenfourfox on 04 Mar, 2021 05:46 AM

    kby+tenfourfox's Avatar

    I will give it a try. Thanks.-kby

    Sent from my iPad

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac