discord problem

kevmo's Avatar

kevmo

27 Apr, 2019 06:56 AM

hello:

I have a discord server account and amazingly have been able to access discordapp.com with no trouble since I began using TFF.
the other day when I click on my bookmark I should login automatically, but for some reason I can't get in at all, just a black page.
I'm able to access from my PC so the account is still active.

My best guess is they performed some update maybe.

I have a console screenshot - any ideas?

  1. 1 Posted by kevmo on 27 Apr, 2019 07:00 AM

    kevmo's Avatar

    I forgot to mention if I just goto discordapp.com I can see the start page - but I can't access the account

  2. Support Staff 2 Posted by Chris (chtrusch... on 27 Apr, 2019 09:26 AM

    Chris (chtrusch)'s Avatar

    This may be issue 533, but I'm not sure.
    https://github.com/classilla/tenfourfox/issues/533
    If so, it should work in Safari 5 (Leopard Webkit).

  3. 3 Posted by kevmo on 27 Apr, 2019 10:25 AM

    kevmo's Avatar

    no it will crash Safari 5 (Leopard Webkit).

    I don't understand why it worked since august 2018 and now it does not.

  4. Support Staff 4 Posted by Chris (chtrusch... on 28 Apr, 2019 10:17 AM

    Chris (chtrusch)'s Avatar

    I created a test account at discordapp.com. Logging into https://discordapp.com/activity I also get the black screen, but I'm not getting the "this is undefined" JS error which might lead to issue 533 you're seeing. So it may be something else.

    I can log in with Safari/LWK (r226588) just fine, no crash.

    I'm pretty sure – as you've been able to log in until recently – that they introduced something at the front end which we don't support (yet).

  5. 5 Posted by kevmo on 28 Apr, 2019 10:44 AM

    kevmo's Avatar

    thanx for taking a look see.

    I have the current webkit/Safari - I can get to the home page and I get a splash screen but after that crash, and it won't even get that far with my account link, crash.

    glad to see the "yet" - that would be cool if you could fix it,
    but you've done so much as it stands

    thanx
    k

  6. Support Staff 6 Posted by Cameron Kaiser on 07 May, 2019 02:53 AM

    Cameron Kaiser's Avatar

    I can reproduce. The errors I get in a debug build are

    JavaScript error: https://discordapp.com/assets/87e7808498f9654b9557.js, line 1: SyntaxError: missing = in const declaration
    JavaScript error: https://discordapp.com/assets/87e7808498f9654b9557.js, line 1: SyntaxError: missing = in const declaration
    JavaScript error: https://discordapp.com/assets/87e7808498f9654b9557.js, line 1: SyntaxError: missing = in const declaration

    There is a construct in the code "for(const n in this.payload)" which is probably https://github.com/classilla/tenfourfox/issues/541 . The solution there was very hacky and I chose not to implement it at the time since it didn't clearly fix anything, but I can reconsider it for FPR15 (too late for 14). However, no guarantees, since there may be other broken things that this just unmasks.

    This was a front end change for sure, btw.

  7. 7 Posted by kevmo on 13 May, 2019 06:49 AM

    kevmo's Avatar

    hello again

    an update (sort of) - I was importing some bookmarks into Safari WK on a whim I tried the imported Discord link and it went thru. Then I clicked on the field to reset my password and in TFF accessed the email and clicked the reset button, and it opened Discord and informed me I reset my password - again just a black screen. :-(

    BUT it did work and I was able to login with Safari WK.

    so some progress, I'm guessing that b4 I copy/paste the link and Safari didn't like that and crashed - still not sure.

    win some lose some

    k

  8. 8 Posted by kevmo on 13 May, 2019 07:32 PM

    kevmo's Avatar

    well, that didn't last long.
    back to crashing again...
    :-(

  9. 9 Posted by kevmo on 14 May, 2019 08:39 AM

    kevmo's Avatar

    ok now this is getting weird - seems Discord WK only works very early after midnight not during the day ?

    wtf

  10. 10 Posted by kevmo on 24 May, 2019 05:44 AM

    kevmo's Avatar

    the latest Discord attempt on G5 Feature Parity Release 14

  11. 11 Posted by kevmo on 29 Jul, 2019 03:36 PM

    kevmo's Avatar

    Hello

    It seems to be working again, for a few days now.

    so far so good...

    thanx

  12. Support Staff 12 Posted by Cameron Kaiser on 29 Jul, 2019 09:38 PM

    Cameron Kaiser's Avatar

    I'm glad to hear it, though undoubtedly they reverted to the old page source for some other reason, so I would not be surprised if it were a temporary phenomenon. :(

  13. 13 Posted by Jan Tremmel on 12 Sep, 2019 10:19 AM

    Jan Tremmel's Avatar

    I have the problem with Discord, that TenFourFox does not reognize the mic or the speaker. It says that version 38 or higher is required. My TenFourFox has version 45 in reality and version 60 (emulation). Both modes do not except the Mic and the speakers and refer to a newer FireFox-version, that I already have with TenFourFox FPR16. Keyboard typing is so heavy instead of hearing and speaking...Any suggestions?

  14. 14 Posted by kevmo on 13 Sep, 2019 11:30 AM

    kevmo's Avatar

    hello

    yeah it's still working here,
    but I use it for music stuff, I never tried the mic or anything else really.

    I think most of that is off anyway, but I'll take a look at it when I get a chance.

    k

  15. 15 Posted by kevmo on 21 Sep, 2019 05:00 AM

    kevmo's Avatar

    oh well - stopped working again today...

  16. 16 Posted by kevmo on 03 Dec, 2019 09:33 AM

    kevmo's Avatar

    Discord is working again ...

    but for how long ?

  17. 17 Posted by Widar8472 on 04 Dec, 2019 07:39 AM

    Widar8472's Avatar

    Oh yes. Discord works but without support of speakers and mics. A higher Firefox-version is required. AFAIK actually 68 is possible to configurate in TFF17. 70 is the actual version of Firefox. Discord says, that a more modern version is required. Hmmm.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Picture_1.png 297 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

04 Dec, 2019 04:47 PM
04 Dec, 2019 07:39 AM
22 Nov, 2019 03:13 AM
22 Nov, 2019 01:05 AM
20 Nov, 2019 11:12 PM