Some Small Issues I've Run Into With TenFourFox PR 13 SPR 1?

Steve Graanet's Avatar

Steve Graanet

21 Apr, 2019 11:12 AM

Thank you for your continued work with TenFourFox. It's all very appreciated

I love the way this new version is so fast. Much faster than many previous versions. But the are some things that I'm struggling with. Maybe it's just me.

1. I'm unable to install any FireFox theme from https://addons.mozilla.org/en-US/firefox/themes/ . I'm aware that the User Agent setting in TenFourFox has to be set to one of the FireFox browsers in order to install a FireFox theme, but when I try to install a theme, I get a warning that the theme is corrupt and therefore will not be installed. I never had this problem before.

2. The individual news stories don't appear like they use to at the bottom of Bing.com

3. The webpage on https://addons.mozilla.org/en-US/firefox/addon/video-downloadhelper/reviews/ doesn't align properly.

4. I sometimes get a warning form some video sites that html5 is not installed on TenFourFox and many times videos outside of YouTube will not play. They leave a blank space instead.

Other that that, I really want to commend you all for the fine work that you've been doing on TenFourFox

  1. Support Staff 1 Posted by Chris (chtrusch... on 21 Apr, 2019 04:13 PM

    Chris (chtrusch)'s Avatar

    1. I can reproduce this, even though I can't explain it. The Themes I installed previously in TFF are still available in Tools>Add-ons and still work. When I'm forced to use Windows at work I use Waterfox (which also has the pre-Quantum UI) and there I can install Themes just fine. There must be something wrong with the integrity checking routine, or Mozilla very recently must have disabled backwards compatibility to the pre-Quantum UI.

    2. I have never used Bing and can't say much about this. However when I go to Bing.com right now I do see news stories at the bottom. Can't say if anything has changed, though.

    3. Correct, we have a CSS problem. Renders fine in Safari 5/LWK. In TFF I see lots of security warnings in the console like
    Content Security Policy: The page's settings blocked the loading of a resource at self ("style-src https://addons-amo.cdn.mozilla.net").
    …which may be the cause of the weird rendering we see.

    4. This is the easiest question to answer. Just update to TFF FPR 14 as soon as it's available. It will have H.264 HTML5 video in addition to web.m video. YouTube uses web.m, but most other sites use H.264 only.

  2. 2 Posted by Steve Graanet on 22 Apr, 2019 09:39 AM

    Steve Graanet's Avatar

    Thank you Chris. That was a wonderfully speedy response. Cheers to you and your co-workers. Regarding my questions:

    1. I thank the latter i probably true: Mozilla has recently updated the routines for its theming and they're currently not working with TenFourFox FPR 13 SPR 1. If you try to install a theme from https://addons.mozilla.org/en-US/firefox/themes/ , first you'll have to change the User Agent setting in TenFourFox's preferences to FireFox 60 (it won't work if it's set to TenFourFox or any other version of FireFox). And then, you'll get a warning that the theme is corrupt and therefore will not be installed. A future goal for future versions of TenFourFox.

    2. I run TenFourFox 13 (7450) on a 1.67Ghz PowerBook G4 with Leopard on it and 2Gbs of ram. I've had this issue with all of the FPR versions of TenFourFox. Anything I can do to help? The news stories come up fine in Webkit for Leopard, but never in any of the FPR versions of TenFourFox.

    3. Thank you for attending to this.

    4. Thank you for attending to this too. There's a lot of websites where videos don't come up at all, even if you click on them repeatedly. Sometimes you get the "no html5 plugin" warning to.

    Thank you all for all of the very nice help and all the hard work you all do. We are all very indebted to you. Thank you.

    I really look forward to all the html5 and web.m fixes that you mentioned coming in TenFourFox FPR 14. Cheers!

  3. Support Staff 3 Posted by Cameron Kaiser on 22 Apr, 2019 01:23 PM

    Cameron Kaiser's Avatar

    #3 is probably CSS grid support. This is a very large undertaking and is not likely to be done anytime in the near future.

  4. Support Staff 4 Posted by Chris (chtrusch... on 22 Apr, 2019 04:02 PM

    Chris (chtrusch)'s Avatar

    1. I'll have a closer look at this later. Maybe we'll need an archive for compatible Themes like the one we have for extensions.

    2. When I load Bing.com in TFF and Safari+LWK I see pretty much exactly the same. See screenshot; what's missing in TFF? Note that I'm in Germany and may see something entirely different from what you're seeing.

  5. Support Staff 5 Posted by Chris (chtrusch... on 22 Apr, 2019 04:37 PM

    Chris (chtrusch)'s Avatar

    1. Steve, you're right. FF Themes now require ver. 53 or later, TFF is officially at ver. 45. Even Themes like this one
    https://addons.mozilla.org/en-US/firefox/addon/blue-cookie-monster/
    which I installed years ago. It has been at version 1.0 for 8 years now and should just work. Somehow Mozilla changed the .xpi file to require ver. 53 or later. Stupid.

  6. 6 Posted by Steve Graanet on 24 Apr, 2019 12:03 PM

    Steve Graanet's Avatar

    Here's a screenshot of https://www.bing.com on TenFourFox FPR 13 (SPR 1) from my 17" 1.67 Ghz PowerMac G4. It has 2 Gb of ram and runs Leopard and I hid the dock.

    No news stories. Could it be a setting in TenFourFox's preferences somewhere? Like the "No popups" setting?

    Anyway, thank you for all of the nice help and the quick replies. You're the best!

  7. Support Staff 7 Posted by Chris (chtrusch... on 24 Apr, 2019 03:15 PM

    Chris (chtrusch)'s Avatar

    Re-checked using FPR 13 SPR 1, same result for me: I cannot reproduce the issue, stories at bottom load fine. BTW I'm also on a 1.67 GHz G4 PowerBook with 2 GB of RAM :-) I am served a (partally) localized version, though, that may be it. You also might want to check with a fresh brwoser profile with default settings to make sure the problem's not on your end. If you're comfortable with the terminal, start the browser with this command:

    /Applications/TenFourFox7450.app/Contents/MacOS/firefox-bin -p

    In the profile manager, uncheck "Use the selected profile without asking at startup", then create a new profile for testing.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 May, 2019 09:09 AM
24 May, 2019 05:44 AM
23 May, 2019 06:26 PM
22 May, 2019 02:16 PM
21 May, 2019 02:11 AM