kby+tenfourfox's Avatar


02 Aug, 2018 04:49 PM

…upon going to the site (can't even get to front page). I assume this is a missing certificate? icloud/apple upgraded security recently, bu t I thought it was before this release and it was just disabling old hash algorthims.

  1. Support Staff 1 Posted by Cameron Kaiser on 05 Aug, 2018 04:04 AM

    Cameron Kaiser's Avatar

    I can't reproduce this in FPR9 beta 1, but OCSP stapling problems can sometimes be transient. FPR9 does have a certificate refresh, so you could try switching to that and see if it works, though I'm not sure that's the actual problem. Make sure your date and time are correct as well.

    Note that icloud loads substantial visual animations to the point where it took my Quad G5 three attempts with performance cranked all the way up to get the login page to load; the other two tries timed out. We render this in software which is why it's so slow. You can report this to Apple from the window that appears, assuming they even care. I don't use icloud, though, so I can't test the rest of the service.

  2. Support Staff 2 Posted by Chris (chtrusch... on 05 Aug, 2018 06:06 AM

    Chris (chtrusch)'s Avatar

    I've had no problems loading the login page at icloud.com today (never had) with my PowerBook 1.67 GHz and FPR9b1. No trouble with certificates. It takes a while to load, though, because of that kindergarten animation. I did experience a timeout once *after* logging in when the page tried to display a blurb about data protection which I had to agree on to continue.

    If you just need to change something in your Apple ID (email, payment/shipping settings, password) you can simply go to appleid.apple.com, the login page there is much easier on the processor.

  3. 3 Posted by kby+tenfourfox on 06 Aug, 2018 04:41 PM

    kby+tenfourfox's Avatar

    Thanks; I will try the beta. I tried a couple of different widely spaced
    times, but got the same error, so, albeit with only a small sample
    space, it didn't seem transient.

    I know the interface is slow. The only reason I use it is occasionally
    to use Find my iPhone (although something else is almost always easier),
    and because it's the only way to edit contact groups.
    I have/had a long-term project to upgrade to a caldavd (on 10.5.8
    server) that includes cardav as well, but I've never managed to get all
    of the required pieces together (right packages, right compilers, right
    version of python, etc.) to get a version to work.
    Actually, not quite true: I got it to work except for OpenDirectory
    authentication. Unfortunately now I have no time to work on such a
    project as my current day job has nothing to do with it and leaves
    little time, and, more to the point, not enough brain cells left.

  4. 4 Posted by kby+tenfourfox on 08 Aug, 2018 06:56 AM

    kby+tenfourfox's Avatar

    It looks like I have something else going on. For some reason if I t ype "icloud.com" it isn't gettring turned into (and resolved) as www.icloud.com. But it works on another machine, so I've got more fiddling to do. Going to www.icloud.com works fine.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac