Google Voice and FPR8

M. Southall's Avatar

M. Southall

04 Jul, 2018 03:23 AM never completes loading, just a circle endlessly spinning, so that there is no functionality at all.
I've tried refreshing, no change. I haven't noted this problem with releases several iterations back. I did not find this issue referenced by anyone else yet.

  1. Support Staff 1 Posted by Chris (chtrusch... on 08 Jul, 2018 10:12 AM

    Chris (chtrusch)'s Avatar

    M., I can reproduce the problem and will look into this later today.

  2. Support Staff 2 Posted by Chris (chtrusch... on 08 Jul, 2018 10:59 AM

    Chris (chtrusch)'s Avatar

    Doesn't work in TFF FPR8, but works in 38 (tested with fresh profiles each). Also works in Safari 5 with LWK.

    Regression window is exactly between 45.3.0b2 (last working version) and 45.4.0.

  3. Support Staff 3 Posted by Cameron Kaiser on 08 Jul, 2018 04:03 PM

    Cameron Kaiser's Avatar

    Chris, thanks for the regression window, that was very helpful for confirming my theory.

    TenFourFox doesn't officially support WebRTC or its components, including RTCPeerConnection. This is documented in the release notes. WebRTC is the underlying media conferencing framework that Google Voice uses. Earlier versions sort of worked, and we still build it as part of the browser, but it is unsupported due to certain features which are not compatible with 10.4 and 10.5 and video generally runs poorly which is its primary use case. It can be used for audio alone, however, which is what Google Voice uses it for.

    I am not a Google Voice subscriber, but I was also able to confirm the problem (it also happens on the signup screen). In a debug version, this appears:

    JavaScript error: line 89 > eval, line 38: TypeError: e.RTCPeerConnection is undefined

    Between 45.3.0b2 and 45.4.0, I disabled RTCPeerConnection due to its potential to leak people's network addresses to a malicious intermediary (see for an explanation). Since we don't support it officially, there was no reason to take the risk.

    Officially this is not a bug I plan to fix, since I don't support this mode of operation, and there are likely to be other problems with Google Voice.

    Unofficially, you can turn peer connections back on by going to about:config and setting media.peerconnection.enabled to true (you may need to restart the browser for this setting to stick). When I did this, the spinning circle disappeared and I was asked to sign up. I did not do further testing since I don't subscribe to Google Voice. If you find other bugs and you are interested in fixing this, I certainly do accept code submissions, though WebRTC will remain officially unsupported as a matter of policy.

    Hopefully this is somewhat helpful.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • googlevoice_hang.tiff 72.6 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

05 Jul, 2020 09:16 AM
04 Jul, 2020 09:32 PM
01 Jul, 2020 01:45 AM
25 Jun, 2020 05:10 PM
22 Jun, 2020 12:48 PM