ten4fox crashes when accessing banking sites

tim's Avatar

tim

28 Aug, 2017 03:16 PM

Anyone else have this problem?
The login page will mostly load, but before I can type my login info, ten4fox quits.

  1. Support Staff 1 Posted by Chris (chtrusch... on 28 Aug, 2017 03:34 PM

    Chris (chtrusch)'s Avatar

    Hello Tim, which banking site is it? Problem is that we cannot check all sites to find a solution to your problem. My banking sites, for example (Barclay's and German Savings Bank), do not crash when I log in.

  2. 2 Posted by tim on 28 Aug, 2017 03:43 PM

    tim's Avatar

    thanks for the quick reply.
    two sites.....citibank credit card and wells fargo advisors

  3. 3 Posted by Tim Gabbert on 28 Aug, 2017 04:20 PM

    Tim Gabbert's Avatar

    Chris
    Thanks for the quick reply.
    Two sites....citibank and wells fargo advisors.
    Citibank worked before the latest update.
    Wells Fargo Advisors worked before the update
    Back in march.

    Sent from my iPad

  4. Support Staff 4 Posted by Chris (chtrusch... on 28 Aug, 2017 07:47 PM

    Chris (chtrusch)'s Avatar

    Weird, I can load https://online.citi.com/US/login.do and https://www.wellsfargoadvisors.com/ without crashing TenFourFox FPR2. Are these the URLs you use to log in?

  5. 5 Posted by Tim Gabbert on 28 Aug, 2017 09:11 PM

    Tim Gabbert's Avatar

    Chris
    Yes that is weird, i agree.
    The wells fargo url is what i use.
    The citibank is different, but i tried
    The one you used.
    Same scenario.....sign page almost loads,
    But the application quits before fully loaded.
    I disabled my only four ad ons, restarted,
    same thing.

    I am using FPR2 , 7450

    I even tried starting in safe mode, no change.

    Any suggestions?

    Sent from my iPad

  6. 6 Posted by Tim Gabbert on 28 Aug, 2017 09:33 PM

    Tim Gabbert's Avatar

    Chris
    Tim again!
    I tried logging in to the two accounts thru my
    out dated Safari browser. Nothing crashes but
    both tell me i am using an outdated browser
    and Tenfourfox is not on their approved list
    I did however, on Tenfourfox, successfully login
    to mu bank CFFC and to BB&T.

    When you opened the login page, did it come
    up fully, so that you could try to log in?
    When i open the URL, it takes 20 seconds or so
    before it causes the app to quit.
    Tim

    Sent from my iPad

  7. Support Staff 7 Posted by Cameron Kaiser on 28 Aug, 2017 11:41 PM

    Cameron Kaiser's Avatar

    Tim, I am a Citibank (credit card) customer and a Wells Fargo (banking) customer myself, and I can't reproduce this on any of the test systems I have here. I'm able to log in and perform account activities without difficulty. These systems are all 10.4-based.

    We have intermittent reports of people who have occasional crashes on text fields, though they are invariably able to restart the browser and continue without a problem. Yours sounds somewhat similar except your description indicates it crashes every time? Although these reports pop up every now and then, we've never found anything in common with those systems, and I've never been able to reproduce such a crash on one of my test machines.

    Are you able to give us a crash log? (Please attach the file; don't cut and paste.) These are stored in your home directory, under Library/Logs/CrashReporter.

  8. Support Staff 8 Posted by Chris (chtrusch... on 29 Aug, 2017 10:03 AM

    Chris (chtrusch)'s Avatar

    Tim, yes, both login pages came up fully and ready to sign on.

  9. 9 Posted by Tim Gabbert on 29 Aug, 2017 02:22 PM

    Tim Gabbert's Avatar

    Chris
    Thanks again for your help.
    Cameron Kaiser, another support member has
    requested crash logs, as he is a customer of both
    financials that i am having issues with, and is
    able to access the sites and work within.

    Meanwhile, i grabbed my old g4 ibook, installed
    a fresh version of tenfourfox, and with that, i
    have no trouble accessing both sites. So, my
    thinking is to clean the power mac of tenfour
    and start over.
    How best to clean all items out of the hd?

    Thanks
    Tim

    Sent from my iPad

  10. 10 Posted by tim on 29 Aug, 2017 02:33 PM

    tim's Avatar

    Cameron
    Thanks for your help.
    I am attaching both the "???crash log" and the "exited process crash
    log".in the meantime, i installed a fresh version of Ten4 on an old
    ibookG4 and yes, i could access both the Citi and WellsFargo sites. So
    something is wonky in the app only on the PPC.
    My thoughts, as I expressed to Chris, would be to completely eliminate Ten4
    from the PPC and start new.
    That is unless you spot something in the crash logs!

    Thanks
    Tim

  11. Support Staff 11 Posted by Cameron Kaiser on 29 Aug, 2017 02:51 PM

    Cameron Kaiser's Avatar

    Tim, those logs are for the situation where an application or process has exited abnormally but the OS can't figure out what it actually was. The TenFourFox crash log will have TenFourFox or tenfourfox somewhere in the filename.

    Since the sites work okay on the iBook G4, this narrows down the problem to one of two general possibilities: a profile that either is corrupt, has an incompatible setting or has a misbehaving addon; or, a system extension or haxie on your regular G4 that doesn't exist on the iBook.

    To fix the first situation, try the steps under "How to reset your profile" (see lower right). If this fixes your problem, you're good to go.

    If this does not fix your problem, you may need to compare what is installed on your G4 versus what is installed on the iBook. There is a useful guide to finding troublesome extensions on this site: http://www.tempel.org/FindingCrashCausesOnOSX

    Either way, if you figure out what the issue is, please post it here so that other users can benefit. If there is an extension which is commonly troublesome, we can either figure out a way to work around it or at least warn people about it.

  12. 12 Posted by tim on 29 Aug, 2017 03:18 PM

    tim's Avatar

    cameron
    ok, i found this file under "console Logs" with firefox" as the title.
    Nothing exists that i can find with tenfourfox.
    I cannot get directly to the file to attach. it will not show up in my
    attachment box.
    its under "console,log", "~Library/Logs", "Crash Reporter", Firefox.

    i will try the other things you suggested.
    As an alternative, how do i wipe ten4 entirely from the system?

  13. 13 Posted by Tim Gabbert on 29 Aug, 2017 03:28 PM

    Tim Gabbert's Avatar

    Cameron
    So I tried to reset my profile.
    There is no tenfourfox or firefox under
    "Application support"
    Could this be the issue?

    Sent from my iPad

  14. Support Staff 14 Posted by Cameron Kaiser on 29 Aug, 2017 04:23 PM

    Cameron Kaiser's Avatar

    Sorry, yes, it should have firefox in the name. There is a crash log on my system located at ~/Library/Logs/CrashReporter/firefox.crash.log. Does this not exist on your system?

    Also, the folder in question is ~/Library/Application Support/Firefox. If that does not exist, what are the permissions on that folder? Does repairing permissions fix it? If TenFourFox can't write to that location, that will certainly cause unexpected behaviour at minimum.

  15. 15 Posted by tim on 29 Aug, 2017 05:17 PM

    tim's Avatar

    cameron
    yes, i found it finally. i was searching in the hard drive and not on the
    side panel under admin. and there i also found the firefox folder under
    application support.
    resetting my profile did not fix it. so i deleted ten4 entirely.
    reinstalled....no change
    what is interesting is that i can access all other banking and credit card
    services including amex, bbt, paypal etc.
    if nothing stands out to you in the crash log, i will be content using my
    old ibook to access the two sites!

  16. 16 Posted by tim on 29 Aug, 2017 05:30 PM

    tim's Avatar

    cameron
    on the last crash, the apple box came up and detailed the crash so i could
    send to apple. i copied it into a text file. i have attached it here. i
    may help or it may not. whatever! its tiring me out!

  17. Support Staff 17 Posted by Cameron Kaiser on 29 Aug, 2017 05:34 PM

    Cameron Kaiser's Avatar

    The two consistent failures come from a crash in CoreGraphics, but it is not the same issue I mentioned above. This one appears to be specific to how images are rendered and involves a null pointer getting to an operating system routine.

    Did the second option bear any fruit? Did you find any difference between the two systems?

  18. 18 Posted by Tim Gabbert on 29 Aug, 2017 06:17 PM

    Tim Gabbert's Avatar

    Well, the two systems have lots of differences.
    Most of my post production for photography is
    Done on the PPC. So most of that software is
    Not on the ibook.
    I will have a closer look later this afternoon
    And start deleting unused software.
    Thanks for your help. It is most appreciated!
    Tim

    Sent from my iPad

  19. 19 Posted by Tim Gabbert on 29 Aug, 2017 07:59 PM

    Tim Gabbert's Avatar

    So....i am now able to load the sign on page,
    enter my sign on info
    But its only with Javascript toggled off.
    After entering my info i am promted by the
    site to turn on Javascript.
    When i do, i am returned to a sign on page,
    Enter my info, hit sign on and the crash.
    Any new info in that?

    Sent from my iPad

  20. Support Staff 20 Posted by Cameron Kaiser on 29 Aug, 2017 08:09 PM

    Cameron Kaiser's Avatar

    What type of computer is this? How much RAM and which OS?

    If you start the browser in safe mode, does it work properly? See this FAQ entry: https://github.com/classilla/tenfourfox/wiki/AAATheFAQ#can-104fx-ru... Even though the instructions are for an Intel Mac, if you disable the JavaScript compiler using those directions, does that make a difference?

    Please note that I can't reproduce this and neither can Chris, but if this is a Power Mac and resetting your profile didn't work, this would point to either a conflicting system extension or possibly even an early symptom of hardware problems. TenFourFox tends to stress hardware more than other browsers because of its compilation system, and occasionally it has unmasked an impending failure that didn't occur anywhere else at first.

  21. 21 Posted by Tim Gabbert on 29 Aug, 2017 08:36 PM

    Tim Gabbert's Avatar

    Powermac 3.3. PowerPC G4
    Tiger 10.4.11
    2gb ram - status -ok

    Operating in safe mode makes no difference.
    Changing the config javascript makes no diff

    Sent from my iPad

  22. Support Staff 22 Posted by Cameron Kaiser on 30 Aug, 2017 01:42 PM

    Cameron Kaiser's Avatar

    Thanks for checking. Unfortunately, based on that, I'm afraid I'm out of suggestions right now. If you discover what the difference is, please do let us know.

  23. 23 Posted by Tim Gabbert on 30 Aug, 2017 02:35 PM

    Tim Gabbert's Avatar

    Thanks for all your help.
    What continues to baffle me, and it may
    be just coincidence......citibank was working
    fine before the latest update.
    And wells fargo was working fine before the
    update i did in april.
    And i have not added anything else to the system.
    The sites continue to load as long as javascript
    is turned off. But i cannot login as they require
    Javascript. As soon a java is back on, down they
    go.
    I have a second hard drive installed in the box as
    photo storage. I have thought about installing
    tiger on it and then tenfour, just to see if it works.
    When time permits!

    Sent from my iPad

  24. 24 Posted by tim on 01 Sep, 2017 10:10 PM

    tim's Avatar

    well.....to update
    in case you have put me completely out of your mind! this is tim, with
    the crashing problem trying to log in to wells fargo and citibank.
    i did install the tiger osx on my "storage hd"
    and viola.......tenfour opens both banking sites. so something in all my
    apps for photo post production is interfering.
    and i think i will leave it this way. seems like an added layer of
    protection!!!

    again...thanks for all the attention you and chris gave to my issue. your
    support of 10.4 is super appreciated.
    tim

  25. Support Staff 25 Posted by Cameron Kaiser on 02 Sep, 2017 12:23 AM

    Cameron Kaiser's Avatar

    I'm glad the clean install fixed it. If at some point you feel like doing a little detective work to determine which specific component is conflicting, please let me know. I'll leave this ticket open.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Sep, 2017 07:30 AM
19 Sep, 2017 01:23 PM
18 Sep, 2017 08:48 PM
13 Sep, 2017 09:21 PM
05 Sep, 2017 07:23 PM