inverse bullet in facebook text entry

kathiallyson's Avatar

kathiallyson

13 May, 2017 03:47 PM

Hi, I know this isn't a popular subject but just quickly… Since TFF went to 45 (I believe) I'm getting a lot of inverse bullet symbols when I input text on Facebook. They're between words, sometimes strings of them, and they're not visible in MacOS or iOS—only in Windows. Anyone else had this problem and figured out how to solve it? Other than that, TFF is the only browser that really works for Facebook on my Power Mac G5. Attached shows what these stray symbols look like, in case I'm not identifying them correctly.

  1. Support Staff 1 Posted by Cameron Kaiser on 13 May, 2017 04:53 PM

    Cameron Kaiser's Avatar

    Can you show a screenshot of where these appear on screen?

  2. 2 Posted by kathiallyson on 14 May, 2017 12:31 AM

    kathiallyson's Avatar

    Will go find one on my Windows computer, or if I've fixed them all I'll manufacture a new one. Thanks.

  3. 3 Posted by kathiallyson on 14 May, 2017 12:56 AM

    kathiallyson's Avatar

    This is from the Messenger app within Facebook so the symbols are white with a blue dot because of the message background color. In Facebook itself, in "status" posts and comments, the symbols appear in similar fashion as black rectangles with white dots. Looking at it refreshes my impression that these errors are related to the issue with the backspace key. I think the symbols appear in spots where I've used the backspace key for corrections/edits.

  4. Support Staff 4 Posted by Cameron Kaiser on 14 May, 2017 03:50 AM

    Cameron Kaiser's Avatar

    I'm not sure what to say to that. I don't have any Windows machines here and I don't really recognize that particular character glyph as meaningful or indicating a specific problem.

  5. 5 Posted by kathiallyson on 14 May, 2017 05:22 AM

    kathiallyson's Avatar

    OK, thanks. Just to be clear, these things appear in Facebook/Messenger *only* when I enter text via TenFourFox on my G5. The fact that they're visible only in Windows is a further oddity. I didn't even know about the problem until a friend with a Windows laptop asked me what "those little black boxes" were that kept appearing in my Facebook posts. Safari doesn't do this, but Safari isn't a good solution for reasons I'm sure I don't need to go into here. :) Oh well, not a big thing. If it weren't for all the other tasks and sites that TenFourFox can handle where other browsers stumble and choke—and I'm pretty sure I've tried them all, repeatedly—my faithful and beloved G5 would probably have been recycled long ago.

  6. Support Staff 6 Posted by Chris (chtrusch... on 14 May, 2017 05:27 AM

    Chris (chtrusch)'s Avatar

    This may be related to
    https://tenfourfox.tenderapp.com/discussions/problems/8336-facebook-the-delete-key
    I'll check whether I can reproduce it, but need to update my Win XP on Virtual PC first, haven't fired it up in ages.

  7. Support Staff 7 Posted by Cameron Kaiser on 14 May, 2017 05:29 AM

    Cameron Kaiser's Avatar

    I hadn't considered that, though the positions they appear in the screenshot don't really look like where a deletion would typically occur. Did you enter those with the delete key at those points, Kathi?

  8. Support Staff 8 Posted by Chris (chtrusch... on 14 May, 2017 06:44 AM

    Chris (chtrusch)'s Avatar

    Can't reproduce it.
    Picture 1 is what it looks like in TenFourFox (posted from TFF with several corrections using the Delete key; issue 8336 is still present).
    Picture 2 is what it looks like in Firefox 45.9 on Win XP.

  9. 9 Posted by kathiallyson on 14 May, 2017 02:01 PM

    kathiallyson's Avatar

    Thanks guys for persisting with this.

    Cameron: I'm 99% sure one of the two keys that delete triggers these glyphs to appear in text that I have edited. I would wager that it's the backward delete because (1) that's the one that acts up on Facebook (as someone mentioned in one of the other threads, the back-delete tends to delete only one character and then not respond to being repeatedly struck), (2) it's the key I am most in the habit of using for deletions when editing/correcting something I've typed. For example, in my screenshot it looks like I was trying to delete excess "spacebar" spaces. I often end up with extra spaces when I edit posts before sending, and I have the impression that is the most common circumstance for the glyphs to appear. I remember one recent instance when I composed a post outside the browser and pasted it into TFF, and I still got one black box—at the very beginning of the post, where I recall trying to delete a space.

    Chris: I have never worked with Virtual PC. Is it possible it doesn't replicate Windows 100% in this context? BTW/FWIW, my Dell XPS 8700 is running Windows 7 (because I'm too stubborn to pay for an upgrade).

  10. 10 Posted by kathiallyson on 14 May, 2017 02:20 PM

    kathiallyson's Avatar

    Here's a test I did just now. A little surprised there are no stray glyphs in the third sentence. Sometimes when editing I highlight/delete rather than deleting character by character with backspace or forward delete. I think I did do that in the second sentence, where there's a string of five of them. I wonder if the highlight/delete action is the true culprit here…

  11. 11 Posted by kathiallyson on 14 May, 2017 02:21 PM

    kathiallyson's Avatar

    ("TFFB" = TenFourFox Box in case anyone's wondering. The glyphs have appeared either way, whether I'm using the full browser or the box.)

  12. Support Staff 12 Posted by Chris (chtrusch... on 14 May, 2017 02:32 PM

    Chris (chtrusch)'s Avatar

    Please log in to Facebook and visit this profile with your Windows computer:
    https://www.facebook.com/profile.php?id=100015017857606
    Do you see the glyphs in any of the posts?

  13. 13 Posted by kathiallyson on 14 May, 2017 03:17 PM

    kathiallyson's Avatar

    Only in the oldest one. Here's what I see:

  14. 14 Posted by kathiallyson on 14 May, 2017 03:30 PM

    kathiallyson's Avatar

    The plot thickens: The above screenshot was made in Google Chrome on the Dell. In Firefox, the glyphs DON'T appear. Hmmmm. [EDIT:] They don't show in Internet Explorer on the Dell, either.

  15. 15 Posted by kathiallyson on 14 May, 2017 03:37 PM

    kathiallyson's Avatar

    I just questioned my Facebook friend who originally pointed them out to me, and when she's on her Windows laptop, she said, she is usually browsing with Chrome, too. Neither of us can see the glyphs in iOS.

  16. 16 Posted by kathiallyson on 14 May, 2017 03:53 PM

    kathiallyson's Avatar

    So there you go, guys: I just got a lesson in what you already know—Facebook + Google = double your trouble :)

  17. Support Staff 17 Posted by Chris (chtrusch... on 14 May, 2017 06:05 PM

    Chris (chtrusch)'s Avatar

    Thanks for reporting back, kathiallyson. I doubt we can do anything about this in the short run, but it may help eventually to solve the issue reported at
    https://tenfourfox.tenderapp.com/discussions/problems/8336-facebook-the-delete-key

  18. Support Staff 18 Posted by Chris (chtrusch... on 14 May, 2017 06:16 PM

    Chris (chtrusch)'s Avatar

    BTW, the problem is visible in TenFourFox as well, so there really are characters inserted by our Delete Key action, only Gecko "sanitises" the character display somehow.

  19. 19 Posted by kathiallyson on 14 May, 2017 09:34 PM

    kathiallyson's Avatar

    Wow. Thanks so much for looking into this further. Very interesting and informative for me. I would never have thought to look in the inspector. Since you took the trouble to show me an image of the evidence, I inspected the test post I made this morning and sure enough the extraneous characters show up as they do in your test (see snip below). At least I have a better idea how to prevent the problem even if it can't be fixed. Hat tip to Gecko as well :D

  20. Support Staff 20 Posted by Cameron Kaiser on 15 May, 2017 12:40 AM

    Cameron Kaiser's Avatar

    That is quite unusual indeed. I'm looking through the key handling code. There's definitely something awry here but I'm not sure where exactly.

  21. Support Staff 21 Posted by Cameron Kaiser on 15 May, 2017 05:42 AM

    Cameron Kaiser's Avatar

    After struggling with this all day the issue looks like, at some point with repeated delete key events, Facebook stops treating them as backspaces and starts inserting the actual backspace character code.

    Although this gives me a little more understanding into the Facebook delete key problem, unfortunately I'm hitting the same wall I hit with looking at this before, namely that Facebook uses many non-standard methods for its user interface and is heavily dependent on a large battery of minified scripts which are extremely hard to debug (besides the fact I really, really despise Facebook personally). My suspicion is that our custom widget code is not filling in a field in the DOM keyboard event that it's expecting, but several shots in the dark didn't seem to make a difference.

    For now all I can suggest is using either the forward delete, which seems to work just fine for reasons I am unable to determine, or cutting and pasting. If you find a less complex site that does the same thing, I can take a look at that.

  22. 22 Posted by kathiallyson on 15 May, 2017 02:30 PM

    kathiallyson's Avatar

    Thank you Cameron. I know Facebook is awful in many ways of which you're keenly aware, so I hesitated to even bring this up. I appreciate your looking into it and by doing so, you and Chris have given me a much better handle on the issue. I should be able to avoid triggering the glyphs now by taking care not to use the backspace delete when cleaning up my text entry errors, and if I forget occasionally, well, my Chrome-o-phile friends will just have to deal with it. Without your help I probably would never have figured out that Chrome is the only (major) browser that shows the glyphs.

    Even more, I appreciate the huge gift of TenFourFox that has kept my Power Mac G5 in daily use for going on 12 years now, as a classic and a beast the likes of which I won't own again. I'm writing this on the 2012 Mac Mini that sits next to it, but that's only because the G5 and TenFourFox are busy filling a shopping cart :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • inversebullet_edited-1.jpg 12.7 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Sep, 2017 07:30 AM
19 Sep, 2017 01:23 PM
18 Sep, 2017 08:48 PM
13 Sep, 2017 09:21 PM
05 Sep, 2017 07:23 PM