TFF 45.6.0 WARNING

Joe's Avatar

Joe

21 Dec, 2016 07:50 AM

After sluggish performance but no other problems on my G4 powerbook 10.5.6 with TFF 45.5.x I upgraded to 45.6.0. HUGE MISTAKE. The browser opened and seemed to be running faster than previous versions but within ten seconds my entire system froze except for the mouse cursor which moved freely but no longer activated anything, turning into the spinning ball of death when I clicked it.

I had no choice but to reboot. It rebooted once but again the screen froze -- I did notice that my powerbook's wifi was still on. I have since rebooted several times using every possible startup "repair" sequence plus Diskwarrior -- at which point my HD wasn't showing up.

I can only assume that TFF 45.6.0 installed something nasty that corrupted the OS star up sequence or that the multiple attempts to restart the computer did the HD in.

  1. Support Staff 1 Posted by Cameron Kaiser on 21 Dec, 2016 11:23 AM

    Cameron Kaiser's Avatar

    With all due respect, I'm sorry that happened to your system, but jumping to the conclusion that the current version of TenFourFox is malicious is frankly insulting, especially since we do test it on multiple systems and there is an entire 6-week beta test cycle beforehand -- and, as you say, a hardware failure is at least as likely to have been responsible. I do personally use the browser myself, so it's not an issue of not eating our own dog food.

    If there is something specific here you think is at fault, I'll try to resolve it if I can reproduce it on a test system, but if the issue is that TenFourFox broke your computer, I certainly can't confirm that.

  2. 2 Posted by Joe on 21 Dec, 2016 05:15 PM

    Joe's Avatar

    Cameron - I'm sorry if I insulted you. I appreciate that you're performing a service to low end Mac users and I didn't intend to demean you. Because TFF 45.6 seemed to be the catalyst for the demise of my old powerbook, I sounded the alarm to prevent others who might experience the same problem. It may well be that my HD was ready to give up the ghost and just needed a nudge but it worked fine up until the freeze, which may have been the result of an incompatibility -- I was concurrently running Final Draft 8 and Microsoft Word 2011. I was connecting via wifi to my router, using TFF to do a little research for the project I was writing. Luckily I had good back-ups to a USB stick so all I need to do is replace my powerbook.

  3. 3 Posted by Bo on 21 Dec, 2016 06:44 PM

    Bo's Avatar

    This comment was split into a new discussion: TFF 45.6 crashes when opening email links

    Just want to report that I've been using 45.6.0 since Dec 10, 2016 and the browser is crashing more than usual. Today it crashed about 6 times, one after the other as I opened links from my email. Rebooted my Powerbook G4 and clicked directly on the TFF app in Applications, this time it opened ok.

    Am also using Anonymox + other add-ons + Startpage is homepage. Curious to know if any of these factors would affect the operation of TFF.

    Otherwise, very happy with TFF - it's been a lifesaver!!!!

    Thank you :)

  4. 4 Posted by Brian Szemon on 23 Dec, 2016 12:56 AM

    Brian Szemon's Avatar

    Sounds like hardware and not software mate, Hard drives do go bad. This is why I do regular maintenance every month with Onyx to check the health of the drive and files. It can be frightening when something goes wrong just don't try to jump to conclusions about the software before you know it's not the hardware testing and re-testing is the key to insure accurate information.

  5. 5 Posted by Bo on 23 Dec, 2016 05:25 PM

    Bo's Avatar

    Hi Brian, thanks for your advice re: Onyx maintenance check. I ran it last night (will also run monthly, as suggested) and discovered my start up disk needs repair - but don't have the original OS X 10.4.11 CD or DVD. Any suggestions on where I could find one ? Thanks for any suggestions.

  6. 6 Posted by Joe on 23 Dec, 2016 11:01 PM

    Joe's Avatar

    One thing I forgot to mention. Before the crash the last thing that happened was I clicked on a link to open in a new tab and it tried to open several tabs at the same time. There were at least five or six extra tabs opening, maybe more, before it all locked up.

  7. 7 Posted by Brian Szemon on 24 Dec, 2016 03:51 AM

    Brian Szemon's Avatar

    Bo you can try a boot into safe boot it will scan and correct error, With the computer off turn it on and hold down the shift key once you see the apple logo you can let go once the check is done log in and then restart. Once booted back up in regular mode run onyx again and see if you get the same errors if not problem fixed if not you may have to boot into single user mode and run fsck the old fashioned way in terminal let me know how it goes.

  8. 8 Posted by Colin on 24 Dec, 2016 07:42 AM

    Colin's Avatar

    iBook PPC updated to TFF 45.6 yesterday.

    Smooth as silk: No problems whatever.

    Merry Christmas Cameron and Team!

  9. 9 Posted by Bo on 24 Dec, 2016 09:20 PM

    Bo's Avatar

    Brian, I did the safe boot, followed your instructions but when I logged in again in regular mode and ran Onyx I got the same message that the startup disk needs repair. So, can you please tell me how to boot into single user mode and run fsck (?) in terminal? Thanks again. All help appreciated, Bo

  10. 10 Posted by Brian Szemon on 27 Dec, 2016 03:12 AM

    Brian Szemon's Avatar

    Bo with the computer shut off turn it on and hold down Command + S if successful you should know their will be noting but text. Once boot sequence has finished type in "fsck -fy" with out the quotation marks" " and let it run. After it has ran and if you see a “File system was modified” message just run the same "fsck -fy" command again until you see the message “The volume (name) appears to be OK”. Once everything is done and ok just type the command "restart" and it will boot back up into normal mode. I Bought my mac off E-bay when I got it I had to problems and no tiger disk and this was able to fix the disk for me hope it can for you best of luck.

  11. 11 Posted by Bo on 28 Dec, 2016 06:14 PM

    Bo's Avatar

    Thanks, Brian, for the info on how to run "fsck -fy" in single user mode. Very useful :)
    I ran it several times until I got the message “The volume (name) appears to be OK”. Then, I ran Onyx to double check and it still tells me the startup volume needs to be repaired! So, short of finding/using the Tiger startup disk, I will just leave as is. My Powerbook G4 is operating well, so I'm not too worried about it.

    Thanks again for your help. Any other feedback is welcome.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 May, 2019 09:09 AM
24 May, 2019 05:44 AM
23 May, 2019 06:26 PM
22 May, 2019 02:16 PM
21 May, 2019 02:11 AM