Repeatable crash when trying to print from within TFF

kennethy4's Avatar

kennethy4

27 Aug, 2016 02:50 AM

I'm having a reproducible crash problem on a G5 running 38.9 while trying to print from within the browser, and get the following in the crash log:

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000014
Crashed Thread: 0

This happened a few times several months ago, which I ignored, and within the last week or 2 it's constant. I click on print in the print dialog box, it closes, nothing happens for maybe 5 - 10 seconds, then the app quits. I started using TenFourFoxBox several months ago, and also occasionally use v.31.4 when I'm not too concerned about security - because it runs much faster. I've checked lots of things, and it only happens with TFF (either version above) or TFFB, as described above.

Ken

  1. Support Staff 1 Posted by Cameron Kaiser on 27 Aug, 2016 03:12 AM

    Cameron Kaiser's Avatar

    Does printing to PDF work within TenFourFox?

    Did you recently change your printer?

    Does resetting your profile (see link at lower right "How to reset your profile") make any difference?

  2. 2 Posted by kennethy4 on 27 Aug, 2016 05:04 PM

    kennethy4's Avatar

    1. No, printing to PDF also crashes.
    2. No, have had the printer (Brother HL-5370DW) for several years.
    3. Haven't tried that, but that was my last thought last night. I'll work on it today.

    One other thing, I tried other browsers (Safari 5.0.6, FF 3.6.15) and had no crashes.

    Last thing I did last night was to try 45.3.0 and altho that seems to run faster that other recent versions, it also crashed on printing. And it looks like it's not using my profile. Is that possible? Anyway, I'll work on resetting it this morning and let you know.

    Thanks,
    Ken

  3. Support Staff 3 Posted by Cameron Kaiser on 27 Aug, 2016 05:09 PM

    Cameron Kaiser's Avatar

    Don't switch back and forth between 3.6 and TenFourFox. This can corrupt your profile (which is probably why 45 appeared to not be "using it"); it may work and it may not, but there are many reports of data loss from others who have and we've never supported doing so.

    If a simple profile reset doesn't work, continue on through the remainder of the instructions up to and including removing the entire profile folder since it's possible the reset may not touch this setting.

    That said, I print and save to PDF from my systems all the time, so I don't have any other advice for you right now and I can't replicate it on a test system. If you're able to, please attach the crash log.

  4. Support Staff 4 Posted by Cameron Kaiser on 27 Aug, 2016 05:10 PM

    Cameron Kaiser's Avatar

    One other thought is to change it to another printer and change it back to see if that fixes anything, but I don't know if you have another printer you can use.

  5. 5 Posted by kennethy4 on 27 Aug, 2016 06:51 PM

    kennethy4's Avatar

    Got it fixed. I used the shortcut in the reset instructions, and then was able to do several print jobs in 38.9. I'm guessing that I may have corrupted settings by frequently switching back and forth between 31.4 and the latest versions? I did this because the latest versions always got painfully slow after several minutes of use, and 31.4 was much faster. Maybe 45 will be better in that regard.

    But I saw that 38.9 was now running on a brand new default profile, no bookmarks, nothing. So Ibrought up the Profile Manager, and found I had 2 Profiles: default and default -147231847, Set Profile Manager to appear at startup, and tried both profiles. The first was almost everything that I had before, all my bookmarks, but minus 2 Extensions, Zotero (old version that will run with TFF) and Evernote - which I don't care about. I think I can track down the old Zotero extension, and I don't think it was causing problems under either 31.4 or 38.9.

    And about FF 3.6, I don't use it - just used it to test the printing problem. And the only other printer I have is a Deskjet, which works OK.

    So thanks. Easy fix and next time I should know better.

    Ken

  6. 6 Posted by kennethy4 on 28 Aug, 2016 12:19 AM

    kennethy4's Avatar

    Regarding potential sources of corrupting a profile -

    In a message on 8/1/2015 in the thread "Re: TFF 31.0 has killed Zotero!! [Problems #1435]," you said "... for 38 I put a stub in which emulates just enough to seem to make Zotero happy." Is that still the status? I was using the same profile for 31.4 and 38.9 which included Zotero and wasn't having any problems with Zotero in either.

    Ken

    Ken

  7. Support Staff 7 Posted by Cameron Kaiser on 28 Aug, 2016 02:06 AM

    Cameron Kaiser's Avatar

    45.x has full support for the JavaScript Intl API, so the stub is no longer required. It should "just work." Post in that thread if it doesn't seem to be.

  8. 8 Posted by kennethy4 on 29 Aug, 2016 09:47 PM

    kennethy4's Avatar

    So far 45.3 and the latest Zotero extension (4.0.29.11) seem to be getting along fine.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

24 May, 2019 05:44 AM
23 May, 2019 06:26 PM
23 May, 2019 04:31 PM
22 May, 2019 02:16 PM
21 May, 2019 02:11 AM