killing unresponsive scripts

Guy Palmer's Avatar

Guy Palmer

20 Dec, 2015 05:01 PM

I'm probably one of the few that actually looks at Yahoo's main page on a regular basis. Lately - I've been getting the spinning beachball of death more frequently. When it seems to be spinning interminably I use the command-option-esc option to kill tenfourfox. It would be far better to just tank the script in stead of the app. Any ideas?

  1. 1 Posted by Zi Pinsley on 20 Dec, 2015 07:47 PM

    Zi Pinsley's Avatar


    I have that problem with gmail's "hangouts' trying to load. I don't want that to open, but wouldn't care if it didn't make everything 'hang'.

    I get the unresponsive script error msg, with the choice to end the script or to de-bug it. Since ending the script doesn't work, I started clicking 'debug' instead.

    Once the debug sub-window opens, then I click on the 'x' in the upper right corner... and the script is 'done'... until the next time.

    It's a pain, but it stops me from gnashing my teeth endlessly. I wish there was a way to remove the 'hangouts' instead.

    Will be very interested to read other user's solutions, or, best... to have 10-4-fox show us the best fix available!


  2. Support Staff 2 Posted by Cameron Kaiser on 20 Dec, 2015 09:41 PM

    Cameron Kaiser's Avatar

    Zi, Google tells you how to disable it very easily.

    Guy, Yahoo pages have indeed become very heavy lately. The problem is that it is rarely one single script that's the problem, but a large number of simultaneous ones competing for execution resources. There isn't a whole lot I can suggest there currently. It's not very fast even on my i7 MacBook Air.

  3. 3 Posted by Guy on 21 Dec, 2015 02:00 AM

    Guy's Avatar

    Thanks for the input. What happens with my Tenfourfox is that I never get the dialog box, just the beachball of death. But I remember seeing something somewhere where I could adjust the time-out for putting up the box, and then see if I can get it to show and then do Zi's suggestion where I go into debug mode. Cumbersome, yes, but better than nuking 10-4. Thanks again.

  4. Support Staff 4 Posted by Cameron Kaiser on 21 Dec, 2015 02:37 AM

    Cameron Kaiser's Avatar

    Guy, what you probably want to do is change the setting mentioned in to a lower value. This will make the browser time out the script sooner, though if it's a whole mess of scripts getting backlogged, you might find this more annoying than useful. It's worth a try, though.

  5. 5 Posted by Guy on 24 Dec, 2015 04:34 PM

    Guy's Avatar

    Hi all, I did the first thing where I set the value to zero - seemed to help a bit. But then I looked at the Ad blockers I had installed. Bingo. Turned both of them off and at least as far as Yahoo is concerned, much better performance. Seems like Yahoo has figured out how to test for the presence of these ad blockers. BTW, I was useing Ublock and Adblock without adjusting any of their settings. I think Ublock was automatically updated, but in either case, Yahoo is working much better.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac