Using Mega.nz

pasquale.1996's Avatar

pasquale.1996

05 Oct, 2015 09:33 AM

Hello guys, i know our beloved browser does not support javascript, but i wanted to know if there's a way to use mega.nz, as it's very useful to me. When i try to download something, it goes up to 99% and then nothing... it remains on 99% and i can't save files

Thanks in advance

  1. Support Staff 1 Posted by Chris (chtrusch... on 07 Oct, 2015 02:31 PM

    Chris (chtrusch)'s Avatar

    I think this has come up before and we didn't find a solution. Do you have an example download from that site? I would like to look into this more deeply.

  2. 2 Posted by bombman on 13 May, 2016 12:19 PM

    bombman's Avatar

    here is a sample

    https://mega.nz/#!oAtFnSoK!MXVGcBXDP7er79tKRgNaqXcXhsNdsrEirN1bwxPqkpE

    small files download okay but the browser hangs with files over 100MB or so

  3. Support Staff 3 Posted by Chris (chtrusch... on 18 May, 2016 03:10 PM

    Chris (chtrusch)'s Avatar

    In the console I see "TypeError: asm.js type error: AsmJS not currently supported on PowerPC", so we know what's likely to be the problem.

    This is covered in this thread:
    https://tenfourfox.tenderapp.com/discussions/problems/7505-problems-uploading-to-facebook

    Note that Facebook fixed the issue on their end, but the underlying problem (i.e. asm.js not working on PPC) still exists.

  4. Support Staff 4 Posted by Cameron Kaiser on 20 May, 2016 04:15 PM

    Cameron Kaiser's Avatar

    I suspect this is another endian issue, actually. asm.js code will run on PowerPC, it just isn't accelerated. But if the code makes endian assumptions, it won't run correctly and we have uniformly seen this problem with asm.js because of Emscripten. See

    http://tenfourfox.blogspot.com/2016/03/3870-available-plus-thanks-m...

    The long term plan is to fix this with the "LE" part of the planned IonPower-NVLE but this is not a small project and I'm still working on getting 45 ported.

  5. 5 Posted by kevmo on 02 Nov, 2018 03:51 AM

    kevmo's Avatar

    yeah, I have the same issue as well and it's been 2 years now.

    still not a big deal, I can use another computer to download.

    I have not tried to upload anything - yet

    thanx

  6. 6 Posted by kevmo on 02 Nov, 2018 04:25 AM

    kevmo's Avatar

    OK (using version 10)

    I tried to upload a folder that was zipped and called "this is a test file" and it uploaded successfully!

    it read as 165 k on Mega, and I was also able to download and unzip it successfully!

    I still have a zip archive of TenFourFoxG5-FPR9.app.zip which I successfully uploaded but unfortunately - it got to 99% for the download.

    I don't know what that means but win some lose some :-)

    k!

  7. Support Staff 7 Posted by Chris (chtrusch... on 09 Dec, 2018 02:24 PM

    Chris (chtrusch)'s Avatar

    The thing with mega.nz is: If the file is big it will take a long time to "transfer" and then to "decode" the file (whatever mega.nz is doing at this stage, in theory is should start downloading right away). "Decoding" means the progress bar will stay at 99%; for a 100 MB file this may take several hours with only little processor load on the client side. I've had a 550 MB file sitting there over night for at least 9 hours, but it downloaded eventually. Again, I have no idea what mega.nz is doing there and why it takes so long, but it does work if you're patient.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac