Why is TenFourFox adding a trailing slash to the end of URLs?

Tom's Avatar

Tom

06 Feb, 2014 01:00 PM

As the subject. I can't login to a site because the site won't accept the trailing slash at the end of the URL.

  1. Support Staff 1 Posted by Chris (chtrusch... on 08 Feb, 2014 08:35 AM

    Chris (chtrusch)'s Avatar

    Which website is it?

    If this is about the URL bar: TenFourFox behaves exactly like Firefox here. You type the URL, you hit enter, the slash is added. Safari, Opera (and the Internet Explorer on Windows) do likewise. If the website doesn't accept that, they have a problem because pretty much nobody except from Chrome users will be able to log in.

    If you mean a saved form or password: Look at Preferences>Privacy>Custom Settings>Remember search and form history (maybe there's something saved and auto-completed when you type in the log-in field) and Preferences>Security>Remember passwords for sites>Saved Passwords…

  2. 2 Posted by Tom on 10 Feb, 2014 03:47 PM

    Tom's Avatar

    The address is http://social.chillifish.com/admin/login

    Firefox on my PC doesn't do it and nor does Safari. The developers of the site say it's my problem and not theirs! I think they should solve it, but it doesn't look like they're interested…

  3. Support Staff 3 Posted by Cameron Kaiser on 11 Feb, 2014 03:24 AM

    Cameron Kaiser's Avatar

    This URL works fine on all the TenFourFox test systems; it doesn't add a slash. Do you have an add-on that might be interfering?

  4. 4 Posted by Tom Boltwood on 11 Feb, 2014 09:58 AM

    Tom Boltwood's Avatar

    That's what they said as well. I restarted in safe mode with add-ons
    disabled and it was still doing it! If it's just me then, I guess I'll
    have to figure it out myself. Thanks anyway though.

  5. Support Staff 5 Posted by Chris (chtrusch... on 13 Feb, 2014 06:16 AM

    Chris (chtrusch)'s Avatar

    What I observe with TenFourFox: If I type www.google.com and hit enter, a slash is added (that's what I was referring to in my first post). If I type www.google.com/login, no slash is added. This seems to be the standard behavior. Maybe there's a URL autocomplete setting interfering?

  6. 6 Posted by Tom Boltwood on 13 Feb, 2014 10:07 AM

    Tom Boltwood's Avatar

    What do you know? It's now working fine… all I've changed is to
    install the MozBar addon!

  7. Support Staff 7 Posted by Cameron Kaiser on 14 Mar, 2014 01:47 PM

    Cameron Kaiser's Avatar

    Sorry about the (admittedly clever) spam.

  8. 8 Posted by Tom Boltwood on 14 Mar, 2014 02:27 PM

    Tom Boltwood's Avatar

    No problem…!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac