"Bad Font Detected" New York Times Website Only

joe.smith's Avatar


01 Jul, 2015 01:45 PM

Is there a solution to the bad font issue for NYT website? This problem began for me about three-four months ago. It is happening on all my G3 and G4 Powerbooks and iBooks, so I doubt it's any kind of font library corruption issue, rather that the NYT changed something about their headline fonts or that the latest tenfourfox versions are unable to resolve the font. Are others experiencing this and is there a known fix or workaround? Thanks! J Smith, Des Moines. (Running OS 10.4.11 on all machines.)

  1. Support Staff 1 Posted by Cameron Kaiser on 01 Jul, 2015 01:48 PM

    Cameron Kaiser's Avatar

    I don't have any trouble with the New York Times on my 10.4.11 systems. What you're describing usually appears as a popup window on a corrupted font, which makes me wonder if something is wrong with your connection or ISP. Can you post a screenshot of the window and an example URL that does this reliably?

  2. 2 Posted by joe.smith on 01 Jul, 2015 03:13 PM

    joe.smith's Avatar

    Here's an example, Cameron.
    When it occurs in the NYT site, it seems to involve article titles or captions and it replaces the font with boxes around a capital letter "A".
    First noticed this about three of your updates ago, back in the Spring.
    I appreciate any thoughts you have, it's not bad yet but I was worried that it would accelerate due to something NYT was doing.
    I have not seen this on any other sites.

  3. Support Staff 3 Posted by Cameron Kaiser on 01 Jul, 2015 04:01 PM

    Cameron Kaiser's Avatar

    I haven't seen an issue like that. Have you cleared your font cache (this usually requires a restart afterwards)? If you don't know how to do this, there are third-party tools that can do this for you, or see http://www.extensis.com/support/knowledge-base/clearing-mac-os-x-fo...

  4. 4 Posted by joe.smith on 01 Jul, 2015 04:28 PM

    joe.smith's Avatar

    I’ll see if I can get a call pulled together to discuss. Use/audience is still pretty “fluid” at this point. They want detail on the cc’s to frame it up in leadership audience’s mind, as the operational plans will be really down in the weeds.

  5. 5 Posted by joe.smith on 01 Jul, 2015 07:31 PM

    joe.smith's Avatar

    Oops, don't know how that other comment got posted - that was part of my work flow.

    I tried both trashing the com.apple.ATS folder from the Cache folder and also running FontNuke to clear all font caches. I have done this twice, but alas am getting the same result on the NYT website, Cameron. See new screenshot enclosed. Very weird. Any additional thoughts? -J

  6. Support Staff 6 Posted by Chris (chtrusch... on 01 Jul, 2015 07:59 PM

    Chris (chtrusch)'s Avatar

    Data points for the website shown in the screenshot above

    - both 31 and 38 give me the "bad font" warning and show As in squares.

    - 31: no bad font warning, no text in this place at all.
    - 38: can see the text ok for a moment, then the browser crashes.

    I'll try to find the offending font.

  7. Support Staff 7 Posted by Chris (chtrusch... on 01 Jul, 2015 08:20 PM

    Chris (chtrusch)'s Avatar

    It's http://typeface.nytimes.com/fonts/nyt-cheltenham-200-normal.woff (maybe some more fonts I couldn't find in the source code).

    If I block http://typeface.nytimes.com/fonts/* with Adblock, I get this on 10.5 (both 31 and 38, no crash); see screenshot. Looks like in Safari, only that the font displayed is Georgia instead of the downloaded nyt-cheltenham. Georgia is the first fallback font specified in the font family in the source code.

    Instead of using Adblock one could just set gfx.downloadable_fonts.enabled to false in about:config as a quick workaround.

  8. Support Staff 8 Posted by Cameron Kaiser on 02 Jul, 2015 12:46 AM

    Cameron Kaiser's Avatar

    Yes, I can reproduce it with that URL. That workaround should suffice in the short term. I need to add it to the font blocklist once I figure out the PostScript name.

  9. Support Staff 9 Posted by Cameron Kaiser on 02 Jul, 2015 04:12 AM

    Cameron Kaiser's Avatar

    This is going to be a problem -- there is no PostScript name for this font internally. We'll have to craft a new way to block it.

    I'm reopening issue 261 to track this.

  10. 10 Posted by joe.smith on 02 Jul, 2015 01:25 PM

    joe.smith's Avatar

    Thanks, guys, I appreciate the help with this. Remind me, do I use Terminal to get to about:config to change that or is that within TenFourFox itself? I know I've done something with the config settings, but it was a while back.

    Cameron, every day that I use my Powerbooks and iBooks I give thanks for you and your entire team. Without TenFourFox they would not be useful to me, but with it, they are still such a pleasure to use.


  11. Support Staff 11 Posted by Chris (chtrusch... on 02 Jul, 2015 02:44 PM

    Chris (chtrusch)'s Avatar

    Just type about:config in the URL bar.

  12. Support Staff 12 Posted by Cameron Kaiser on 02 Aug, 2015 02:34 AM

    Cameron Kaiser's Avatar

    This issue has been corrected (hopefully) in 38.1.1 beta 2. Feel free to give it a try; 38.2 will become final in just under two weeks.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac