RE: 24.2 fails to load on either G4 or G5 machines

Andres Caamano's Avatar

Andres Caamano

12 Dec, 2013 06:35 PM

Downloaded the 24.2 updates for both a Quicksilver Mac (7450) and a G5, and in both cases, when I boot up the program, I immediately get: "XML Parsing Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 2042, Column 7: <toolbarbutton id="home-button" class="toolbarbutton-1 chromeclass-toolbar-additional"
------^" in a yellow boxed window. I don't get any menu, except if I click the "About TenFourFox" selection, but when I try to open a new window, for example, I can't get past the yellow window. I've gone with a default profile, and tried the safe mode option, but neither gets me past the yellow window. I've been using the v17 of TenFourFox with no issues for months, but figured to update with this latest version until my inability to even open the program stopped me.

Sincerely,
Andres Caamano

  1. Support Staff 1 Posted by Cameron Kaiser on 12 Dec, 2013 06:43 PM

    Cameron Kaiser's Avatar

    This is almost always due to either a bad profile or a bad add-on. You may have to simply remove the entire Firefox folder out of Library/Application Support in your home directory to get this to reset if "Reset Profile" and safe mode didn't work, but you will lose everything. If you're still able to start 17, I'd backup your bookmarks first.

    If this still occurs after that with everything completely wiped, I have no other suggestions for you; obviously it works fine on my quad G5 and my iBook G4.

  2. 2 Posted by Andres Caamano on 13 Dec, 2013 04:23 PM

    Andres Caamano's Avatar

    Dear Cameron:

    Went ahead and put in the trash the "Firefox" folder that had been residing
    in my acaamano/Library/Application Support folder, and quit Firefox.
    Started up the G5 version on a G5, and it recreated a new "Firefox" folder
    in that Application Support folder, but immediately created the same yellow
    popup window on startup. I didn't restart the machine because I figured I
    didn't need to do that, as it obviously started with a fresh folder, but
    that in of itself failed to fix anything. I checked to see if the folder
    was a fresh set, using v17, and it showed no bookmarks, so I knew it was a
    fresh set. I went back and reloaded the old set so I can at least use v17
    for the time being. Were there any builds between v17 and v24 that might
    work for me either on the G5 or the Quicksilver G4?

    Sincerely,

    Andres Caamano

  3. Support Staff 3 Posted by Chris (chtrusch... on 13 Dec, 2013 05:25 PM

    Chris (chtrusch)'s Avatar

    Andres, just a quick question: Whicht app do you use to unpack the TenFourFox.zip download?

  4. 4 Posted by Andres Caamano on 16 Dec, 2013 03:37 PM

    Andres Caamano's Avatar

    Dear Chris:

    Solved. Your question had me check what I had used to mount the ZIP file,
    and the default program was the BOMArchive Helper. I then went to mount it
    with Stuffit Expander, and had to make sure that the program was zipped off
    my desktop, as the Windows servers I use in my office limit the number of
    characters for a file name and wouldn't let me unzip it to that folder.
    Once I did that, it worked fine. Thanks for the pointer.

    Sincerely,

    Andres Caamano

  5. Support Staff 5 Posted by Chris (chtrusch... on 16 Dec, 2013 06:28 PM

    Chris (chtrusch)'s Avatar

    Good. I remember seeing this sort of yellow-window-xul-error-mess when some files inside the application package are incorrectly named for whatever reason, or point to the wrong or nonexisting files (I see this a lot when preparing the language pack installers and messing up). Glad it's solved.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

24 Aug, 2019 08:37 AM
22 Aug, 2019 10:51 PM
22 Aug, 2019 10:44 PM
19 Aug, 2019 03:03 AM
14 Aug, 2019 12:17 PM