huge contextual menu...

tina holm's Avatar

tina holm

01 Dec, 2013 03:51 AM

finally bit the dust and upgraded from tff 7.0 to the newest release 17.0.11

now my contextual menu is a mile long with all sorts of options and doesn't really seem to work - like in: nothing happens when I try to click "open link in new tab"

powerbook g4, 10.4.11

what to do?

tia

/tina

  1. Support Staff 1 Posted by Cameron Kaiser on 01 Dec, 2013 05:50 AM

    Cameron Kaiser's Avatar

    Can you post a screenshot?
    Are you sure an add-on hasn't run amok?

  2. 2 Posted by tina holm on 01 Dec, 2013 11:50 AM

    tina holm's Avatar

    he, I'm not sure of anything :-)

    I only have one add-on, NoScript, which should be up to date I guess, since I was sent there in the first run and the site stated i had the latest

    tia
    /tina

  3. 3 Posted by tina holm on 01 Dec, 2013 12:03 PM

    tina holm's Avatar

    well, since you asked, I tried checking if there should be another add-on I'd forgotten about. but I can't get to the add-on management screen, it just sits there with "loading..." forever

    a spotlight search only turns up a NoScriptSTS.db in "home"

    /tina

  4. Support Staff 4 Posted by Cameron Kaiser on 01 Dec, 2013 05:21 PM

    Cameron Kaiser's Avatar

    Wow, I have no idea what to say about that. Those are all the TenFourFox menus but they're all glommed together.

    I'd reset your profile -- there's probably something icky in the XUL fastcache. (See the document link at lower right)

  5. 5 Posted by tina holm on 02 Dec, 2013 12:33 AM

    tina holm's Avatar

    he-he :-) thought so

    well, I can't get to the troubleshooting page either

    XML Parsing Error: undefined entity
    Location: jar:file:///Users/tina/Downloads/TenFourFox7450.app/Contents/MacOS/...

    Line Number 14, Column 12: &aboutSupport.pageTitle;

    I've moved it since the first run, will that really mess things so much up?

    oh well, I'll take another shot at it and let you know what happens

    thank you so far

    /tina

  6. Support Staff 6 Posted by Cameron Kaiser on 02 Dec, 2013 01:09 AM

    Cameron Kaiser's Avatar

    Moved the application? No, that wouldn't cause this. Using the How to reset your profile article, find your profile folder and delete localstore.rdf inside of it (with the browser shut down). Restart the browser and see if that fixes it. If it doesn't, I would remove your entire profile folder and trash it -- this will completely reset the browser, including bookmarks and add-ons. Try to export your bookmarks first before you do.

  7. 7 Posted by tina holm on 02 Dec, 2013 02:23 AM

    tina holm's Avatar

    hmmm, ready to cry now .-(

    deleted the localstore.rdf, and yes it did solve the contextual menu thing - happy about that

    but now my noscript is gone, I've installed it again severeal times and it doesn't turn up in the navigation bar as it did before - it's in the add-on bar at the bottom, but only as text - can I get i back at the top somehow?

    also how do I get rid of the google search field, the home and bookmarks buttons

    also missing the "stop loading"-button

    travelled the preferences for hours without finding anything

    oh sorry - I am actually very happy that you've done such a great job on this browser, it is so great that I can still use my old macs reasonably safe, can't afford new ones, and also can't stand throwing away perfectly good hardware long before it's worn out

    you should be awarded some great prize and have a golden medal of sorts if it were up to me to decide such things

    thanks

    /tina

  8. Support Staff 8 Posted by Cameron Kaiser on 02 Dec, 2013 02:29 AM

    Cameron Kaiser's Avatar

    Okay, good, that solved the main problem, so let's figure out the other details.

    • NoScript was probably corrupted also. Go to Tools, Add-ons. Remove NoScript (so that all the messed up issues are cleaned), then go to https://addons.mozilla.org/en-US/firefox/addon/noscript/ and reinstall it.

    • To change how your navigation controls look, go to View, Toolbars, Customize. Then you can rearrange the controls or remove controls you don't want, including the search field and home/bookmarks.

    • In this version of TenFourFox, the reload and stop control is all one control: it's stop when something is loading, and reload when it's done.

  9. 9 Posted by tina holm on 02 Dec, 2013 11:24 AM

    tina holm's Avatar

    thanks, everything is now where it should be - I've stopped crying :-)

    and the noscript menu icon was available in the customize menu too, so no need to reinstall

    /tina

  10. Support Staff 10 Posted by Cameron Kaiser on 08 Dec, 2013 05:23 PM

    Cameron Kaiser's Avatar

    Great! I'll close this ticket; no further reply is necessary. If you need to re-open this ticket with new information, just reply and it will automatically re-open for you.

  11. Cameron Kaiser closed this discussion on 08 Dec, 2013 05:23 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac