17.0.11 Won't Play iTunes Movie Trailers Even with Plugins Enabled

David's Avatar

David

25 Nov, 2013 04:37 AM

Hello! I downloaded 17.0.11, enabled plugins, checked to make sure the QuickTime Plugin (7.6.4) showed-up under TFF's Plugins tab (which it did), restarted the machine, and even checked the Permissions. Unfortunately, on Apple's iTunes Movie Trailer site, none of the clips will play. All that appears is a black screen when the play-icon is selected. The site works fine with Safari 4.1.3 on the same machine. Any ideas would be appreciated. Thank you!

  1. Support Staff 1 Posted by Chris (chtrusch... on 25 Nov, 2013 08:13 AM

    Chris (chtrusch)'s Avatar

    David, we don't support plugins anymore. In 17 they still (sort of) work, but are disabled by default for security reasons. They won't work at all in future versions of the browser. If you enable plugins in TFF 17, you're on your own. See http://code.google.com/p/tenfourfox/wiki/PluginsNoLongerSupported

    Unofficially however, I can say that e.g. http://trailers.apple.com/trailers/lions_gate/thehungergamescatchin... plays for me in 17 after the plugin has been activated. As of 17.0.11 (or 17.0.10, not sure) Mozilla added a very reasonable security feature that makes the browser ask every time to activate a plugin unless you give permission to always activate the plugin on a per-site basis. "Click here to activate the plugin" doesn't work on the Apple site because there's a layer over it preventing the click to go through, but you can activate it in the URL bar. You can change permissions in the Page Info window (cmd+I) in the Permissions tab.

  2. 2 Posted by David on 25 Nov, 2013 06:16 PM

    David's Avatar

    Thanks, Chris, for the response!

  3. Chris (chtrusch) closed this discussion on 22 Dec, 2013 03:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac