Why is 10.0.9 so much slower than 10.0.7

SBoothby's Avatar

SBoothby

20 Oct, 2012 12:33 AM

I was having no problems with 10.0.7, but after being constantly pestered to upgrade, I did. Why is 10.0.9 SOOOOOO much SLOOOWER? Everything is is the same, but it takes forever to load the same things I had no problem with before. Can't I just go back to 10.0.7? What was the urgency about upgrading?

  1. Support Staff 1 Posted by Cameron Kaiser on 20 Oct, 2012 12:57 AM

    Cameron Kaiser's Avatar

    I don't have an explanation for you about the speed, other than to say that there were no changes made I am aware of that would affect performance, but the bug repaired by 10.0.9 was publicly released and can cause the browser to be exploited or leak data. For this reason it is imperative for people to update.

    If you like, you can try 17 beta and see if this is faster for you. Although it is a beta, it is generally safe for day to day use, and 17.0 will replace the TenFourFox 10 series in November. However, I would strongly advise against using any version of TenFourFox 10 before 10.0.9.

  2. 2 Posted by Jonathan on 23 Oct, 2012 11:27 PM

    Jonathan's Avatar

    I have found the same thing, actually. I don't have an explanation, but it is clearly slower (on a g4 1.5 ghz Powerbook with maxed RAM, 7450 build).

  3. Support Staff 3 Posted by Cameron Kaiser on 24 Oct, 2012 12:01 AM

    Cameron Kaiser's Avatar

    I'm going to need a benchmark or objective measurement before I can explore this further, and bear in mind with 17 around the corner, the most likely suggestion will still be to update when it becomes available. I can't reproduce any noticeable difference on my test units between 10.0.7, 10.0.8 and 10.0.9.

  4. 4 Posted by SBoothby on 24 Oct, 2012 12:18 AM

    SBoothby's Avatar

    I have 1.33 ghz G4 iBook/512mb RAM, also 7450 build. Yes this is ridiculously low RAM, but the point is I had no problems with 10.0.7. I really have no way of benchmarking, but I simply cannot load the same sites I was using before in any reasonable time. Am constantly force-quitting & relaunching.

    There is such an extreme difference that I wonder about 17, if your test units have shown no differences. I'm sure your test units have a lot more RAM.

  5. Support Staff 5 Posted by Cameron Kaiser on 24 Oct, 2012 12:24 AM

    Cameron Kaiser's Avatar

    They do. If the RAM ceiling is the issue, you're going to find that problem more and more. I'm considering not supporting any less than 1GB of RAM for 18+, for example, and 512MB is already a very tight fit for 10 and 17. None of the test systems here have less than 1.25GB. While I support 512MB systems still, I only support them insofar as to make sure they work. Performance is another story.

    The iBook you have can take up to 1.5GB (I have the same iBook, running 10.0.9 and 17 beta with a full RAM loadout) and a 1GB SO-DIMM for it will be around $50 well-spent.

  6. 6 Posted by SBoothby on 24 Oct, 2012 12:38 AM

    SBoothby's Avatar

    I have bought the RAM, just haven't gotten around to installing it yet (MUCH less than $50, btw.) But the reason people are using TenFourFox is that they are using older machines with less RAM. Why not take this into account with your upgrades?

  7. 7 Posted by Jonathan on 24 Oct, 2012 12:40 AM

    Jonathan's Avatar

    I have 1.25 gb of Ram on my 1.5 ghz Powerbook, however, and I have the same problem. This is also true for beta 17--slow, spinning disk, etc. What kind of benchmark data would you need?

  8. Support Staff 8 Posted by Cameron Kaiser on 24 Oct, 2012 12:43 AM

    Cameron Kaiser's Avatar

    Because the point of TenFourFox is to bring as modern a browser as possible to Power Macs, and that's going to require more memory to do so as we need to upgrade system libraries and compilers, as well as dealing with the rapidly growing Mozilla code base.

    When it gets to a point where more RAM is required than the majority of machines are capable of, then we'll have to have that discussion. But we're not to that point yet.

    Jonathan, I would accept a comparison between Dromaeo, SunSpider, V8 or Peacemaker on the relevant versions showing a statistically significant regression. But if you're seeing issues with 17 also, I really don't know what to tell you. My internal benchmarking shows 17's JavaScript is 10-20% faster than 10's, for example, so there is an obvious difference between your system and my test bank. (TenFourFox is tested routinely on four machines before release.)

  9. Support Staff 9 Posted by Cameron Kaiser on 24 Oct, 2012 12:44 AM

    Cameron Kaiser's Avatar

    (It also goes without saying that such tests should be done on clean profiles. Addons can unpredictably affect the browser, as well as cache and pref cruft.)

  10. 10 Posted by Jonathan Sadow on 24 Oct, 2012 12:48 AM

    Jonathan Sadow's Avatar

    Thanks--I will try to get around to it, then send you the data (if it
    shows a significant discrepancy).

  11. Support Staff 11 Posted by Chris (chtrusch... on 24 Oct, 2012 12:05 PM

    Chris (chtrusch)'s Avatar

    My benchmarks on a low-end machine (400 MHz G3/512 MB RAM) show no regression between TFF 10.0.8 and 10.0.9, and TFF 17 is considerably faster at pure JS. I haven't noticed a slowdown in real life.

  12. 12 Posted by SBoothby on 08 Nov, 2012 04:33 AM

    SBoothby's Avatar

    Actually, this is a new topic, but I am adding it here since I have a history with you.
    I installed 17beta and did not have any of the slowness, but it would quit often enough to be annoying. Haven't complained since it is beta. Then I installed my 1gb ram stick & a new battery & can't get my 1.33 ibook to start up. So I got out my older G4 ibook 1.2 which I haven't used for awhile. Installed 10.0.10 on it, but am getting gmail messages that I need to upgrade my browser to use gmail features. So I just tried to download 17 beta & get this message:

    /Users/sharonboothby/Desktop/V35LmCbO.zip.part could not be saved, because the source file could not be read.

    Try again later, or contact the server administrator.

    What does this mean?

  13. Support Staff 13 Posted by Cameron Kaiser on 08 Nov, 2012 05:05 AM

    Cameron Kaiser's Avatar

    It almost sounds like the temporary file used for the download got deleted before it was processed. Do you get that error every time you try to download it?

    I haven't had any reports of abnormal instability with 17 beta, but it sounds as if your iBook G4/1.33 has a hardware issue, unfortunately.

  14. 14 Posted by SharonB on 08 Nov, 2012 06:13 AM

    SharonB's Avatar

    I had tried it 3 times before I contacted you. I switched to Opera,
    which gives me all the features of Gmail, but was so slow I could not
    stand it. So I tried downloading your 17 beta again & it worked. No
    idea what was different. Anyway, why am I now unable to get all the
    features of Gmail? Had no problem on my other iBook but it was running
    10.5 and this one is 10.4.11. But the whole point of TenFourFox is to
    run on 10.4, right?

  15. Support Staff 15 Posted by Cameron Kaiser on 08 Nov, 2012 03:28 PM

    Cameron Kaiser's Avatar

    I replied to your other copy of this question, but for people tracking this ticket specifically, I have no explanation for why it would work one day and not the next. FTR, I'm logged into Gmail right now with the current 17 beta. It's not superfast on a G4, but it does work, so I can't replicate your issue here either.

    Are you positive this is the only application you're having trouble with? Opera is no speed demon, but it shouldn't be as slow as you describe either. It certainly isn't on my own iBook G4/1.33.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

04 Dec, 2019 04:47 PM
04 Dec, 2019 07:39 AM
22 Nov, 2019 03:13 AM
22 Nov, 2019 01:05 AM
20 Nov, 2019 11:12 PM