Unresponsive Script

Chris's Avatar

Chris

17 Oct, 2012 05:32 PM

This comment was split from the discussion: "Preferences" not working v 10.0.8

I have the same problem with my eMac which is a 800 MHz PowerPC G4 version 10.4.11. I get an unresponsive script banner across my browser controls and the page cannot be closed unless the browser is shut down. I thought this problem would be settled with the latest version, 10.0.9. Apparently it has not.

This usually occurs when browsing a page that continuously updates. Static pages such as eBay don't seem to have this problem.

It was recommended to me that I rewrite code (which goes beyond my knowledge of computers).

I highly recommend that the developers of TenFourFox utilize a dial up service to test their browsers as many rural areas do not have high speed internet access, if that's the cause of the problem.

At this time, I am considering trying out Camino, an alternative to TenFourFox.

Enclosed is a screenshot of the problem.

  1. Support Staff 1 Posted by Chris (chtrusch... on 17 Oct, 2012 05:42 PM

    Chris (chtrusch)'s Avatar

    Chris, your problem is, it seems, unrelated to the stuck preferences pane thread in which you posted, so I created a new discussion.

    Your problem with the unresponsive script message however is valid and affects many users. See here what you can do about it (turn off the warning):
    https://tenfourfox.tenderapp.com/discussions/problems/211-unrespons...

    Huffington Post is one of the most Javascript-heavy sites, so it will trigger the warning quite frequently. You should, however, be able to dismiss it, i.e. a "close" button should be visible. This doesn't seem to be the case with very long script urls, and I'll investigate whether this is Mozilla's bug or ours.

    I'm not sure whether dial-up is related to this. The script can only execute once it's fully loaded, but scripts that dynamically re-load stuff may be affected. This will also be mitigated by turning off the unresponsive script warning.

  2. Support Staff 2 Posted by Chris (chtrusch... on 17 Oct, 2012 06:33 PM

    Chris (chtrusch)'s Avatar

    Attached original screenshot with no close button in the warning dialog.

    It's Mozillas bug (604626, probably more), but nobody seems to be working at it.

  3. 3 Posted by Chris on 18 Oct, 2012 01:09 AM

    Chris's Avatar

    The warning has now been turned off. Your suggestion worked, but at the same time, pages seem to load much slower.

    Thanks for the suggestion. At least I don't have the banner problem anymore. Let's hope the problem will be resolved in future updates of TenFourFox.

    Take care.

  4. Support Staff 4 Posted by Cameron Kaiser on 18 Oct, 2012 02:06 PM

    Cameron Kaiser's Avatar

    The reason they load more slowly now is because your computer is now executing the code in full, without being prompted, so more JavaScript is actually being executed.

    I think what will help you even more is having your computer reduce the amount of data it must download. Do you use NoScript or AdBlock Plus? Both are Firefox add-ons which are compatible with TenFourFox, and would reduce the amount of JavaScript that executes and the amount of ad content that must load.

    As far as the oversized alert problem goes, we generally track Mozilla's updates and this is technically their bug to fix, but it does disproportionately affect the slower systems that run TenFourFox and I have repaired Mozilla bugs for them in the past because it also benefits us. I might add this to our list as we get spare cycles to work on issues at higher levels than TenFourFox itself.

  5. 5 Posted by vanilla on 29 Nov, 2012 03:25 AM

    vanilla's Avatar

    NoScript and AdBlock plus can be intrusive and hard-to-learn.

    For Dial-up, a simpler speed-up to try is to be sure you have flashblock installed:
    https://addons.mozilla.org/en-US/firefox/addon/flashblock/

    You also can temporarily get fast text-only browsing like so: under Content, I just un-check "Load images", and un-check "Enable Java script". I then google for whatever.

    Once I've found the pages where I want to see images and/or need to use java script, then re-check them, and reload the page.

  6. Support Staff 6 Posted by Cameron Kaiser on 29 Nov, 2012 04:06 PM

    Cameron Kaiser's Avatar

    Flashblock is indeed a good extension, but Flash and all plugins are disabled by default in TenFourFox anyway. If you turn them on with the undocumented switch, you are using TenFourFox in an unsupported state, and plugin code will stop working regardless in TenFourFox 18+ due to incompatible Mozilla changes.

    However, you also make an excellent point about image loading. This can be a major drain on a dial-up connection. Going to View > Page Style and selecting No Style will also turn off style-sheets, which may make the page easier to navigate without the images.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 May, 2019 09:09 AM
24 May, 2019 05:44 AM
23 May, 2019 06:26 PM
22 May, 2019 02:16 PM
21 May, 2019 02:11 AM