Italic display

tconsolo's Avatar


16 Jan, 2012 03:47 AM

In every version of TenFourFox I've used (5, 7, and now 9), italic fonts do not display correctly, particularly on Wikipedia. Anyone dealt with this already? This happens on multiple machines as well.

Showing page 2 out of 3. View the first page

  1. Support Staff 31 Posted by Chris (chtrusch... on 08 Feb, 2012 10:21 AM

    Chris (chtrusch)'s Avatar

    tconsolo – so on one machine, a clean profile fixes the bug (see comment 24), on the other one, it doesn't. This is very weird indeed, and I have to admit that given all the contradicting user reports about this issue (or: these related or unrelated issues), I'm now completely lost for answers.

    I guess the issue won't be fixable if we don't find the font(s) that don't play nicely with TenFourFox's text renderer. Since we can't reproduce the issue here, we still need someone who can and who takes the time to finde the font with the bisecting method.

  2. 32 Posted by tconsolo on 08 Feb, 2012 10:56 PM

    tconsolo's Avatar

    I don't know that this is useful information, but I'll offer it just in case: I just installed TFF 10 for G4/7450 on an old eMac running 10.4.11. It took over the profile from a Firefox 3.2.26 install. So far I've seen no problems.

  3. 33 Posted by tconsolo on 10 Feb, 2012 02:32 AM

    tconsolo's Avatar

    Follow-up: Just installed TFF 10 (G4/7400) on the Powerbook. The issue seems to be gone. So I guess I recommend upgrading to v10 for anyone else with this problem.

  4. 34 Posted by Mike on 10 Feb, 2012 04:29 AM

    Mike's Avatar

    Well, I just tried 10.0 on my G5...same issue. This is what the first page of this thread looks like.

  5. Support Staff 35 Posted by Chris (chtrusch... on 10 Feb, 2012 10:08 AM

    Chris (chtrusch)'s Avatar

    Mike, does the thread look the same with TFF 9.0 on your G5?

  6. 36 Posted by Mike on 11 Feb, 2012 03:00 AM

    Mike's Avatar


    It looks exactly the same in v9.0. Here is a screenshot of the page in version 9 of TFF.


  7. 37 Posted by Chris Jones on 11 Feb, 2012 03:16 AM

    Chris Jones's Avatar

    Tried the update and sadly its still the same..

  8. Support Staff 38 Posted by Chris (chtrusch... on 11 Feb, 2012 10:37 AM

    Chris (chtrusch)'s Avatar

    This will still be in TFF 20 if we don't find the offending font(s). :-(

    Mike, this looks bad, but as I said, there must be a font on your systems that isn't part of the original OS X installation that causes this. Can we try something? Go to
    and print->save as PDF both in TFF 10.0.1 and Safari 5.0.6 on your G5. The PDF files will be about 300-500 kb each. Attach them here. For reference what it should look like, here's my system's TFF and Safari outcome. Thanks!

  9. 39 Posted by Mike on 11 Feb, 2012 03:22 PM

    Mike's Avatar


    My G5 is running Tiger (v10.4.11) so v4.1.3 of Safari is the newest I can run. Attached is a PDF from Safari 4.1.3, TFF 9.0 and 10.0.1, Firefox 3.6.25, and finally one that may or may not be useful, Safari 5.0.3 from my MacBook Pro running Leopard. This machine cannot run TFF but as I mentioned in an earlier post, it has the same exact font set as the G5 and renders web type just fine in FF 9.0 and Safari 5. In case the PDF might yield any clues, I've included it in this post.


  10. 40 Posted by tobias.netzel on 11 Feb, 2012 04:43 PM

    tobias.netzel's Avatar


    your MacBook Pro can actually run TFF when you install Rosetta. You could give it a try!


  11. Support Staff 41 Posted by Chris (chtrusch... on 11 Feb, 2012 04:57 PM

    Chris (chtrusch)'s Avatar

    The FF3 and TFF9 pdfs are corrupt, but it doesn't matter because I'm not making any progress anyway. I'm completely at a loss. Thanks anyway for your effort, Mike.

    My last shot is to go to Preferences > Content > Fonts & Colors > Advanced and make sure it doesn't have any exotic settings there. Default is this (attachment).

    Otherwise it'll be bisecting to find the offending fonts.

  12. 42 Posted by Mike on 11 Feb, 2012 05:55 PM

    Mike's Avatar


    Don't know what happened to the files. Here are replacements although I understand completely that they may not help.

    On the pref settings, my settings are EXACTLY as shown in your screenshot (default settings).

    I may try bisecting my fonts at some point, but that will be a lengthy process and I'm short on time to devote to this right now.

    @Tobias, FF and Safari work great on my Intel MacBook Pro, as does Chrome if I want it and Opera if I'm so inclined. I see no advantage to running TFF under Rosetta under the circumstances, unless there is some advantage I am unaware of.

  13. Support Staff 43 Posted by Chris (chtrusch... on 11 Feb, 2012 08:49 PM

    Chris (chtrusch)'s Avatar

    Thanks, Mike. If you can find the time (doesn't have to be today or tomorrow), this might be our only chance to fix this bug (if it's fixable) – we ned a test case, viz. the offending font, to test this on our machines.

  14. Support Staff 44 Posted by Cameron Kaiser on 11 Feb, 2012 09:37 PM

    Cameron Kaiser's Avatar

    To answer the Rosetta question, what Tobias is suggesting is running TenFourFox on your 10.5/10.6 Intel system to see if the problem occurs there too. If it does not (and I doubt it will), then the problem is font or profile related. If it does occur there, then I'm absolutely out of ideas.

    However, one interesting thing about your Unicode pdfs is that the leading section of that page does appear correctly. So try changing the default font (under Preferences > Content) to Arial or Helvetica (the fonts that page is using) or any other font you want. You can do this and see if the page changes without having to close the window. If switching fonts works, you have your answer.

  15. 45 Posted by Mike on 12 Feb, 2012 03:24 PM

    Mike's Avatar


    No improvement if I set my default font to something else.

    I'll try bisecting my font library when I have time. Remodeling the house right now be awhile.


  16. Support Staff 46 Posted by Cameron Kaiser on 12 Feb, 2012 03:26 PM

    Cameron Kaiser's Avatar

    Even if you set it to Arial or Helvetica? That's the font that the page header is using and that displays normally.

  17. 47 Posted by Mike on 13 Feb, 2012 05:30 AM

    Mike's Avatar


    I misunderstood and only looked at THIS page (this TFF discussion thread) and there was no improvement in the issue regardless of the font I selected in the Preferences using TFF v10. However, I was able to get the Unicode sample page to display correctly using Arial and Times New Roman. PDF is attached using Arial. When I went back to Times, the pages looks like the first PDF I posted above. Unfortunately, it did nothing to this TFF discussion page. But maybe there is a clue here as to what is going on?

  18. 48 Posted by tobias.netzel on 13 Feb, 2012 06:59 AM

    tobias.netzel's Avatar

    @Mike: I actually thought of testing TFF on the MacBook just to see if you get the same problems there, too.

  19. Support Staff 49 Posted by Cameron Kaiser on 13 Feb, 2012 04:47 PM

    Cameron Kaiser's Avatar

    It means you definitely have iffy fonts: just good enough for ATSUI, but not quite enough for HarfBuzz. On the Tenderapp pages I suspect the CSS computed font on your system for this page is Helvetica (Inspect Element > Style will tell you, if you're interested). Try pulling Times and Helvetica out of your fonts folders (don't delete them, just move them), flushing the font cache and restarting. It will probably try to pick Arial, which I bet will work.

    The real question is how the fonts got altered, because on all my 10.4.11 systems, they're fine. Was this a Mac with a long update history? Was the OS simply updated, or did you ever do a clean install of an OS at some point? All of my systems had 10.4.11 installed "clean" -- they are not updates from, say, Jaguar.

  20. 50 Posted by Mike on 15 Feb, 2012 03:28 PM

    Mike's Avatar

    Okay, good news...sort of.

    Cameron nailed this one. I disabled my entire Helvetica and Times font families in FontBook and TFF works fine now with the sites I was previously having issues with. So then I re-enabled Times (leaving Helvetica off) and everything is still fine. Taking it a step farther, I disabled Times and enabled Helvetica and, bang, the problem re-appears. So Helvetica is definitely the issue.

    Exactly what is wrong, I have no idea. This is a problem for me since so many of the files I receive (remember, I do print/prepress work) contain some sort of Helvetica font so I have to have Helvetica running all the time. But at least I know where to focus my efforts. I may just try to reinstall the family and see if that takes care of it.

    As for my OS upgrades, I only run updaters with small incremental OS updates, such as 10.4.8 > 10.4.11. I never, ever install a major update over an older OS. I always do an "Archive and Install" when installing a new OS version which installs a clean OS. So I don't know how my Helvetica fonts got buggered but I'll look into it as soon as I can.

    Thanks to everyone, especially Cameron, for help with this. I hope it helps others down the road. For now, I'm going to go enjoy the TFF experience on my aging G5.

  21. 51 Posted by Mike on 15 Feb, 2012 03:45 PM

    Mike's Avatar

    Oops...spoke too soon. While perusing some of my regular sites, the problem cropped up again, mostly inside text boxes for typing messages and forum responses. It even happened in a text field on an eBay page where I was sending an invoice to a buyer and trying to type in a message to him. It was all those rectangles again. Obviously TFF does not like something in my Helvetica family, but there are other fonts it doesn't like either. Back to square one and back to FF v3.6 for now.

  22. Support Staff 52 Posted by Cameron Kaiser on 15 Feb, 2012 03:46 PM

    Cameron Kaiser's Avatar

    Glad to hear it's working, Mike! Chris Jones, does this help you at all?

    I might add a note about this to the FAQ.

  23. 53 Posted by Mike on 15 Feb, 2012 04:05 PM

    Mike's Avatar

    Oops...spoke too soon. Still seeing the issue on some sites, in particular in text fields for inputting text, including eBay and a forum I post to regularly. Just a bunch of little rectangles appear as I type.

    Obviously TFF has an issue with a font in my Helvetica family, but there are apparently additional font problems so I'm back to square one. So for now, it's back to FF 3.6. Bummer.

  24. 54 Posted by Chris Jones on 15 Feb, 2012 06:05 PM

    Chris Jones's Avatar

    No, I tried it but no joy

    Sent from my LG phone

    Mike <[email blocked]> wrote:


  25. 55 Posted by Chris Jones on 15 Feb, 2012 06:17 PM

    Chris Jones's Avatar

    I will try it when I have time and at my work machine.

    Thanks for you all working on this. I will let you all know

  26. 56 Posted by Chris Jones on 16 Feb, 2012 05:13 AM

    Chris Jones's Avatar

    I disabled Helvetica and Times and no joy.. I am also in Prepress and press
    in printing. I am trying to get this to work on a G5 10.5.8 machine.. But
    is not successful


  27. 57 Posted by Michael Breault on 02 May, 2012 06:27 PM

    Michael Breault's Avatar

    In TenFourFox preferences select the Content tab. Half way down that tab is the Fonts & Colors section. Click the Advanced button, and in the new window select your preferred fonts. I am using
    Proportional: Serif;
    Serif: Verdana;
    Monospace: DejaVu Sans Mono
    You can probably play with those, and last, uncheck Allow pages to choose their own fonts, instead of my selections above.
    Everything seems to be working on the sites that have been showing the empty boxes where text should be visible

    I am on a G4 Powerbook with 10.5.8

  28. Support Staff 58 Posted by Chris (chtrusch... on 17 Jul, 2012 10:39 PM

    Chris (chtrusch)'s Avatar

    I don't know anymore how far we've come resolving this issue, but I can finally reproduce it on

    TFF 10.0.x shows squares where the text should be (both 10.4 and 10.5, both G3 and G4 7450).
    TFF 14.0 shows no indication of text at all, which is even worse than 10.
    FF 12 on Windows has the text right.

    Changing fonts in the prefs doesn't help. The text is visible if View>Page Style is set to No Style.

    It does not happen on a completely fresh install of Mac OS X 10.4.11. However, I see the issue on all three of my Macs, which means I can now start looking for the offending font(s).

  29. Support Staff 59 Posted by Chris (chtrusch... on 18 Jul, 2012 02:39 AM

    Chris (chtrusch)'s Avatar

    The problem for my systems is the Myriad family, e.g. "Myriad" (Font Suitcase, 60 kb),
    "MyriaBol" (Postscript outline 36 kb), MyriaBolIta (Postscript outline 32 kb). If only Myriad is in Library/Fonts, the problem is solved for me. As soon as Myriad is accompagnied by one of its bold/italic variants, the problem re-occurs. All variants, but without Myriad itself, is also no problem. Restart of the Mac is required to empty the font cache.

  30. Support Staff 60 Posted by Cameron Kaiser on 18 Jul, 2012 03:25 AM

    Cameron Kaiser's Avatar

    Very interesting. I do not have Myriad Pro on my system, so the page appears normally to me.

    The problem is that I'm not sure I can solve this directly (Harfbuzz is not under my control, and Behdad may not want AAT weirdness in the codebase). However, if we have known fonts we repeatedly see are triggering this, I could write exceptions for them to use some other font. Then at least the page would be legible even if the typeface were wrong.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac