Italic display

tconsolo's Avatar


16 Jan, 2012 03:47 AM

In every version of TenFourFox I've used (5, 7, and now 9), italic fonts do not display correctly, particularly on Wikipedia. Anyone dealt with this already? This happens on multiple machines as well.

  1. Support Staff 1 Posted by Cameron Kaiser on 16 Jan, 2012 04:21 AM

    Cameron Kaiser's Avatar

    I'm sorry, I can't verify this. You might consider flushing your system's font caches as it looks like TenFourFox can't find equivalent characters. This is a small portion of how the page appears on my system.

  2. Cameron Kaiser closed this discussion on 16 Jan, 2012 04:21 AM.

  3. Cameron Kaiser re-opened this discussion on 16 Jan, 2012 04:21 AM

  4. 2 Posted by tconsolo on 16 Jan, 2012 05:20 AM

    tconsolo's Avatar

    Thanks. Good idea, but no change. If it matters, the pages have continued to display correctly in Safari and Firefox 3.6.

  5. Support Staff 3 Posted by Cameron Kaiser on 16 Jan, 2012 06:00 AM

    Cameron Kaiser's Avatar

    You might try a clean profile to make sure it's not an unusual font setting, though nothing in about:config should specifically affect italic. Short of that, I don't have any other suggestions for you, but I'll leave it open to see if anyone else has encountered the same problem.

  6. Support Staff 4 Posted by Chris (chtrusch... on 16 Jan, 2012 04:15 PM

    Chris (chtrusch)'s Avatar

    I can't reproduce it either and would also suggest testing with a clean Firefox profile.

    One thing that just came to my mind was a screenshot Dan Knight posted in december about a TFF font glitch (which I can't reproduce either, but we may have a more general problem):

  7. 5 Posted by tconsolo on 16 Jan, 2012 06:40 PM

    tconsolo's Avatar

    Well, that looks familiar. I get those characters as well.

  8. Support Staff 6 Posted by Chris (chtrusch... on 16 Jan, 2012 11:43 PM

    Chris (chtrusch)'s Avatar

    I have a 10.4.11 installation on an external FW drive (for diagnosis and troubleshooting) that's completely default (as it comes from the retail disk, plus all updates from Apple). I checked on this installation, and the problem does not occur. I need some hints how to reproduce this.

    tconsolo, can you please create a new OS X user account (for testing) in System Preferences > Accounts, log into the new account, start TenFourFox from the Applications folder and see if the problem on Wikipedia still occurs?

  9. 7 Posted by Chris Jones on 17 Jan, 2012 06:59 AM

    Chris Jones's Avatar

    just started using this but I also have the problem that had

  10. Support Staff 8 Posted by Cameron Kaiser on 17 Jan, 2012 02:18 PM

    Cameron Kaiser's Avatar

    On all of my 10.4.11 testing machines (450MHz G4, 1GHz iMac G4, 1.33GHz iBook G4 and quad G5), as well as my 10.5.8 Intel Mac mini in Rosetta, I can't reproduce any font glitches of this type. There has to be some change in your system(s) that accounts for it.

  11. 9 Posted by tconsolo on 18 Jan, 2012 06:31 PM

    tconsolo's Avatar

    I created a new test OS X account. The display glitch did not occur using it.

    FYI: The machines displaying the problem are a Lombard Powerbook with G4 upgrade and a stock Dual G4, both on 10.4.11.

  12. Support Staff 10 Posted by Chris (chtrusch... on 18 Jan, 2012 07:16 PM

    Chris (chtrusch)'s Avatar

    Exellent, thank you! This is actually a good thing because it means that the error isn't system wide. Now we need to figure out wheteher there is a problem in your (normal) OS X user account, or in your TenFourFox installation, which may help us to fix the bug (if it's fixable from our perspective).

    Can you do the following:

    • Quit TenFourFox.
    • In the Finder, navigate to Macintosh HD>Users>[your user name]>Library>Application Support>Firefox and drag the Firefox folder to the Desktop (this folder contains your TenFourFox user account with bookmarks etc).
    • Now start TFF. A new Firefox folder with a default profile will be created in Application Support. Try to reproduce the bug.
    • When you're done, quit TenFourFox and drag the Firefox folder from the Desktop back into Application Support, replacing the newly created test account folder. This will restore your old settings in TenFourFox.

    (If you're uncertain, backup the entire Application Support folder to an external disk first before you start the experiment.)

    Thanks for your assistance.

  13. 11 Posted by Chris Jones on 19 Jan, 2012 12:41 AM

    Chris Jones's Avatar

    I forgot to mention that my machine is Mac 10.5.8 with G5 dual PPC

    Chris J

  14. 12 Posted by Chris Jones on 19 Jan, 2012 12:41 AM

    Chris Jones's Avatar

    Thanks for the steps.. I did it exactly and its still a problem
    and even when try to reply back with it:

    According to the online discussion, you may be replying to another user on
    it instead of me. But I appreciate you looking at it.

    FYI, I am using a FONT Manager Suitcase Fusion version 12.1.17 if that


  15. 13 Posted by MIke on 19 Jan, 2012 10:02 PM

    MIke's Avatar

    I have the same issue. On some sites, text renders as little squares, including in text entry fields, as in a forum. It also renders some images as a string of little boxes with four numbers in each box like "0073" or "0050". This is a duocore 2.0 G5 running OS X Tiger 10.4.11. No issues in FF 3.6, Safari or Camino or with any browsers on my Intel MacBook Pro. Here's an example of a site as seen in TenFourFox v9.0 and correctly in Camino v2.1.


  16. Support Staff 14 Posted by Cameron Kaiser on 19 Jan, 2012 10:36 PM

    Cameron Kaiser's Avatar

    Mike, your bug seems different than the OP's bug, which is italic-only.

    The font renderer used in TenFourFox is HarfBuzz, not ATSUI, which is the renderer used in 10.4-compatible official Mozilla releases from Mozilla 1.9.2 (Camino 2.1/Firefox 3.6) and lower. It is entirely possible that iffy fonts that work okay in ATSUI do not work with HarfBuzz. This can't be changed; ATSUI is not suitable for the types of text run rendering required by Firefox 4+.

    We know from comment 10 that the base 10.4 font set does not do this, so I would investigate extra fonts that you may have installed. It is possible that one of them is faulty and is being picked up by TenFourFox to render in, which fails. Without having a clear way of reproducing this on the test systems, however, we'll need some detective work on the part of those affected.

  17. 15 Posted by MIke on 20 Jan, 2012 02:40 AM

    MIke's Avatar


    Thanks for the reply and info. I do a lot of graphic design work for print so yes, I have a lot of fonts and turning all of them except the default set just for browsing isn't practical. I do have all the original system fonts installed though so I don't know why the browser is trying to use some other font.

    Trying to troubleshoot which of the hundreds of fonts I have is causing the issue would be like looking for a needle in a haystack. I have the same exact set of fonts on my Intel MacBook Pro and as I mentioned, all the browsers I have on that machine work fine.

    I have no idea how to troubleshoot this so I guess I'll have to forego TenFourFox and leave my trusty G5 in the Internet dark ages. Oh well. It was worth a shot. Thanks.

  18. 16 Posted by Chris Jones on 20 Jan, 2012 02:50 AM

    Chris Jones's Avatar

    Hey, Cameron,

    I hear you,, sound like what i am doing. Also in Printing, both prepress and press. Have a G5 but alot is obsolete because of dropping the PPC Support. But maybe down the line, there will be a solution.

  19. Support Staff 17 Posted by Cameron Kaiser on 20 Jan, 2012 05:22 AM

    Cameron Kaiser's Avatar

    Your other option is to, as tconsolo did in comment 10, create a new user (you can keep your current one) and see if the problem happens there also.

    If it does not happen, but you are unwilling or unable to mess with your fonts to see what the problem is, you could simply use fast user switching and run TenFourFox in that unaffected account's desktop. This is not terribly convenient, but it would be better than nothing.

    For the record, the G5 I develop on has 542 fonts catalogued in Font Book, and the problem does not occur there. So there must be something in common amongst you three that isn't replicated in tconsolo's fresh account, or on chtrusch's or my systems.

  20. Support Staff 18 Posted by Chris (chtrusch... on 20 Jan, 2012 12:13 PM

    Chris (chtrusch)'s Avatar

    I have 875 fonts installed in the root library, zero fonts installed in the user library. There may be conflicts between fonts in those two libraries. If the problem doesn't occur in a fresh OS X user account, I would look at the (usually fewer) fonts in the user library first. Some products (Adobe, Microsoft) may also install fonts in different places.

  21. 19 Posted by Mike on 20 Jan, 2012 02:58 PM

    Mike's Avatar


    I forgot to mention in my last post that I did try a new user account but the same problem exists there as well. I have zero fonts in my user library. They are all in the system library. That is consistent with the problem following me regardless of which user logon I use. I manage fonts with FontBook, no third-party font management tools. I'm sure you are correct that it is a font issue but again, needle/haystack. ;-)

    If I find the time some day, I could do the old troubleshooting trick we used from the System 7 and below days, disable half your Control Panels, then the other half, and keep halving the halfs where the issue is until you narrow it down. Except instead of Control Panels, it will be fonts. Maybe some day when I have time.

    In the mean time I'm open to any other ideas.

    Thanks again.


  22. Support Staff 20 Posted by Chris (chtrusch... on 20 Jan, 2012 06:37 PM

    Chris (chtrusch)'s Avatar

    Mike, do you see any changes when you play around with Character Encodings (in the View menu)?

  23. 21 Posted by Mike on 20 Jan, 2012 09:08 PM

    Mike's Avatar


    I tried a number of encoding settings and the only change I could detect was one of the settings changed everything to Chinese. Other than that, nothing but boxes with all the other settings.

  24. Support Staff 22 Posted by Chris (chtrusch... on 21 Jan, 2012 05:18 PM

    Chris (chtrusch)'s Avatar

    To sum up what we have so far, this looks like a font issue. The troublesome fonts are not in the default installation of Mac OS X 10.5 and 10.4. Some users may have installed the additional fonts together with third party software in the root library, some in the user library, some elsewhere.

    So the next thing would indeed be the bisecting technique to find that (maybe just one) troublesome font. Mike, if you have all your fonts in one place, you would be the ideal person to do this. I'd be glad to do this myself, but since I can't reproduce the bug here, there's not much I can do in this respect. If you have the time, it would be of much help. There seem to be quite a few users affected by this.

  25. 23 Posted by tconsolo on 21 Jan, 2012 06:01 PM

    tconsolo's Avatar

    @chtrusch: The clean AppSupport Firefox folder did not create the display glitch. I'm a little surprised at this only because the problem exists identically on multiple machines. Could this have been caused by TFF inheriting an old Firefox account (those folders dates back to a FF 2 installation)?

    Just FYI, all the latop's fonts are in the main (not user) library, as are most of those on the Dual G4. If they were at fault, would the clean User/Lib/AppSupport/Firefox folder have fixed this?

  26. Support Staff 24 Posted by Chris (chtrusch... on 21 Jan, 2012 06:16 PM

    Chris (chtrusch)'s Avatar

    tconsolo, if a new FF profile in the same OS X user account fixes it for you, then you have a different problem which is probably not related to the installed fonts. It may well be an old setting from FF2. In this case I'd just take the 10 minutes time to export my bookmarks and add-on settings, note down custom browser settings and passwords (if applicable), start over with a new profile and reimport bookmarks etc.

  27. Support Staff 25 Posted by Cameron Kaiser on 21 Jan, 2012 06:18 PM

    Cameron Kaiser's Avatar

    I agree with Chris. Yes, the same fonts would be in both accounts. So this looks like a profile issue, and yes, old profiles definitely can corrupt TenFourFox -- this is even mentioned in the FAQ. They can trip up Firefox too.

    Mike and Chris Jones, please try creating a new profile (not a new OS X account). If you're not clear on this process, see

  28. 26 Posted by Chris Jones on 21 Jan, 2012 06:46 PM

    Chris Jones's Avatar

    Well, I did this earlier, but I tried it again. Same issue. What I had done, is (Since Im on a Mac) I went to user/Chris/Library/Application Support and dragged out Firefox folder, where the profiles were.

    Restarted TenFourfox but same. Should I had restarted Mac before starting TFF?

  29. 27 Posted by tobias.netzel on 21 Jan, 2012 10:24 PM

    tobias.netzel's Avatar

    While I don't think it's the problem here, I recommend to also try the G3 build when you get issues with wrong characters.

  30. 28 Posted by Chris J on 21 Jan, 2012 11:08 PM

    Chris J's Avatar

    Thanks but I just tried the G3 build and even trashed the profile and started anew and still having these issues

  31. 29 Posted by Mike on 22 Jan, 2012 02:13 PM

    Mike's Avatar


    I forced TenFourFox to create a new, blank profile by moving the FF folder from User > Library > Application Support then launching TenFourFox letting it create a new profile as Chris did above. It did that just fine, but it did nothing to mitigate the problem. It's the same whether I use my original profile or the newly created one.


  32. 30 Posted by tconsolo on 03 Feb, 2012 11:34 PM

    tconsolo's Avatar

    Update: On my other machine (on which I'm working for the first time in a few weeks), I created a new Firefox user account by removing the User/AppSupport/FF folder. No change -- still squares instead of italics in TFF 5 and TFF 7. This is a Dual G4 on 10.4.11.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac