BankID Personal

Olle Klein's Avatar

Olle Klein

01 Feb, 2012 06:05 PM

In Sweden and some other countries many banks use an authorization method called BankID which uses a small program "Personal" which is called from the web browser. For some reason it does not work in TFF from ver 6 up to 10 (it did work in ver 5). Also FF had this problem with ver 6 I think but they resolved it from ver 7 and it works fine in ver 8, 9 and 10.

Would be very fine if you could fix this.

To check you could go to the link
https://www.hoistspar.se/
and click on LOGGA IN (login) in the upper right corner.

I have attached two versions of the Personal program which needs to be installed (there is an uninstall menu item just in case)
ver 4.15 is for 10.4 Tiger and 4.18 is for 10.5 Leopard

Kind regards
Olle

  1. Support Staff 1 Posted by Chris (chtrusch... on 01 Feb, 2012 08:31 PM

    Chris (chtrusch)'s Avatar

    I installed Personal.app on a 10.4.11 test system. Clicking LOGGA IN results in a message

    „Du verkar inte ha Bank ID Säkerhetsprogram installerat eller så behöver den uppdateras“

    in TFF 4.0.3, 5.0 and 10.0, so it doesn't seem to work in any version. In Firefox 3.6.26 the Personal.app is indeed called and requests to authenticate.

    So far, so good. Cameron?

  2. 2 Posted by Olle Klein on 01 Feb, 2012 09:03 PM

    Olle Klein's Avatar

    Hello Chris,
    many thanks for the quick reply.
    I tried with the TFF 5.0 again and it worked for me, both the 7400 on a PowerMac G4 and the G5 on a PowerMac G5. Perhaps you did not have the Personal.app in the Applications folder when you tested TFF 5.0?
    Olle

  3. Support Staff 3 Posted by Chris (chtrusch... on 01 Feb, 2012 09:58 PM

    Chris (chtrusch)'s Avatar

    I had Personal.app in the Applications folder, and, as I said, it worked as expected with Firefox 3.6. Now we need to figure out why it doesn't work with some or all versions of TFF.

  4. Support Staff 4 Posted by Cameron Kaiser on 02 Feb, 2012 03:22 PM

    Cameron Kaiser's Avatar

    Personal installs a browser plugin, and TenFourFox does not support plugins. If you look under about:plugins in 3.6, you should see it installed.

    That said, the plugin does not appear to work correctly in 10.4Fx even with enabling forced on, and this may be due to plugin changes implemented by Mozilla (you already discovered this with Firefox). If you know of a fix in hand, I will consider implementing it, but in general because of this and other issues plugin problems are no longer accepted. Camino may be your best solution in this case.

  5. 5 Posted by Olof Klein on 02 Feb, 2012 06:43 PM

    Olof Klein's Avatar

    Hello Cameron,
    Thanks a lot for taking the time to look into this problem. Sorry I
    had not seen that Personal used a plug-in and that I had forgotten
    that 10.4Fx does not support plug-ins.

    I think I understand now what happened when Personal started to work
    again with Firefox. I guess both Firefox and Personal were updated to
    fix the problem. The latest version of Personal ver 4.18 works with
    Firefox 10, but it can not be installed (and does not work) on 10.4
    Tiger but does work on 10.5 Leopard both Intel and PowerPC so I tried
    10.4Fx ver 10 with enabled plug-ins, and surprise, it worked
    perfectly. So I can now use 10.4Fx with Personal on my PowerMac G5 and
    PowerBook G4 running 10.5 anyway.
    (Personal 4.15 which can be installed on 10.4 Tiger does not work with
    recent Firefox or 10.4Fx on any system)

    Perhaps you could consider enabling "safe" plug-ins by default and
    disable the rest rather than disabling all.
    Best regards
    Olle

  6. Support Staff 6 Posted by Cameron Kaiser on 03 Feb, 2012 05:34 AM

    Cameron Kaiser's Avatar

    I'm glad it is operating for you. Please reopen if there are further issues related to this.

  7. Cameron Kaiser closed this discussion on 03 Feb, 2012 05:34 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac