Error "400 Bad request - Your browser sent an invalid request." on some links

Geeji's Avatar

Geeji

03 Jul, 2012 08:06 AM

Some kind of links, such as this one :
"http://bigbrowser.blog.lemonde.fr/2012/07/02/une-seconde-ajoutee-au..." always lead to "400 Bad request - Your browser sent an invalid request.".
Curiously, the same links work perfectly on Safari 5.0.6 on the same machine.
Looks like a bug, but is there any workaround (outside of switching to Safari) ?

  1. Support Staff 1 Posted by Chris (chtrusch... on 03 Jul, 2012 08:31 AM

    Chris (chtrusch)'s Avatar

    Hello Geeji, I can't replicate this problem over here. Both TenFourFox 10.0.5 and 13.0 show the Article (TIC-TAC – Une seconde ajoutée au temps universel fait « planter » Mozilla et LinkedIn) without a problem. I could imagine that some extension interferes, so the first thing to identify the culprit is disabling Add-ons that try to protect your privacy, or re-starting TenFourFox with Add-ons disabled completely (in the Help menu). If that doesn't help, there's more we can try later.

  2. 2 Posted by Geeji on 03 Jul, 2012 09:32 AM

    Geeji's Avatar

    Thanks Chris for the super fast answer :-).
    I did restart with all extensions disabled (using the Help menu entry) and all add-ons explicitly disabled.
    No difference on http://bigbrowser.blog.lemonde.fr/2012/07/02/une-seconde-ajoutee-au-temps-universel-fait-planter-mozilla-et-linkedin/, still getting Error 400...
    ...BUT when I accessed a similar link NOT previously accessed before (and thus which did NOT failed before), it worked OK ! (some internal TenFourFox cache keeping the erronated information ?). So you are right, it is related to some of my extensions or add-ons.
    Note that this bug existed too on my previous version of FireFox, so it is not related to TenFourFox port.

    I will now start the cumbersome process of trying to isolate the culprit and will let you know.
    Thanks again

  3. Support Staff 3 Posted by Chris (chtrusch... on 03 Jul, 2012 10:04 AM

    Chris (chtrusch)'s Avatar

    It may well be a combination of extension and cache, but may also be just a cache issue. Try re-enabling the Add-ons and then Tools>Clear Recent History… Restart the browser and try again to load the problematic link.

  4. 4 Posted by Geeji on 03 Jul, 2012 10:34 AM

    Geeji's Avatar

    You nailed it Chris ! :-)
    I Cleared Recent History (except Preferences and Forms), and then reenabled all Extensions and Plugins.
    And now, all my links work properly ! :-)
    But the "bad link" [http://bigbrowser.blog.lemonde.fr/] in some cache must have been VERY persistent, since I had the problem for months before finding the time to report it.
    And it was even persistent through migration from Firefox to TenFourFox, since AFAIR I had the exact same problem on my old Firefox before migrating to TenFourFox 10.0.4.
    Thanks again Chris, great support !!

  5. Support Staff 5 Posted by Chris (chtrusch... on 03 Jul, 2012 11:13 AM

    Chris (chtrusch)'s Avatar

    Good to hear your problem is solved. TenFourFox uses the same user profile and cache folder as Firefox, because to the computer, it just is Firefox. To prevent this from happening again, you might want to set browser.cache.check_doc_frequency to 1 in about:config. This does not disable the disk cache in any way, but makes the browser check always if what's in the cache is actually what it's supposed to show. The default (3) means it checks "when the document has expired", but the strategy to determine this point in time has always been the weak spot in Mozilla's caching technology.

  6. 6 Posted by JJG on 03 Jul, 2012 11:26 AM

    JJG's Avatar

    Done, thanks again !

  7. Chris (chtrusch) closed this discussion on 16 Jul, 2012 07:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

21 Dec, 2014 05:07 PM
20 Dec, 2014 01:48 PM
19 Dec, 2014 08:15 PM
11 Dec, 2014 01:16 AM
07 Dec, 2014 11:40 AM