NEEDS TO GO "It looks like you haven't started...." banner running across the bottom of TFF 31

mozzz's Avatar

mozzz

27 Jul, 2014 02:49 AM

"It looks like you haven't started TenFourFox in a while. Do you want to clean it up for a fresh, like-new experience? And by the way, welcome back!" Includes a reset button.

As it keeps coming back on each reopen of TFF, this is very annoying. Especially as it wastes valuable screen space.

There is a close button, but I see no way to dismiss it permanently. How can this be permanently removed?

  1. Support Staff 1 Posted by Chris (chtrusch... on 27 Jul, 2014 05:31 AM

    Chris (chtrusch)'s Avatar

    Hello mozzz, please make sure first that your system time/computer clock is set correctly. If that doesn't fix it, you have encountered a Mozilla bug, i.e. an error in an intentional feature. As of now, there is no user-friendly solution I could recommend, I'm afraid. See here
    http://forums.mozillazine.org/viewtopic.php?f=38&t=2766881
    and here
    https://bugzilla.mozilla.org/show_bug.cgi?id=498181

  2. 2 Posted by mozzz on 27 Jul, 2014 01:08 PM

    mozzz's Avatar

    Thanks for the links. The suggestion in one of those to run touch (sudo touch for OSX) on the .parentlock file appears to be the fix. (No idea what the equivalent will be for Windows. Maybe just delete that file so a new one with the updated time will be created on the next restart?) Tried 3 or 4 TenFourFox restarts and it didn't come back. I think my date/time are correct, so I 'm hoping that I won't encounter this issue the next time I start up the old Mac.

    Still, I don't understand why this bug showed up only after installing the 31. I had just a few minutes earlier installed the 24.7.0 and didn't have this issue.

  3. Support Staff 3 Posted by Chris (chtrusch... on 27 Jul, 2014 06:54 PM

    Chris (chtrusch)'s Avatar

    Mozilla introduced this feature in Firefox 25, so we TenFourFox users see it for the first time now.

    Good to know that running touch on the culprit file helped, but I still wouldn't know what to tell people who don't know their way around in the Terminal.

  4. 4 Posted by mozzz on 27 Jul, 2014 08:40 PM

    mozzz's Avatar

    You would run the following command from an admin account only in Terminal (Mac.) Must observe case and spaces carefully.

    sudo touch ~/Library/Application\ Support/Firefox/Profiles/profilename.default/.parentlock

    (Formatting here is screwing with this command. No space here: profilename.default/.parentlock)

    (profile name will be something like 7kltxyz.default or xyzp3ppo.default)

    Hit enter/return and when prompted give the admin password, which won't appear in any form in the Terminal window--not even asterisks. Then hit enter/return again. Should get a new $sign prompt and then just close the window.

  5. Support Staff 5 Posted by Cameron Kaiser on 27 Jul, 2014 08:45 PM

    Cameron Kaiser's Avatar

    You shouldn't need the sudo part -- that would run that command as root, and you should already own that file. If you had to include it to get the command to work, somehow the permissions got screwed up, which may have been part of the problem in the first place.

  6. 6 Posted by mozzz on 27 Jul, 2014 08:49 PM

    mozzz's Avatar

    I ran it as sudo just as a matter of course. But yes, shouldn't be needed in this case.

  7. 7 Posted by Walter Ian Kaye on 06 Mar, 2015 03:59 AM

    Walter Ian Kaye's Avatar

    For me the path was ~Library/Firefox/Profiles/default/profilename.slt/.parentlock

    (And it seems to have worked; I just tried it.)

  8. 8 Posted by Ged on 02 Jun, 2015 11:00 PM

    Ged's Avatar

    I had this today - it started with Samucaya Dynamic Search Engine 5.0.2.1 and stopped when I disabled it.
    My interim attempt to clear it with touch pulled .parentlock out of the profile.default folder but failed to cure the problem.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • _.png 12.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac