Can't Downlaod Updates -- only get broken files

me1004's Avatar

me1004

24 May, 2014 04:45 PM

I have ALWAYS had trouble downloading any updates. So, I rarely even attempt to do so. As such, when I next bother to even try, I don't even remember how I managed to finally get it last time I managed to accomplish it.

I have just had serious aggravation again trying to download your latest update. In the end, I think I know where the issue is: In your browser. Please fix it. I identify the issue as your browser, because after fightng this for 1 1/2 hours, I finally thought of trying the URL in my old Safari 4.1.3 browser -- and from there, the download works perfectly! So, the issue is in your browser.

Again, the latest update does like it ALWAYS does from your browser: It downloads BROKEN. It comes in as a .zip and a second .part file. Neither will open, because it is broken. It does not seem to matter which mirror I use to download it -- but even managing to change the mirror is an ordeal, as you put us in a 5-second race to change to another page, read a long list and figure out which to click, then click and see nothing happen, then a message comes up saying basically to drop dead, the download is already underway from another mirror. But even when I manage to change the mirror, it makes no difference, the download still comes in broken. I DO NOT NEED THIS KIND OF AGGRAVATION!

I have zero other download problems from the Intrnet, no matter what browser I use. I have ZERO other problems with .zip files.

I have been trying to download using your browser. I am using Mac OS X 10.4.11, on a G4. My machine takes the 7450 (G4E) browser.

You need to change your download process, put in one that actually works -- which I guess means to fix your browser, or at least the 7459 (G4E) version. And allow us to change mirrors without having to race against a 5-second countdown.

  1. Support Staff 1 Posted by Chris (chtrusch... on 24 May, 2014 06:05 PM

    Chris (chtrusch)'s Avatar

    Okay, I see multiple issues, some of which I can confirm but can't change, some I can't even confirm. But let's start.

    1) Downloads don't work in TenFourFox, but do work in Safari. Can you describe what happens when you use TenFourFox to download? Do you get some kind of error message? What I can confirm is that Sourceforge downloads sometime terminate before the file is downloaded completely (their service is free, so we can't really complain), but I see no difference in the browser I use. I can definitely not reproduce what you're seeing, viz. that Safari always works, and TenFourFox never.

    2) Mirror changing problems: This is Sourceforge's business, not ours. I know the site is a hassle, but I would prefer not being SCREAMED at for of something I'm not responsible for. If you know a good alternative to host our files, please share. We aren't aware of one at the moment.

    3) Downloading process in TenFourFox. We're Firefox in this respect, i.e. we use the same code. If you think there's something broken, please file a bug at https://bugzilla.mozilla.org.

    I think the main problem is 1). Since I can't reproduce it as you describe it, I don't really know what to do. I just test-downloaded 24.5.0 7450 and it completed in under 40 seconds. If you only have problems downloading our updates, and Safari always works here, why not just use Safari for this purpose as a workaround?

  2. 2 Posted by me1004 on 24 May, 2014 06:40 PM

    me1004's Avatar

    No, I don't get any error message at the time of download. A few minutes or 5 minutes later, out of nowhere an error message appears:

    Download Error
    /Users/(home)/Desktop/TenFourFox7450-24.5.0.app.zip.part could not be saved, because the source file could not be read. Try again later, or contact the server administrator.

    The broken file names I get are:

    •TenFourFox7450-24.5.0.app.zip.part

    •TenFourFox7450-24.5.0.app.zip

    They are supposed to be about 32 MB in size. They are not. The .part one is 1.1 MB, and the .zip one is 0 MB.

  3. 3 Posted by me1004 on 24 May, 2014 07:00 PM

    me1004's Avatar

    I just discovered something important, I think. I had put a previous effort at downloading it in a folder. I just checked the size of those two files. The one ending in .part was the full 32 MB in size.

    Of course, it will not open, not ending in .part So, I tried taking off the .part, leaving it ending is .zip.

    With that, it now expands, and I get the browser out, at 100.2 MB in size! I have opened it, and gone to a Website,and it seems to work.

    So, it still should not come down as two parts. But the one that comes down ending in .part should not end with that extension. Of course, I can't tell is some small thing is left out of the .part file,but it does open and get on the Web.

    I note, when this downloads it simply appears pretty much instantly on my desktop (I download to my desktop), with nothing in the download window indicating it is still downloading, looking as if it is all done. At 32 MB, it should take longer. So, that is a related issue, that the download window has to show it is still downloading, if it is.

  4. Support Staff 4 Posted by Chris (chtrusch... on 24 May, 2014 08:42 PM

    Chris (chtrusch)'s Avatar

    Thanks for the additional information. If there's still a .part file, the download wasn't complete (at least for the browser, it may have timed out just the moment when the last bits were transferred).

    If the download appears instantly on your desktop, it was cached somewhere, but I can't say where. Maybe in a Firefox cache, maybe on a local server, e.g. if you're on a corporate or university network that caches big files and serves them locally via ethernet.

  5. 5 Posted by me1004 on 24 May, 2014 09:36 PM

    me1004's Avatar

    That's hard to believe. This happened exactly the same every time at least 10 different times. And did not happen at all in safari. This has happened every time I have tried to download an update ever since I first got TenFourFox a year or more ago. It can't stop at the exact same spot every time for eons but only when using that one browser.

    I told about the .part file since my first post.

    What I got out of the .part file is 98,597,859 bytes. Is that all of it?

    I am suspecting that there might be something wrong in the browser about combining the .part file in the .zipf ile. That mighty be the last step, and the browser just doesn't do it. Thus, all the download is left in the .part file

    This is from home, not off some corporate server in the middle.

  6. Support Staff 6 Posted by Cameron Kaiser on 24 May, 2014 09:44 PM

    Cameron Kaiser's Avatar

    I can't reproduce this problem either. For the record, I intentionally download updates to my test iBook G4 from SourceForge too, not locally, so it should be testing the same path you're using unless there is something local on your side yet to be accounted for. Keep in mind that Safari and TenFourFox have substantially different network code under the hood.

  7. 7 Posted by me1004 on 24 May, 2014 11:23 PM

    me1004's Avatar

    Well, how many bites should that version be, 7450 (G4E)? If I got the correct number of bites out of the .part file, then that would seem to suggest the idea that the .part file stopped before finishing the download is not correct. As I said above, I got 98,597,859 bytes for the final app.

    Re a different network code for Safari and TenFourFox, while I don't know the tech stuff about that, that is why I noted that it works in Safari, but not TenFourFox ever. But perhaps that difference in network code might point to the problem.

    If this were a one-time problem, I would write it off as such. But as I keep saying, this has been the issue ever since I first got TenFourFox more than a year ago. And it is limited to downloading with this browser (I think the only thing I have downloaded with this browser is the updates).

    I have no idea why you guys cant replicate it. But a bit more info, I'm on a G4 Quicksliver tower, 933 MHz. I doubt that helps, but now you know. My setup here is pretty straight forward, just WiFi to modem WEP to Internet. I can't think of anything else local here that would be in the path. Oh, my WiFi reception is via internal Airport card.

    I did try two or three different mirrors, but the same thing happened.

  8. Support Staff 8 Posted by Cameron Kaiser on 24 May, 2014 11:35 PM

    Cameron Kaiser's Avatar

    The correct size of 24.5.0 for 7450 is indeed 98,597,859 bytes. The normal download process is to download to a temporary file (the .part file you found), and then to rename it to the final name when the process is complete. It's doubtful that the file system code is to blame, because that would be quite easy to reproduce on any system. More likely, the download code is not getting the signal from the network that the download is complete and it times out and closes the connection, but because the download connection closed abnormally, it does not treat the .part file as valid. I don't know how to solve this for you. None of the test systems show any such issue, both inside my local network and on my external WiFi.

    If you're not running any proxies or network tools (Little Snitch has been implicated on some systems) that would change your network settings, then I don't have any other suggestions for you to look. However, without any way to reproduce it locally, I obviously won't be able to fix it.

    I would like to make a response to your original post, though: you're clearly upset with the download system. That's fine; I don't care much for SourceForge either, but the main reason we're using it is that it has no limit on storage and it doesn't cost anything. Given that I spend close to $600/mo on Floodgap.com for hosting and operations, free for a project that consumes a large amount of my time is non-negotiable. I'm sorry you don't like it, but it's the way it is, and unless something substantially better comes along, that's what we'll be using.

    If this is a problem for you, as politely as I can put it, you haven't paid us anything, the upkeep of what does run around here comes directly out of my pocket, everyone who works on this is volunteer, and you aren't obligated to use this software. It seems Safari is doing the job for you so far and that may save you a lot of aggravation.

  9. 9 Posted by me1004 on 24 May, 2014 11:45 PM

    me1004's Avatar

    I'm not using Little Snitch or any other such app.

    So, you're saying I got the entire download in the .part. It did create the actual.zip file, but it did not put .part into.zip, so I had two files, the .zip with nothing in it. Does the fact that it crated the .zip file mean it got the signal you are referring to? If so, is the issue then something clashing on my side with your browser -- and its not Little Snitch or other such app? I will say, I do have X11 and Macports installed on my computer. I can't think of anything else I have worth mentioning.

  10. Support Staff 10 Posted by Cameron Kaiser on 24 May, 2014 11:50 PM

    Cameron Kaiser's Avatar

    The .zip file (or whatever the final filename is) is created with length 0 when the download begins so that the final filename is reserved. It is replaced by the .part file at the end.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac